Versandkostenfrei

Mir ist aufgefallen, dass Artikel, welche als versandkostenfrei markiert sind, grundsätzlich keine Versandkosten berechnen. In Shopware 5 hatten wir den Zusatz „Versandkostenfrei in Deutschland“. Es ist ja gut, dass für Deutschland bei Shopkunden keine Versandkosten berechnet werden, bei Händlern wiederum macht es keinen Sinn. Ist dies auch schon jemandem aufgefallen oder haben wir etwas falsch konfiguriert?

nein, es ist so, wie du beschreibst.

Ich hab das mit verschiedenen Rules und Preismatrix beim Versanddienstleister gelöst,

Okay, danke, vielleicht besteht ja noch die Hoffnung, dass dies geändert wird. Könntest du bitte mal ein Beispiel anführen?

kann ich gerne machen, dazu bräuchte ich aber nähere Angaben, z.B.
handelt es sich um einzelne Artikel oder
alle Artikel einer Kategorie oder
Artikel mit Streichpreis oder im Abverkauf
gibt es einen Wert für versandkostenfreie Lieferung für Endverbraucher
gibt es einen für Händler
usw

je größer der gemeinsame Nenner, desto einfacher

Es betrifft alle Artikel, für Endkunden kostenlos, für Händler aber erst ab 200€.

ok, das ist verhältnismäßig einfach.

Bei den Einstellungen -> Kundengruppen 2 Gruppen anlegen:
Standardhändler, Standardkunde

Beim Rule-Builder neue Rules anlegen:
Alle Endverbraucher - Kundengruppe . ist eine von . Standardkunde
Alle Händler: Kundengruppe . ist eine von. Standardhändler

Bei Versand:
Lieferdienst(e) auswählen und neue Preismatrix anlegen:
Alle Endverbraucher: Warenkorbwert von 1 bis … Brutto 0 Netto 0
Alle Händler: Warenkorbwert von
1 bis 199.99 Brutto 0 Netto 5,85 (oder was auch immer du verlangst)
200 bis … Brutto 0 Netto 0

Es gibt natürlich unterschiedliche herangehensweisen
 

Okay, das hatte ich soweit auch umgesetzt, mir ging es aber darum, dass ich trotzdem „versandkostenfrei“ im Artikel aktivieren kann, ist das möglich?

nein

edit:
du möchtest die Anzeige Versandkostenfrei beim Produkt angezeigt haben, denke ich mal.
da müsste man wahrscheinlich was im Template modifizieren.

Bei aktiviertem Versankostenfrei im Backend überlaert das alle anderen Rules, zumindest bei allem, was ich probiert habe.
Eigentlich nicht wirklich zu Ende gedacht diese Funktion

Ja, genau, zumal es in Shopware 5 nicht so war. 

Noch was anderes, den Tracking Link, den ich hier hinterlege, sollte der nicht im Kundenkonto unter Tracking den entsprechenden Link öffnen? Macht er bei mir nämlich irgendwie noch nicht.

dir Link bei DHL müsste sein: 

https://www.dhl.de/de/privatkunden/pakete-empfangen/verfolgen.html?piececode=%s

Ja genau, so habe ich den drin, ich werde das mal weiter beobachten.

kannst auch das hier probieren:

https://www.dhl.de/de/privatkunden/pakete-empfangen/verfolgen.html?lang=de&idc=%s

Ich bin gerade noch ein wenig am Tüftlen und auf ein kleines Problem gestoßen (wahrscheinlich aber nur eine Einstellungssache). Wenn ich im Shop unterwegs bin und beispielsweise eine deutsche Adresse hinterlegt habe, lege ich etwas in den Warenkorb und es wird richtigerweise Versand Deutschland ausgewählt. Wechsele ich dann das Land, zeigt das Auswahlfeld im Warenkorb auch nur noch Versand Ausland an, darüber erscheint aber immer noch Versand Deutschland mit der Meldung "Die Versandart “Versand Deutschland” ist für Ihren aktuellen Warenkorb gesperrt. Wie kann ich dieses Problem umgehen?

Aktuell wird die Versandart nicht automatisch gewechselt, deswegen gibt es den Hinweis. Der Kunde muss also manuell wechseln.

Ich habe dazu schon ein Ticket aufgemacht und denke wir werden das auch in absehbarer Zeit lösen.

1 Like

[@Moritz Naczenski](http://forum.shopware.com/profile/14574/Moritz Naczenski “Moritz Naczenski”)‍ Alles klar, danke, dann weiß ich Bescheid. Ist die Tatsache, dass die Option “versandkostenfrei” beim Produkt alle anderen Regeln überschreibt so gewollt oder wird das eventuell auch noch geändert?

Das ist erstmal so gewollt, sollte aber mitlerweile so funktionieren, dass es nur „versandkostenfrei“ ist, wenn auch alle Produkte im Warenkorb versandkostenfrei sind.

Ich möchte, dass z.B. die Artikel ab 100€ versandkostenfrei sind, würde dann quasi den Haken immer bei versandkostenfrei setzen wollen und den Text in versandkostenfrei ab 100€ umbenennen und genau hier liegt dann eben das Problem, dass auch bei Artikeln unter 100€ keine Versandkosten berechnet werden, zumindest, wenn es sich ausschließlich um versandkostenfreie Artikel handelt.

Hallo ich hätte es gerne so wie hier geschrieben (Das wenn ich ein Artikel in den Warenkorb lege der Versandkosten frei ist das alle Artikel im Warenkorb Versandkosten frei werden) wie kann ich das ändern ?
ich habe schon ein paar regeln erstellt aber das habe ich noch nicht hinbekommen.

Das ist erstmal so gewollt, sollte aber mitlerweile so funktionieren, dass es nur „versandkostenfrei“ ist, wenn auch alle Produkte im Warenkorb versandkostenfrei sind.

Hallo Moritz,
ich habe mir jetzt frisch die 6.4 installiert.
Wenn ein Artikel die Markierung „versandkostenfrei“ hat, werden im Misch-Warenkorb weiter die Versandkosten auf 0 gesetzt. Was mache ich falsch? :wink:

Edit:
Muss ich nicht verstehen: Nehme ich den Standardversand, werden die Versandkosten 0 wie oben beschrieben. Lege ich mir eine eigene neue Versandart an, und konfiguriere sie so wie den Standardversand, werden Versandkosten berechnet, sobald ein Artikel nicht versandkostenfrei ist - also so, wie ich es gerne hätte. Wie kann so ein inkonsistentes Verhalten mit vermeindlich gleichen Einstellungen entstehen?