Shopware langsam - DomainFactory Professional - Was tun?

Hallo,

wir hosten bei DomainFactory mit ManagedHosting Professional. Das Paket hat 4/6 Punkte bei Performance. Der Shop ist aber sehr langsam.

Wir haben unter 100 Artikel und nur 5 Kategorien, auch sonst keine großen Inhalte. Der Shop ist neu.

Wir befinden uns im Produktivmodus mit aufgewärmtem Cache.

trotzdem haben wir Ladezeiten beim Seitenwechsel von einigen Sekunden… an was kann das denn liegen? 

Das ist nicht der einzige Shop den wir betreuen auf verschiedenen Hostings. Aber es ist definitiv der langsamste… liegt das an DF? Kennt sich da jemand aus?

Hallo,

kann an vielen Dingen liegen.

Haste die Systemkonfigurationen angepasst? Einstellungen -> Theme Manager -> Einstellungen

Neuladen der Textbausteine erzwingen = deaktiviert
Compiler Caching deaktivieren = deaktiviert
CSS Source Map erstellen = deaktiviert
CSS komprimieren = deaktiviert
JavaScript komprimieren = deaktiviert

Ansonsten lass mal https://gtmetrix. drüber laufen.

angeblich haben wir diesen Score bei GTmetrix

also “angeblich” ziemlich OK … fühlt sich aber nicht so an als User

Oben steht doch schon: APCu und Zend wäre ideal: kann dir DomainFactory einrichten. Bei diesem Anbieter sind wir auch.

Gerade auch getestet: PageSpeed Score C 74%, YSlow Score C 74%. Wir haben eine relativ hohe Conversion Rate und sind gut bei Google gerankt. Also trotzdessen läuft es gut.

PHP Version? Aktuell kannst du bei Shopware auf PHP 7.2 gehen, wenn du keine verschlüsselten plugins mehr hast.

ok ich stelle mal eine Serviceanfrage an DF wegen APCu und Zend. Danke für den Hinweis!

nur mal eine blöde Frage… was genau bewirken APCu und Zend?

Auf englisch: Shopware 5 performance guide for system administrators

leider erhalten wir jetzt Fehler

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 272

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 275

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 281

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 287

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 296

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 314

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 319

Fatal error: Uncaught RuntimeException: Cannot send headers; headers already sent in /vendor/zendframework/zend-code/src/Reflection/MethodReflection.php, line 272 in /engine/Library/Enlight/Controller/Response/ResponseHttp.php:373 Stack trace: #0 /engine/Library/Enlight/Controller/Response/ResponseHttp.php(203): Enlight_Controller_Response_ResponseHttp->canSendHeaders(true) #1 /engine/Shopware/Controllers/Widgets/Index.php(35): Enlight_Controller_Response_ResponseHttp->setHeader('x-robots', 'noindex') #2 /engine/Library/Enlight/Controller/Action.php(183): Shopware_Controllers_Widgets_Index->preDispatch() #3 /engine/Library/Enlight/Controller/Dispatcher/Default.php(563): Enlight_Controller_Action->dispatch('shopMenuAction') #4 /engine/Library/Enlight/Template/Plugins/function.action.php(102): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_Reque in /engine/Library/Enlight/Controller/Response/ResponseHttp.php on line 373

 

EDIT:

die Fehler sind mittlerweile verschwunden… haben sich aufgelöst. War wohl ein Cachingproblem oder so…?

Moin moin, hat DF jetzt einfach so auf Anfage bei dir APCu und Zend aktiviert?

Hab gelesen das es nur für dedizierten Servern verfügbar wäre wozu „ManagedHosting Pro“ nicht gehört … 

https://www.df.eu/de/support/df-faq/webhosting/weitere-technische-faq/fastcgi/

Also APCU und Opcache sind ein muss - einfach weil häufig verwendete Dateien dann deutlich schneller abgerufen werden können.

Darüber hinaus hast du die Komprimierung von CSS und JS in deinem Screenshot deaktiviert. Hat das irgendeinen tieferen Sinn?

Hallo @WOLLkenSchaf‍,

ja haben sie getan, hat keine 15min gedauert nach Anfrage

1 Like