Shop geht nicht mehr

Hallo, habe ein riesen Problem. Mein Shop läuft seit Dezember ohne Probleme. Nun hat mein Hoster sein PHP von 5.2 auf 5.3 geändert. Seit dem geht mein Shop nicht mehr. Ich hab dann ein paar mal mit denen telefoniert. PHP5.2 wird auch in der .htacess erzwungen Nur irgendwie funktioniert alles nicht. Die momentane Fehlermeldung lautet: Fatal error: Corrupted encoded data detected in /home/w13469/web/public_html/engine/Shopware/Plugins/Default/Core/System/Bootstrap.php on line 0 Kann mir jemand von euch weiterhelfen??? schon mal danke im vorraus Gruß

Hi, dann hast du damals bestimmt Shopware mit Zend Optimizer installiert?! Unter PHP 5.3 gibt es den Zend Optimizer nicht mehr. Die Meldung deutet nämlich darauf hin, dass die Dateien nicht entschlüsselt werden können. Sprech mal den Provider an, ob er unter PHP 5.3 den IonCube Loader installieren kann. Dann kannst du die Dateien aus unserem IonCube Package drüber kopieren und der Shop läuft wie vorher! PS: bitte vorher von allem ein Backup anlegen.

1 Like

Danke für die schnelle Antwort. Muß ich den shop dann neu installieren oder wie ist das gemeint? Sry für die Frage, aber ich mach sowas nicht jeden Tag. :wink: Gruß

Wäre klasse wenn das mal genau erklärt würde, da ja (wie es sich anhört) zwangsläufig jeder früher oder später von Zend zu IonCube wechseln muss.

Leider. Auch Profihost hat schon eine Mail rausgeschickt das demnächst Zend Optimizer nicht mehr angeboten wird. Grund sind Veränderungen des php Beschleunigers eAccelerator auf APC. Da dieses zu Stabilitätsproblemen führt kann. Gruß Kay

Keiner mehr da, der helfen kann? Laut den anderen, die hier geantwortet haben, könnte es die nächste Zeit mehr solche Fragen zu dem Thema geben. Gruß

Guten Morgen Leute, ich möchte meinen Shop heute von Zend auf IonCube umstellen. Wie muß ich da vorgehen, ohne alle Daten wie Artikel, Kategorien usw. zu verlieren. Würde mich über eine Antwort freuen, da mein Shop seit letzten Freitag nicht mehr funktioniert. Gruß Sven

Hallo, ich arbeite seit Wochen an meinem neuen Webshop, ich hatte auch den Zend-Installer gewählt. Wenn ich nun solche Meldungen lese macht mich das schon nervös das jetzt schon feststeht das mein Shop irgendwann nicht mehr funktionieren soll wenn mein Provider sein System aktualisiert. Wieso kommt überhaupt die Frage nach der Wahl des Installers wenn eine davon offensichtlich veraltet oder nicht mehr gewünscht ist? Was bedeutet das für mich, kann ich meinen Shop nun vor der Online-Stellung irgendwie ändern, aktualisieren oder was auch immer? Geschieht das vielleicht sowieso mit dem nächsten Update auf 3.5.4? Über eine Aufklärung würde ich mich freuen. Wann kommt eigentlich das 3.5.4 Update?

Die Aktualisierung ist eigentlich ganz einfach… Man lädt das Installationspackage Ioncube Shopware 3.5.3 herunter (http://www.shopware.de/install/files/350i.tar.gz) und kopiert alle Dateien aus dem Ordner /engine/ per FTP in den Document-Root des Shop-Servers. Dort also einfach das bestehende /engine/ Verzeichnis überschreiben. [quote] Wenn ich nun solche Meldungen lese macht mich das schon nervös das jetzt schon feststeht das mein Shop irgendwann nicht mehr funktionieren soll wenn mein Provider sein System aktualisiert. Wieso kommt überhaupt die Frage nach der Wahl des Installers wenn eine davon offensichtlich veraltet oder nicht mehr gewünscht ist? [/quote] Nicht alle Provider stellen Ioncube bereit - deshalb bieten wir derzeit noch 2 Versionen an, um möglichst viele Hoster zu unterstützen. [quote] Wann kommt eigentlich das 3.5.4 Update? [/quote] Voraussichtlich Ende Mai!

1 Like

Danke für die schnelle Info, dann werde ich das in Kürze so wie beschrieben durchführen, wenn seitens des Providers möglich. Vielen Dank!

Hi, sorry, wenn Euch die Frage blöd erscheint, aber wie kann ich erkennen, ob ich mit Zend-Optimizer installiert habe, weiss ich nämlich nicht mehr. Kann ich Ioncube sofort installieren, oder warte ich bis mein Provider „profihost“ am 17.05.11 den neuen PHP-Beschleuniger APC aktiviert. Gruß Peter

[quote=“Stefan Hamann”]Die Aktualisierung ist eigentlich ganz einfach… Man lädt das Installationspackage Ioncube Shopware 3.5.3 herunter (http://www.shopware.de/install/files/350i.tar.gz) und kopiert alle Dateien aus dem Ordner /engine/ per FTP in den Document-Root des Shop-Servers. Dort also einfach das bestehende /engine/ Verzeichnis überschreiben.[/quote] So habe jetzt alle Dateien aus dem Ordner überschrieben. Es hat funktioniert. Mein Shop läuft wieder: :slight_smile: Muß auch mal dazu sagen, das mein Provider alles für mich getan hat, das mein Shop läuft und das immer ohne zusätzliche Kosten. :wink: Vielen Dank an die Shopware-Mitarbeiter. Gruß Sven P.S: Vielleicht sollte man das in die Wiki aufnehmen, falls der nächste Provider sein PHP von 5.2 auf 5.3 ändert.

@Hobbyladen Bei welchem Provider bist du denn? @Mueslidepot Ich habe die eMail von Profihost so verstanden, dass die Migration automatisch laufen soll. Also das Shopware selbst dann standardmäßig weiterhin im 5.2 Modus läuft. Ich frage da aber nochmal explizit nach

1 Like

[quote=“Stefan Hamann”]@Hobbyladen Bei welchem Provider bist du denn? [/quote] Ich bin bei http://host4free.de/ und habe das 4Profi Paket für 2,-/Monat. Ich denke mal, das das nicht teuer ist :wink: Gruß

[quote=“Stefan Hamann”]@Hobbyladen Bei welchem Provider bist du denn? @Mueslidepot Ich habe die eMail von Profihost so verstanden, dass die Migration automatisch laufen soll. Also das Shopware selbst dann standardmäßig weiterhin im 5.2 Modus läuft. Ich frage da aber nochmal explizit nach[/quote] Hi Stefan, beim arbeiten an einer Shopseite stelle ich fest, dass beim Speichern der Seite aus dem html-Editor Code-Müll erzeugt wird. Sieht dann so aus:

Und bei jedem Speichern entsteht mehr Müll. Kann das mit der Umstellung bei Profihost zu tun hat? Viele Grüße Peter

Wir haben jetzt im mom. den Salat. Bei uns geht das backend nicht mehr… durch die Profihost umstellung…

[quote=“ttmedia”]Wir haben jetzt im mom. den Salat. Bei uns geht das backend nicht mehr… durch die Profihost umstellung…[/quote] Aber Profihost hat doch Wochen vor der Umstellung bereits eine Mail rausgesendet und auf die Umstellung hingewiesen. Hätte man nicht eher reagieren können?

[quote=“schlumpbergercom”][quote=“ttmedia”]Wir haben jetzt im mom. den Salat. Bei uns geht das backend nicht mehr… durch die Profihost umstellung…[/quote] Aber Profihost hat doch Wochen vor der Umstellung bereits eine Mail rausgesendet und auf die Umstellung hingewiesen. Hätte man nicht eher reagieren können?[/quote] Hi, das Thema haben wir ja schon Anfang Mai angesprochen. Geht aber scheinbar doch nicht so “reibungslos”. Stefans letzter Hinweis war: “Ich habe die eMail von Profihost so verstanden, dass die Migration automatisch laufen soll. Also das Shopware selbst dann standardmäßig weiterhin im 5.2 Modus läuft. Ich frage da aber nochmal explizit nach” Ich trau mich im Moment gar nicht an die Seiten, weil jede Speicherung diesen Daten-Müll produziert. Gruß Peter PS. Hab’s gerade nochmal probiert und es scheint nun wieder richtig zu funktionieren. Kein Daten-Müll mehr beim abspeichern. Na dann.:wink:

Hi Problem war bei uns das der Datenbank port nicht mit erkannt wurde. In der config an die ip gehangen und dann ging es…

Hey, Profihost hat „vergessen“ magic_quotes_gpc standardmäßig zu deaktivieren - das soll aber per Auto-Update jetzt gleich passieren, so dass die Probleme behoben sein sollten.