Grundpreisberechnung bei Varianten und Staffeln FALSCH

Hallo Experten :wink: Ich probiere derzeit ein wenig rum, wie wir unsere Artikel am besten anbieten - ob als Einzelteile oder Verpackungseinheiten. Dabei bin ich auf folgendes Problem (bei mir) gestoßen: Ich lege einen Artikel mit Farbvarianten an. Als „Inhalt“ ist 50 hinterlegt, als „Maßeinheit“ „Stück“ und für „Grundeinheit“ 1 Die erste Staffel (1) ist 64EUR ab 2 sind es 60EUR Für den „Vorauswahl“-Artikel* der Varianten wird dann korrekt der Grundpreis vom ersten Preis berechnet. Bei den anderen Varianten ist dann aber die Grundpreisberechnung falsch - es wird immer auf den zweiten Preis der Staffel zugegriffen. *wenn ich den „Vorauswahl“-Artikel auf eine andere Variante umstelle, ändert sich auch das Verhalten. Der Grundpreis der alten Vorauswahl wird nun falsch und die neue Vorauswahl richtig berechnet Ist das nur ein Problem bei mir, oder kann das ein anderer ggf. bestätigen?

Nun habe ich das Verhalten in einer anderen Testumgebung nachgestellt: -keine Plugins -Orange und Emotion Template eingestellt Artikel mit 3 Staffelpreisen (s.O.) angelegt und drei Farbvarianten angelegt: Ergebniss wie oben: Für den „Vorauswahl“-Artikel wird der erste Preis für die Grunspreisberechnung verwendet, für die restlichen Varianten der zweite Preis. Hierdurch wird der Grundpreis zu niedrig angezeigt => wenn das bei anderen reproduzierbar ist, besteht hier doch eine große Abmahngefahr bei Varianten mit Staffelpreisen!

Und auch im Demoshop http://www.shopwaredemo.de/ reproduzierbar. Zeit für ein Ticket. Erstaunlich, dass es keinen interessiert, dass hier ien Abmahnrisiko besteht :happy:

Hi, bekannt ist das Problem nicht. Ich konnte es bei meinen Tests gerade auch nicht nachvollziehen. Sollte es wirklich so sein, so ist das natürlich was für ein Bugticket, welches du unter jira.shopware.de anlegen kannst. Allerdings fällt mit in deinem Screenshot eine Besonderheit auf. Das steht in der Staffel „bis 1“. Das deutet auf eine fehlerhafte Staffel/Artikel hin. Eigentlich steht dort z.B. „bis 9“. Die Staffel muss von 1 bis >1 gehen, z.B. 1-20 Kannst du das mal checken? Sebastian

Was mach ich falsch? Bei Euch im Demoshop den angelegt (dürfte aber bald ja verschwinden) http://www.shopwaredemo.de/detail/index … ategory/23 Screenshop kommt nach… Edit: Screenshop vom Shopware-Demoshop

Hallo, http://www.shopwaredemo.de/detail/index … ategory/22 da klappt es. Wie geschrieben wird es daran liegen, dass du die Staffel 1 bis 1 machst. Das wird bei der Eingabe in der aktuellen Version nicht abgefangen, aber 1 bis 1 ist eigentlich nicht vorgesehen. Mit 1-19 z.B. klappen die Berechnungen. Daher ist es auch keinem anderen bisher aufgefallen Sebastian

1 Like

*Ähm* - Warum darf ich nicht schon für die Anzahl “2” einen anderen Preis machen? Ich habe ja nicht mit unseren echten Werten gestestet, sondern schnell was eingegeben - ein Schnelltest :slight_smile: Die Logik, dass ab dem zweiten “Stück” nicht schon ein anderer Preis gelten darf, verstehe ich nicht. Wir haben einige Artikel, die ab “2 Stück” schon einen anderen Preis haben. Somal der “Vorauswahl”-Artikel es ja richtig berechnet :wink: Was für “Mindestschritte” müssen denn eingehalten werden? Bin ein bischen verwundert, unser Asbach-Uralt-XT:C kann Staffel “1,2,3,4”

Hallo, seit dem gerade ausgeführten Update auf 4.3.6 habe ich auch ein Problem bei der Grundpreisberechnung. Seltsamerweise nicht bei allen Artikeln und auch nicht bei allen Varianten. Bei mir addiert sich der Grundpreis, sobald ich die Menge ändere, bei manchen Artikeln. Hier mal 2 Beispiele! https://kjr-kaffee.de/espresso/espresso … ralda?c=10 Von 250g OK von auf 1000g wird der Preis verviefacht! https://kjr-kaffee.de/koffeinfrei/kaffe … light?c=21 von 250g auf 500g verdoppelt und von 500 auf 1000g wieder verdoppelt Andere Artikel sind OK, im Backend kann ich nichts feststellen! Das ist mal ein extremer Bug!

Hallo, das sieht so aus, als hättest du den Inhalt nicht richtig eingetragen: https://kjr-kaffee.de/espresso/espresso … -esmeralda Wenn ich dort die Variante auf 1000g stelle, dann steht da bei Inhalt drüber immer noch 250. Prüfe nochmal deine Einstellungen. Von der Berechnung her ist das korrekt. Denke du hast den Inhalt von 250 nicht auf 1000 geändert Sebastian

Doch habe ich, alles wie bei den Artikeln die funktionieren auch! Ich muss nun den Shop sowiso umziehen und Updaten auf 5.0, mal schaun obs dann geht!

Umzug ist soweit durch, Du hattest Recht, bei den Varianten hatte ich den falschen Inhalt drin stehen! Viele Dank

hi, Super - Danke dir fürs Feedback Sebastian