Backend spielt verrückt, Fenster gehen einfach zu

Hallo zusammen, habe die letzte Zeit Probleme im Backend. In unregelmäßigen Abständen, Mitten in der Bearbeitung z.b. der Artikel schießt ohne Vorankündigung die Maske. Das ist natürlich nervent ohne enden.

Da bist Du nicht der einzige. Alle 25 Min. schließt sich das Backend. Andere User machen php 5.6 verantwortlich. Ich habe Compositiv darauf aufmerksam gemacht. Die Reaktion: Zitat: " … wir haben mehrere Kunden auf diesem Server die dieses Problem nicht haben. Es ist überaus unwahrscheinlich das die PHP version 5.6 die übrigens Shopware explizit empfiehlt etwas damit zu tun hat. Wir müssten ja die PHP version Serverweit downgraden und das würde den anderen Kunden nicht gefallen. Bitte wenden Sie sich an den Shopwaresupport. Es muss eine Shopeinstellung oder ein Plugin dafür Verantwortlich sein. " Was meint der “Shopsupport” ? Blubb

Hallo zusammen, wir sollten jetzt die Meldungen/Probleme nicht durcheinander bringen. Bei hifibau sind das z.B. Communication Probleme. I.d.R. sind große Datenmengen die Ursache, die vom Server bzw. den Ressourcen nicht verarbeitet werden können. Auf dem Screenshot sind Varianten zu sehen. Ggf. gibt es sehr viele “Optionen” die dann nicht geladen werden können. Bzgl. PHP 5.6 (wo es aber einen anderen Post zu gibt) sind wir parallel in diversen Prüfungen. Beispielsweise nutzen viele Entwickler bei uns PHP 5.6 und bisher sind die Probleme nicht aufgefallen. Das beobachten wir aber im Detail bzw. versuchen das nachzustellen. Sebastian

Hallo, ich habe auch selten die gleiche Fehlermeldung. Bei mir liegt es an kurzen Verbindungsabbrüchen in der Firmenumgebung. Bei mir Zuhause ist dieser Fehler noch nie aufgetreten. Da das Backend auch Live Daten alle 10 Sek (Widget „Besucher online“) abrufen möchte kann es dann mal vorkommen, dass der Abruf genau in dieser Zeit, wo keine Verbindung zum Internet besteht geschieht. Das ganze kann z. B. auch eintreffen, wenn die Internetverbindung nur einige ms getrennt ist. Das diese Abfrage genau da eintrifft ist einfach nur Pech. Minimieren kannst du diese Fehlermeldungen, wenn du die Widgets deaktivierst. Hoffe dir damit geholfen zu haben. Gruß

wie kann man das den jetzt Sinnvoll abstellen? Oder muss man sich jetzt damit abfinden? Ist ja so kein schönes Arbeiten:(

Hallo Josef, erstmal muss man wissen, wie deine Systemvoraussetzungen aussehen. Dort kann man also evtl. noch was an der Performance machen, so dass du keine “Communication Errors” mehr bekommst. Wichtig ist auch zu schauen, welche Fehler bei dir im Error-Log liegen. Also vom Server und von Shopware. Dann kann man sicher auch an den richtigen Stellen ansetzen. So ist das aktuell sehr schwer Sebastian

[quote=“Sebastian Klöpper”]Hallo Josef, erstmal muss man wissen, wie deine Systemvoraussetzungen aussehen. Dort kann man also evtl. noch was an der Performance machen, so dass du keine “Communication Errors” mehr bekommst. Wichtig ist auch zu schauen, welche Fehler bei dir im Error-Log liegen. Also vom Server und von Shopware. Dann kann man sicher auch an den richtigen Stellen ansetzen. So ist das aktuell sehr schwer Sebastian[/quote] Ich werde die Informationen mal zusammen bringen. Mittlerweile ist ein Arbeiten im Backend nicht mehr möglich…bekomme ja nicht mal ein Artikel aktualisiert. Vorab, gehostet bei Profihost (expert (server888-han)) Hier benötige ich dringend Unterstützung…für heute ist erst mal Schluss :x

Hallo, wenn du dich etwas mit Firebug auskennst, kannst du auch im Netzwerk-Tab schauen, welcher Request während des Speicherns/der Aktion nicht beendet wird. Oftmals lässt sich der Fehler dadurch weiter eingrenzen. Viele Grüße Moritz

Danke werde das heute Nachmittag mal testen Mal sehen ob ich da was vestellen kann

[quote=„Moritz Naczenski“]Hallo, wenn du dich etwas mit Firebug auskennst, kannst du auch im Netzwerk-Tab schauen, welcher Request während des Speicherns/der Aktion nicht beendet wird. Oftmals lässt sich der Fehler dadurch weiter eingrenzen. Viele Grüße Moritz[/quote] Diesen Tipp gebe ich gleich mal an Shopware retour. Ich habe das Problem seit Sekunde 1 der Zusendung der Passworter durch Compostiv bis heute. Genauer gesagt: Minute 25. Bis dahin hatte ich nur gelesen … Blubb

Habe hier jetzt mal die aktuelle Log Stelle von heute. Eventuell erkennt jemand etwas auffälliges. exception 'Zend\_Session\_Exception' with message 'The session has already been started. The session id must be set first.' in /hifwfkdw/www.hifi-stecker.de/engine/Library/Zend/Session.php:709 Stack trace: #0 /hifwfkdw/www.hifi-stecker.de/engine/Library/Zend/Session.php(421): Zend\_Session::setId('da602f0b162fccb...') #1 /hifwfkdw/www.hifi-stecker.de/engine/Library/Zend/Session/Namespace.php(143): Zend\_Session::start(true) #2 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Components/DependencyInjection/Bridge/Session.php(81): Zend\_Session\_Namespace-\>\_\_construct('Shopware') #3 /hifwfkdw/www.hifi-stecker.de/cache/proxies/Shopware201409241139ProductionProjectContainer.php(275): Shopware\Components\DependencyInjection\Bridge\Session-\>factory(Object(Shopware201409241139ProductionProjectContainer)) #4 /hifwfkdw/www.hifi-stecker.de/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Container.php(312): Shopware201409241139ProductionProjectContainer-\>getSessionService() #5 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Components/DependencyInjection/Container.php(253): Symfony\Component\DependencyInjection\Container-\>get('session') #6 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Components/DependencyInjection/Container.php(188): Shopware\Components\DependencyInjection\Container-\>load('session') #7 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Bootstrap.php(149): Shopware\Components\DependencyInjection\Container-\>get('Session') #8 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Application.php(196): Shopware\_Bootstrap-\>getResource('Session') #9 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Plugins/Default/Core/Router/Bootstrap.php(342): Shopware-\>Session() #10 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Plugins/Default/Core/Router/Bootstrap.php(230): Shopware\_Plugins\_Core\_Router\_Bootstrap-\>upgradeShop(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp)) #11 /hifwfkdw/www.hifi-stecker.de/engine/Library/Enlight/Event/Handler/Plugin.php(149): Shopware\_Plugins\_Core\_Router\_Bootstrap-\>onRouteShutdown(Object(Enlight\_Controller\_EventArgs)) #12 /hifwfkdw/www.hifi-stecker.de/engine/Library/Enlight/Event/EventManager.php(211): Enlight\_Event\_Handler\_Plugin-\>execute(Object(Enlight\_Controller\_EventArgs)) #13 /hifwfkdw/www.hifi-stecker.de/engine/Library/Enlight/Controller/Front.php(190): Enlight\_Event\_EventManager-\>notify('Enlight\_Control...', Object(Enlight\_Controller\_EventArgs)) #14 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Kernel.php(141): Enlight\_Controller\_Front-\>dispatch() #15 /hifwfkdw/www.hifi-stecker.de/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(472): Shopware\Kernel-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #16 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Components/HttpCache/AppCache.php(256): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, Object(Symfony\Component\HttpFoundation\Response)) #17 /hifwfkdw/www.hifi-stecker.de/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(376): Shopware\Components\HttpCache\AppCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, Object(Symfony\Component\HttpFoundation\Response)) #18 /hifwfkdw/www.hifi-stecker.de/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(335): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>validate(Object(Symfony\Component\HttpFoundation\Request), Object(Symfony\Component\HttpFoundation\Response), true) #19 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Components/HttpCache/AppCache.php(178): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>lookup(Object(Symfony\Component\HttpFoundation\Request), true) #20 /hifwfkdw/www.hifi-stecker.de/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(193): Shopware\Components\HttpCache\AppCache-\>lookup(Object(Symfony\Component\HttpFoundation\Request), true) #21 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Components/HttpCache/AppCache.php(113): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #22 /hifwfkdw/www.hifi-stecker.de/shopware.php(109): Shopware\Components\HttpCache\AppCache-\>handle(Object(Symfony\Component\HttpFoundation\Request)) #23 {main} request: { "uri": "/", "method": "GET", "query": [], "post": [] }

hier scheint doch irgend ein Script nicht immer zu funktionieren

[quote=“Sebastian Klöpper”] Auf dem Screenshot sind Varianten zu sehen. Ggf. gibt es sehr viele “Optionen” die dann nicht geladen werden können. [/quote] Ich kann mir nicht vorstellen das des bei Josef an den Varianten liegt. Ich habe bei All-Inkl “nur” das Webhosting Premium und habe teilweise 230 Optionen pro Artikel und komme super damit zu recht, ich hatte noch nie Probleme mit dem Backend.

Habe mal ein Ticket bei Profihost angelegt. Vielleicht habe die eine Lösung. Der Server soll ja auf Shopware abgestimmt sein. das ist mein Paket bei Profihost

Bei mir hat sich das Problem anscheinend erledigt. Es gibt 2 mögliche Ursachen. Nach dem letzten Einloggen habe ich den länger nicht mehr genutzten vorangelegten Zugang des Hosters Compostiv gelöscht. Etwa 10 Minuten später schmierte der Server ab. Ursache lt. Compositiv „Problem mit dem Mysqlserver“. Nachdem der Server wieder lief und ich mich einloggen konnte, hat sich das Backend nicht mehr von alleine geschlossen. toi, toi, toi … Blubb

Teste auch gerade auf einem anderen Rechner bei einem Kuppel…seit heute Morgen Keinen Abbruch. Werd wohl mein Netzwerk mal prüfen müssen. Eventuell liegt das Problem in meiner DSL Anbindung.

An Netcologne liegt es nicht. :wink:

vielleicht aber an 2&2 :quite:

habe da jetzt mal ein Allgemeine Frage. Habe im Backend eingestellt das der Shop bei einem Error eine Mail an mich sendend. Ich bekomme selbst in der Nacht Error Meldungen (diese Nacht 2 Stück) ohne das ich im Backend gearbeitet habe. Hier muss doch der Hund irgendwo anders begraben sein. Kann hier jemand etwas ähnliches bestätigen? Ich weiß langsam nicht mehr weiter :cry: exception 'Zend\_Session\_Exception' with message 'The session has already been started. The session id must be set first.' in /hifwfkdw/www.hifi-stecker.de/engine/Library/Zend/Session.php:709#newline#Stack trace:#newline##0 /hifwfkdw/www.hifi-stecker.de/engine/Library/Zend/Session.php(421): Zend\_Session::setId('da602f0b162fccb...')#newline##1 /hifwfkdw/www.hifi-stecker.de/engine/Library/Zend/Session/Namespace.php(143): Zend\_Session::start(true)#newline##2 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Components/DependencyInjection/Bridge/Session.php(81): Zend\_Session\_Namespace-\>\_\_construct('Shopware')#newline##3 /hifwfkdw/www.hifi-stecker.de/cache/proxies/Shopware201409241139ProductionProjectContainer.php(275): Shopware\Components\DependencyInjection\Bridge\Session-\>factory(Object(Shopware201409241139ProductionProjectContainer))#newline##4 /hifwfkdw/www.hifi-stecker.de/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Container.php(312): Shopware201409241139ProductionProjectContainer-\>getSessionService()#newline##5 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Components/DependencyInjection/Container.php(253): Symfony\Component\DependencyInjection\Container-\>get('session')#newline##6 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Components/DependencyInjection/Container.php(188): Shopware\Components\DependencyInjection\Container-\>load('session')#newline##7 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Bootstrap.php(149): Shopware\Components\DependencyInjection\Container-\>get('Session')#newline##8 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Application.php(196): Shopware\_Bootstrap-\>getResource('Session')#newline##9 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Plugins/Default/Core/Router/Bootstrap.php(342): Shopware-\>Session()#newline##10 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Plugins/Default/Core/Router/Bootstrap.php(230): Shopware\_Plugins\_Core\_Router\_Bootstrap-\>upgradeShop(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp))#newline##11 /hifwfkdw/www.hifi-stecker.de/engine/Library/Enlight/Event/Handler/Plugin.php(149): Shopware\_Plugins\_Core\_Router\_Bootstrap-\>onRouteShutdown(Object(Enlight\_Controller\_EventArgs))#newline##12 /hifwfkdw/www.hifi-stecker.de/engine/Library/Enlight/Event/EventManager.php(211): Enlight\_Event\_Handler\_Plugin-\>execute(Object(Enlight\_Controller\_EventArgs))#newline##13 /hifwfkdw/www.hifi-stecker.de/engine/Library/Enlight/Controller/Front.php(190): Enlight\_Event\_EventManager-\>notify('Enlight\_Control...', Object(Enlight\_Controller\_EventArgs))#newline##14 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Kernel.php(141): Enlight\_Controller\_Front-\>dispatch()#newline##15 /hifwfkdw/www.hifi-stecker.de/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(472): Shopware\Kernel-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)#newline##16 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Components/HttpCache/AppCache.php(256): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, Object(Symfony\Component\HttpFoundation\Response))#newline##17 /hifwfkdw/www.hifi-stecker.de/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(376): Shopware\Components\HttpCache\AppCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, Object(Symfony\Component\HttpFoundation\Response))#newline##18 /hifwfkdw/www.hifi-stecker.de/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(335): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>validate(Object(Symfony\Component\HttpFoundation\Request), Object(Symfony\Component\HttpFoundation\Response), true)#newline##19 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Components/HttpCache/AppCache.php(178): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>lookup(Object(Symfony\Component\HttpFoundation\Request), true)#newline##20 /hifwfkdw/www.hifi-stecker.de/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(193): Shopware\Components\HttpCache\AppCache-\>lookup(Object(Symfony\Component\HttpFoundation\Request), true)#newline##21 /hifwfkdw/www.hifi-stecker.de/engine/Shopware/Components/HttpCache/AppCache.php(113): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)#newline##22 /hifwfkdw/www.hifi-stecker.de/shopware.php(109): Shopware\Components\HttpCache\AppCache-\>handle(Object(Symfony\Component\HttpFoundation\Request))#newline##23 {main}#newline##newline##newline#request: {#newline# "uri": "/",#newline# "method": "GET",#newline# "query": [],#newline# "post": []#newline#}#newline# #newline#

Hallo Josef, du hast ja zusätzlich auch Probleme mit den Sessions. Das kann auf Anpassungen oder auch plugins zurückzuführen sein. Ich habe hier auch nicht sehen können, wie du den paket eingerichtet hast. Wie viel memory_limit hast du zur Verfügung? Welche PHP Version aktiv? Hast du für schon mal umgestellt? Fremdplugins deinstalliert? Cache wirklich mal komplett geleertY bzw Ordner neu angelegt? Das sind die einzigen Punkte die ich mir vorstellen kann. Richtig ist das Verhalten auf jeden Fall nicht! Bei den anderen Usern wird es wohl an Fehlern in PHP gelegen haben. Eingesetzt wurden ältere und wir nutzen aktuellere und haben die Probleme daher nicht gehabt. Sebastian

1 Like