ZendOpcache + APCu einrichten

Hallo Leute, ich habe meine Seite nun weitgehend optimiert an vielen Stellen wo ich selbst damit klar kam. Pagespeed jetzt bei 70/100 Punkten für Desktop (mobile variante vernachlässige ich mal da ich auf SW5 wechseln möchte). Wo ich jetzt aber hänge ist der ZendOpcache + APCu. Da Speedtest rot bemängelt: Browser-Caching nutzen! Ich habe laut Wiki gelesen zu Performance tipps folgendes: [quote]Bytecode-Cache APC ZendOpcache + APCu Es sollte in jedem Fall ein Bytecode-Cache installiert und korrekt konfiguriert sein - dies beschleunigt die Ausführung des PHP-Stacks nochmal um bis zu 25 % Installationsanleitung: https://gist.github.com/bcremer/5450321 [/quote] Jedoch bringt mir auch die ANleitung nichts, da ich nicht weiß wohin mit dem Code oder verstehe ich hier was grundsätzlich falsch? Mein Provider hat mir ebenfalls erwähnt/empfohlen ZendOpcache + APCu zu aktivieren und auf SW Forum verwiesen. Kann mir einer helfen und erklären was ich tun muss um das einzurichten? Und habt Ihr Tipps für mich was ich noch am Cache/Einstellungen machen kann damit Shopware noch flotter agiert und Speedtest weniger meckert? Speedtest meckert bei Cache und sagt mir: Nutzen Sie Browser-Caching für die folgenden cachefähigen Ressourcen: (Bildche, css, js usw) die Dateien haben alle Ablaufzeit (habe per .htaccess eingerichtet) aber sind trotzdem in der Liste aufgeführt. Was soll ich hier machen? Danke im Vorraus.

ZendOpcache + APCu ist Serverseitig in erster Linie - Es muss also vom Hoster erst einmal auf dem Server installiert werden. Was hast du denn da für einen „Provider“ ? :x Der Link ist hier auch für den Server gedacht, dass hat so erst einmal nichts mit der Shopware Installation zu tun. Dein Problem ist wohl eher das Ablaufdatum der Daten. Hier ist ein recht guter Beitrag: http://webmaster-fragen.de/webdev/pages … 40911.html

1 Like

Super Danke! Habe alle Änderungen in .htaccess laut dem Turbo artikel druchgeführt. Habe 84/100 nun aber Speedtest meckert noch immer mit Cache: Nutzen Sie Browser-Caching für die folgenden cachefähigen Ressourcen: Dann eine Liste von Bildchen, css, js aber alle haben Ablaufdatum von 2 Stunden. Was muss ich hier noch machen dass Caching läuft? Wegen ZendOpcache + APCu habe ich meinen Provider angeschrieben dass der mir dabei helfen soll bzw. das einrichten/installieren/aktivieren soll. EDIT: habe dank provider nun per Confix Menü: apc.enabled & opcache.enable aktiviert. Beide sind nun serverseitig aktiviert. Problem besteht jedoch weiterhin da, in backend sind beide auf Rot markiert. Woran kann das liegen? Der Provieder hat mir noch einen Quelltext zugemailt: ### config.php von shopware // Backend-Cache ‚cache‘ => array( ‚backend‘ => ‚apc‘, ‚backendOptions‘ => array(), ‚frontendOptions‘ => array(), ), // Model-Cache ‚model‘ => array( ‚cacheProvider‘ => ‚Apc‘ // supports Apc, Array, Wincache and Xcache ), Aber laut Forum recherche erkennt SW seit der 4.1er automatisch und muss nichts and er Config.php Datei vorgenommen werden. Was mache ich hier also falsch?

Push* Weiß eienr hier woran das liegen kann das ZendOpcache + APCu obwohl serverseitig aktiv trotzdem vons hopware auf rot stehen? Habe 84/100 nun aber Speedtest meckert noch immer mit Cache: Nutzen Sie Browser-Caching für die folgenden cachefähigen Ressourcen: Dann eine Liste von Bildchen, css, js aber alle haben Ablaufdatum von 2 Stunden. Was muss ich hier noch machen dass Caching läuft?

Dann wird es wohl nicht aktiv sein. Überprüfe doch einmal ob diese zwei Module in deiner phpinfo setehen. Shopware Backend -> Systeminfo -> phpinfo Alternativ eine info.php im Server Root anlegen mit folgendem Inhalt: <?php phpinfo(); ?> Und diese Datei aufrufen.

1 Like

Jetza, war tatsächlich so! Es fehlte das PHP Update auf mind. 5.5 bzw. nun 5.6 jetzt läufts ZendOpcache und APCu sind aktiv. Vielen Dank!! Nur noch der letzte Punkt: Nutzen Sie Browser-Caching für die folgenden cachefähigen Ressourcen:Dann eine Liste von Bildchen, css, js aber alle haben Ablaufdatum von 2 Stunden. Was muss ich hier noch machen dass Caching läuft? Eine Idee woran das noch liegen kann dass die Liste so lang ist und bemängelt wird?

Dein „expires“ Header steht offensichtlich für diese Dateitypen auf 2 Stunden, Google möchte aber einen längeren Zeitraum. Schau mal hier: http://www.inmotionhosting.com/support/ … od-expires Da wird recht gut beschrieben, wie man für welchen Dateityp das Expiry Date setzen kann.

2 Likes

Oh wow, krass, durch diese kleine Änderung an den expires Zeiten, raufgeschnellt auf 89/100 nun Desktop im grünen Bereich! Perfekt, riesen Dank für Eure hilfreichen Tipps. Damit ists für mich erledigt. Jetzt steht mein SW4 Shop bis zur 5er Version wenigstens in der Form auf guten Basis! Nochmals vielen Dank!

Hallo SKB, heute wollte ich auch bei all-inkl ZendOpcache + APCu aktivieren lassen, da beides im Admin auf rot steht. Man sagte mir aber, dass das nicht gehen würde. Darf ich fragen, bei welchem Anbieter Euer Shop ist?