Subshop mit eigenem SSL Zertifikat & ISPconfig

Hallo,

ich möchte einen Subshop betreiben, der unter einer eigenen URL erreichbar ist. Als Konfigurationsoberfläche für die Domainverwaltung dient mir hier ISPConfig.

Sofern ich die Domain als Alias-Domain anlege, funktionert alles wunderbar. Jedoch kann ich hier in ISPConfig zu der Alias-Domain kein eigenes SSL-Zertifikat hinterlegen. Dieses kann ich nur wenn ich die Domain als reguläre Domain in ISPConfig anlege. Das wurde auch soweit umgesetzt und das SSL-Zertifikat hinterlegt. Ich kann so die URL per https aufrufen. 

Jedoch gelingt mir nun nicht die korrekte Umleitung auf die Shopinstallation, so daß der neue Subshop auch unter der gewünschten Domain dargestellt wird. Ich habe schon sämtliche Weiterleitungsvarianten innerhalb ISPConfig ausprobiert - jedoch ohne Erfolg.

Ich habe gelesen, das es wohl am einfachsten mit einem Mulitdomain-SSL-Zertifikat zu lösen wäre, jedoch habe ich hier nur ein „normales“ Zertifikat, da ich die Domain übernommen habe.

Wie kann ich das Problem nun am besten lösen? Die Domain ist in SW5 korrekt eingetragen - das hat ja schon der Test ohne SSL-Zertifikat gezeigt. Natürlich habe ich in SW5 auch beim Subshop „SSL überall verwenden“ aktiviert. Ich sehe im Moment nur einen Ansatz evtl. bei den Felder „SSL-Host“ und „SSL-Pfad“ jedoch bin ich mir hier nicht sicher ob es korrekt ist.

Gruß,
Christian

Hallo,

sofern du ausreichende Zugriffsrechte hast:
richte per SSH einen Symlink ein (web-Verzeichnis des Subshops linkt auf das web-Verzeichnis des Hauptshops).

Alternativ:
In den neuen ISPConfig-Versionen kann man ein LetsEncrypt-Zertifikat kostenlos einrichten (für ältere gibt es hier einen Patch: GitHub - alexalouit/ISPConfig-letsencrypt: Let's Encrypt support for ISPConfig). Dabei wird dann ein Zertifikat für die Domain und alle ihre Alias-Domains erzeugt.

Grüße,
Sven

 

Hi Sven,

wenn es so einfach wäre! :slight_smile:

Mit einem Symlink bekomme ich nur eine 403-Meldung. Das liegt sicher daran, das der Apache mit der falschen user-ID auf das Verzeichnis des Hauptshops zugreift…

 

Let’s Encrypt ist sicher interessant, jedoch möchte ich das ISPConfig (stable) nicht patchen um keine künstlichen Probleme herauf zu beschwören…

 

Danke für deine Hilfe!

@Sven:

Wäre es ratsam / sinnvoll die Benutzer-ID des Subshops auf die des Hauptshops in der ISPConfig-DB anzupassen und entsprechend den PHP open_basedir Pfad?

@Zappodrom schrieb:

@Sven:

Wäre es ratsam / sinnvoll die Benutzer-ID des Subshops auf die des Hauptshops in der ISPConfig-DB anzupassen und entsprechend den PHP open_basedir Pfad?

Habe ich gerade mal geändert, jedoch auch ohne Erfolg… 

mal einen Blick in die error.log geworfen ?

hmmm, ich habe schon lange nicht mehr mit Apache gearbeitet (nur noch nginx) …

gab es da nicht eine Einstellung, dass Symlinks normalerweise nicht gefolgt wird, die man dann freischalten muss:

Options FollowSymLinks

Es hat geklappt! Der Symlink zeigt nun ins Webverzeichnis des Hauptshops. Zusätzlich muss noch eine Umleitung in ISPConfig eingerichtet werden (bei mir in ein Unterverzeichnis innerhalb des Web-Verzeichnises in dem dann SW installiert ist).

Die zusätzliche Umleitung hatte ich vorher nicht eingestellt gehabt. Jetzt klappt es wunderbar. :slight_smile:

Hallo Zappodrom,

solltest du bei @TimmeHosting‍  sein solltest kannst du dir die Funktion dafür freischalten lassen, wenn du bestätigst, dass du auf eigene Gefahr handelst. Dann kann man für Subdomains das entsprechend in ISPconfig einstellen.

//Ich beziehe mich hier nicht auf Lets Encrypt sonder nur Aliasdomains mit Zert

Viele Grüße,

Thorsten

Es dauert wahrscheinlich nur noch wenige Tage, bis ISPConfig 3.1 rauskommt. Einen RC1 gibt es schon.

Hier sollte für die Hauptdomain sowie alle Aliasdomains darauf ein Let’s Encypt Zertifikat erstellt werden. Zumindest habe ich das so verstanden, getestet habe ich den RC nicht.
Das sollte aber die Spielerei mit den SymLinks unnötig machen.

Übrigens: ISPCONFIG 3.1 wurde Ende letzten Monats veröffentlicht und das mit LetsEncrypt funktioniert bisher einwandfrei:  http://www.ispconfig.org/blog/ispconfig-3-1-released/

1 Like

Danke für den Hinweis!