Standardzahlungsart bei Neukunden ist immer Vorkasse

Hallo, ich habe nun wieder ein zusätzliches Problem. Situation: SW4.0.4, Zahlungsarten->PayOne(nur PayPal, später soll Kreditkarte hinzu) Backend->Grundeinstellungen->Storefront->Anmeldung/Registrierung Standardzahlungsart(Id) Registrierung = 9 = PayOne Fallback-Zahlungsart(Id) = 9 = PayOne Backend->Zahlungsarten Die einzig aktive Zahlungsart ist PayOne (Länder und Shop sind zugeordnet -> nach löschen der Zuordnung keine Veränderung) Backend->Kunden->Zahlungen->PayOne->Konfiguration PayPal = aktiv (Länder sind zugeordnet usw.) Wenn sich ein Kunde im Shop anmeldet bekommt er aber nach wie vor Vorkasse zugeordnet, obwohl die nicht einmal aktiv ist. Hat jemand eine Idee? Keiner was zu sagen? VG

Vielleicht gibts ja doch jemanden der eine Idee hat?

Cache leeren?

@leseaw Vielen Dank, … das ist mir tatsächlich völlig neu, so wie vielen anderen hier auch. Also noch mal vielen Dank! @alle anderen & SW, hat jemand eine ernstzunehmende Idee, die einem tatsächlich auch weiter hilft?

Könnte vielleicht irgendjemand von SW dazu etwas schreiben? Wir verlieren potenzielle Kunden, da die Leute sich wundern warum sie dann doch nicht mit Vorkasse bestellen können!

Hallo xp24, wichtig ist, wenn nur PayOne aktiv ist, darf diese Zahlungsart keine Einschränkungen hat. Also es dürfen keine Länder, Shops etc. in der Zahlungsart unter “Zahlungsarten” markiert sein. Bitte entferne einmal alle Markierungen. So kann Shopware dann als Standardzahlungsart und Fallbackzahlungart in jeder Konstellation auf PayOne zurückfallen. Das ist hier eher ein Ausnahmefall, da wirklich nur eine einzige Zahlungsart genutzt werden soll.

Danke Sebastian, aber was machst du wenn es keine Veränderung gibt? Immer noch Vorkasse! Und eine einzige Zahlungsart ist es ja eigentlich nicht, wenn die anderen Zahlungsarten in PayOne wieder funktionieren. Vorgesehen sind dann z. B. 2 Zahlarten, PayPal und Kreditkarte -> beide von PayOne. Was micht zu meiner nächsten Frage führt, was von den Zahlungsarten in PayOne ist denn dann die Standardzahlungsart PayPal oder Kreditkarte und wie stelle ich das ein?

Wir haben derzeit das gleiche Problem. Im Bereich “Mein Konto” wird dem Kunden unter “Gewählte Zahlungsart” immer Vorkasse angezeigt? Die Vorkasse ist allerdings, weil Payone aktiv ist, inaktiv. Payone hat auch bei uns keinerlei Einschränkungen. Es sollte dort entweder eine Zahlungsart aus dem Payone Modul angezeigt werden oder alle in Payone aktivierten oder… @SW: Gibt es dafür einen Bugfix von euch? Grüße

[color=purple][size=200]Gibt es jetzt endlich mal eine klare Ansage oder ein Bugfix? Es ist nicht fördernd fürs Tagesgeschäft![/size][/color] Vielleicht kann sich mal jemand von SW darum kümmern?! Das für diese Woche versprochene Update von PayOne ist leider auch nicht am Start und es gab keinerlei Rückmeldung das es sich verzögern wird. Es macht keinen Sinn den schwarzen Peter immerzu hin und her zu schieben, es macht viel mehr Sinn das alle beteiligten (auch SW!) an einer Lösung arbeiten. Dassind grundsätzliche Probleme die einen Shop komplett aushebeln und Kunden im Nirvana verschwinden lassen.

1 Like

Auch wir haben zur Zeit das selbe Problem! Sorry - so langsam fehlt mir das Verständnis. Wir haben gerade Vorweihnachtszeit und das ist unsere wichtigste Zeit und dann so ein langwieriger Bugfix der bereits verschoben wurde? Jedenfalls schadet ihr gerade nicht nur uns als Shopbetreiber - Community/Prof. Version hin oder her, sondern auch Eurem Image und PayOne ihrem! Viele Grüße, Dominik

Wenn sich bis Montag nächster Woche nichts ändert ist PayOne gestorben, Guten Tag Heidelpay und Co.

Hallo zusammen, wir haben soeben von PayOne die neue Version erhalten und testen sie gerade… wir geben Euch asap Rückmeldung ob bei uns alles funktioniert!

Stehe gerade vor dem selben problem; die Zahlungsart fuer neukunden ist immer die erste option die shopware auf der seite anzeigt - ganz egal was vom user ausgewaehlt wurde. Gibt es nach fast 2 jahren dafuer eine loesung?

Ok, ich habe das problem gefunden. Problem war NICHT shopware, sondern ein jQuery plugin (in meinem fall was es http://fronteed.com/iCheck/) welches checkbox und radio-buttons ersetzt. Das problem dabei ist, dass dieses plugin den entsprechenden ajax-request nichtmehr so ausgeloest hat wie es normale html checkbox/radiobuttons tun wuerden (change event am input element selbst) sobald ein kunde eine zahlungsart anedert, sodass shopware nicht mitbekommen hat wenn der kunde die zahlungsart geaendert hat und daher immer die erstbeste zahlungsart verwendet hat. Falls das hier noch jemand liest weil er ueber die google suche hier gelandet ist: vergleicht in firebug die ajax-requests die shopware in der standard installation (-> http://www.shopwaredemo.de/) ausloest wenn die zahlungsart geaendert wird mit eurer eigenen installation, oder ob es irgendwelche anderen Javascript fehler gibt welcher verhindert dass der ajax-request ausgeloest wird wenn sich die zahlungsart aendert…

Gleiches Problem, aber andere Lösung: Bei “Einstellungen / Grundeinstellungen / Storefront / Anmeldung” muss als Fallback-Zahlungsart (ID) die ID der bevorzugten Zahlungsart eingetragen werden. Bei mir stand da eine 5. Daher wurde Vorkasse (ID 5) eingeblendet, obwohl ich sie ausdrücklich deaktiviert hatte.