Shopware 6 E-Mail Server Einstellungen

Guten Tag,

ich habe die neuste Version von Shopware 6 und möchte gerne für Bestellbestätigungen an den Kunden eine E-Mail versenden, allerdings finde ich keine Einstellungsmöglichkeit die SMTP Zugangsdaten eingeben zu können. Kann mir jemand helfen?

LG Steven

Das findest du in der .env Datei auf dem Server. Wird aber erst mit EA2 komplett funktionieren.

Ich stehe da auch gerade auf dem Schlauch :wink:

###> symfony/swiftmailer-bundle ###

For Gmail as a transport, use: “gmail://username:password@localhost”

For a generic SMTP server, use: “smtp://localhost:25?encryption=&auth_mode=”

Delivery is disabled by default via “null://localhost”

MAILER_URL=null://localhost
###< symfony/swiftmailer-bundle ###

Es müsste also die MAILER_URL nach meinem Verständnis wie folgt beginnen:
MAILER_URL=smtp://mail.agenturserver.de:25 . . .
mir ist nur nicht klar, wie ich den User (Konto) = username und das password = password in den Link einbinde.

Die URL muss dafür wie folgt aussehen:

MAILER_URL=smtp://mail.agenturserver.de:465?encryption=ssl&auth_mode=login&username=&password=

Oder ohne SSL:

MAILER_URL=smtp://mail.agenturserver.de:25?auth_mode=login&username=&password=

Mehr dazu auch hier:

bzw. hier:

 

1 Like

Hallo,

Meine E-Mails werden beim bestellen nicht verschickt. Ich habe folgendes in der .env Datei:

MAILER_URL=smtp://server.de:465?encryption=ssl&auth_mode=login&username=&password=

Muss ich noch etwas anderes beachten?

Danke und Gruß

Username und Password sind gefüllt? Hast du der E-Mail Vorlage einen Saleschannel zugeordnet? Letzteres ist wichtig, damit der Versand erfolgt. Die Option findest du unter Einstellungen -> E-Mail Vorlagen.

@AndreHerking schrieb:

Username und Password sind gefüllt? Hast du der E-Mail Vorlage einen Saleschannel zugeordnet? Letzteres ist wichtig, damit der Versand erfolgt. Die Option findest du unter Einstellungen -> E-Mail Vorlagen.

Was meinst du damit:

„Username und Password sind gefüllt?“ Wo soll ich sie füllen?

" Hast du der E-Mail Vorlage einen Saleschannel zugeordnet?" - habe ich nicht. Soll ich die Vorlagen erst duplizieren?

Danke

@AndreHerking‍

duplizieren von E-Mail Vorlagen funktioniert übrigens nicht.

Folgende Fehlermeldung in der Konsole:

TypeError: “e is undefined”
    value http://domain.de/bundles/administration/static/js/app.js?1571641520:1
    value http://domain.de/bundles/administration/static/js/app.js?1571641520:1
    onDuplicate domain.de/bundles/administration/static/js/app.js?1571641520:1
    click domain.de/bundles/administration/static/js/vendors-node.js?1571641520 line 41 > Function:3
    Xe http://domain.de/bundles/administration/static/js/vendors-node.js?1571641520:41
    n http://domain.de/bundles/administration/static/js/vendors-node.js?1571641520:41
    _wrapper domain.de/bundles/administration/static/js/vendors-node.js?1571641520:41
vendors-node.js:41:11689

 

@KMedia schrieb:

Die URL muss dafür wie folgt aussehen:

MAILER_URL=smtp://mail.agenturserver.de:465?encryption=ssl&auth_mode=login&username=&password=

Oder ohne SSL:

MAILER_URL=smtp://mail.agenturserver.de:25?auth_mode=login&username=&password=

Mehr dazu auch hier:

https://symfony.com/doc/current/email.html

bzw. hier:

https://symfony.com/doc/current/reference/configuration/swiftmailer.html

 

Vielen Dank, so hatte ich das auch aufgebaut. Das Problem war jedoch ein Sonderzeichen # im Passwort. Habe das jetzt umgestellt und es funktioniert z.B. mit _ anstatt #

Gemäß der Docu von Symfony sollte encoden auch gehen, muss ich mal bei Gelegenheit testen.

If the username, password or host contain any character considered special in a URI (such as +, @, $, #, /, :, *, !), you must encode them. See RFC 3986 for the full list of reserved characters or use the urlencode function to encode them.

1 Like

@blueroger schrieb:

@AndreHerking schrieb:

Username und Password sind gefüllt? Hast du der E-Mail Vorlage einen Saleschannel zugeordnet? Letzteres ist wichtig, damit der Versand erfolgt. Die Option findest du unter Einstellungen -> E-Mail Vorlagen.

Was meinst du damit:

„Username und Password sind gefüllt?“ Wo soll ich sie füllen?

" Hast du der E-Mail Vorlage einen Saleschannel zugeordnet?" - habe ich nicht. Soll ich die Vorlagen erst duplizieren?

Danke

Die Variable enthält ja Parameter: 

MAILER_URL=smtp://server.de:465?encryption=ssl&auth_mode=login& username =& password =

Hinter dem „=“ gehört dann jeweils der Username und auch das Password. Sonst fehlen ja die Login Daten. Die Vorlage brauchst du nicht duplizieren, sondern einfach nur dem Sales Channel zuordnen.

LG Andre

 

@AndreHerking‍

danke, ich habe es eingerichtet.

@AndreHerking schrieb:

@blueroger schrieb:

@AndreHerking schrieb:

Username und Password sind gefüllt? Hast du der E-Mail Vorlage einen Saleschannel zugeordnet? Letzteres ist wichtig, damit der Versand erfolgt. Die Option findest du unter Einstellungen -> E-Mail Vorlagen.

Was meinst du damit:

„Username und Password sind gefüllt?“ Wo soll ich sie füllen?

" Hast du der E-Mail Vorlage einen Saleschannel zugeordnet?" - habe ich nicht. Soll ich die Vorlagen erst duplizieren?

Danke

Die Variable enthält ja Parameter: 

MAILER_URL=smtp://server.de:465?encryption=ssl&auth_mode=login& username =& password =

Hinter dem „=“ gehört dann jeweils der Username und auch das Password. Sonst fehlen ja die Login Daten. Die Vorlage brauchst du nicht duplizieren, sondern einfach nur dem Sales Channel zuordnen.

LG Andre

Hallo ich steh gerade vor dem gleichen Problem. Welchen User und welches Passwort soll man da eintragen? die Mail Adresse von meinem E-Mail account?

ich steh total auf dem Schlauch!

Danke für eure Hilfe! 

Die Login Daten für den SMTP Account der Shopbetreiber E-Mail Adresse, die kommen hinter dem „=“ . Wichtig ist, dass du den korrekten Port von deinem Anbieter in Erfahrung bringst, sowie den korrekten SMTP Server (hier server.de:Port).

LG Andre

Hey ihr, ich bin nun auch auf das Problem gestoßen… Aber irgendwie will er keine Mails senden.

 

Hier mein Mailer URL:

 

MAILER_URL=smtp://smtp.strato.de:465?encryption=ssl&auth_mode=login&username=VOLLSTÄNDIGEE-MAILMITDOMAINund@ZEICHEN&password=PASSWORT

 

kann mir hier jemand helfen? Port ist der SSL Port und Server stimmt auch.

 

PS: bei der Mail Adresse habe ich es auch schon mit umcodierung bzw encoding probiert, also statt mail@domain.de mit mail%40domain.de

 

Liebe Grüße

Kann mir jemand helfen?

Hast du denn den RC im Einsatz? Da kann man das im Admin einstellen.

@Moritz Naczenski schrieb:

Hast du denn den RC im Einsatz? Da kann man das im Admin einstellen.

Hey, habe jetzt geupdatet und im Mailer alles eingestellt - aber keine Chance - alles wirklich richtig eingestellt (extra bei Strato angerufen; Dort geht nur SSL und Benutzername = E-Mail Adresse) Irgendwie klappt es hier 0 mit den Mailer…  

Hey - ist Dein Hosting bei Strato mit SW6 überhaupt kompatibel ?

Viele Grüße
Martin

Sobald ich eine Mail verschicken will (z.B. bei Bezahlstatus “bezahlt”) erscheint nur folgendes: 

Fehler

23:25

Beim setzen des Status ist ein Fehler aufgetreten. Zusätzliche Informationen:Error: Request failed with status code 500

@Rocket schrieb:

Hey - ist Dein Hosting bei Strato mit SW6 überhaupt kompatibel ?

Viele Grüße
Martin

Hey, ja das ist komtaibel, die Daten laufen ja auch alle bei Strato… Also der Mailserver ist auf den gleichen Server wie der Webspace… LG