Shopware 6 Backend nach Migration nicht aufrufbar, nur Backend vom 5er

Hallo zusammen,

nach der Migrationsphase (Migration - Livegang bis Schritt Live Gang) hat alles funktioniert. Ich habe eine sub Domäne angelegt, welche per CName auf meine aktuelle Hauptdomäne verweise. Nachdem ich die Migration finalisiert habe (Unter Shopware Account…) bekomme ich nicht das Backend vom 6er. Wenn ich das backend, mit sub.domäne.toplevel/backend aufrufe erscheint lediglich das alte 5er backend.

Wie rufe ich nun das neue backend vom 6er auf damit ich weiter machen kann ?

Vielen Dank für euere Hilfe

LG

domain.toplevel/admin ?

1 Like

Made my day.

Manchmal sind es die kleinen Dinge…

Ich hoffe, dass das die Lösung ist.

Leider nicht, habe ich auch schon versucht.

Ich bin mir auch nicht sicher, ob etwas an den Dateien auf dem Webspace geändert wurde. Ich hab ja lediglich die Lizenzen unter Shopware Account migriert und anschließend die Migration finalisiert.

Mit fehlt die Zuordnung, wie nun die Daten auf dem Webspace aktualisiert werden, damit auch das neue backend geladen werden kann. Davon habe ich leider nichts in der Anleitung gefunden.

Nach einer Anleitung auf Youtube, soll ich das update von Shopware herunterladen, entpacken und auf den Webserver hochladen. Anschließend per shell mit php die recovery/update/index.php ausführen. Da ich kein Shell Zugriff habe, wollte ich diese per URL ausführe aber da werde ich auf https://index.php weitergeleitet und die Webseite wird natürlich nicht gefunden. Aber im Video sieht man dann, dass die Daten auf dem Webserver sowie die Datenbank aktualisiert wird.

Ich habe eine sub Domäne angelegt, welche per CName auf meine aktuelle Hauptdomäne verweise.

Den Schritt verstehe ich nicht. Du hast zwei Installationen SW5 und SW6 und möchtest eine Migration durchführen. Also müssen doch beide Installationen separat erreichbar sein.

Also SW5 unter domain.de und SW6 sub.domain.de
Warum ist die CName Zuordnung notwendig?
Dann kommt ja bei Aufruf von sub.domain.de → CName → domain.de und damit SW5 und Backend.

Installation und Migration haben im SW6 Backend bereits funktioniert?

Ja, das mit dem CName war ein Fehler von meiner Seite. Ich dachte, ich müsste eine Weiterleitung auf die Domäne machen. Ich war davon ausgegangen, dass mit den Einstellungen im Shopware-Account eine Art Updatemanager unter der neuen Subdomäne zur Verfügung steht und ich die auf meine Domäne verweisen muss. Aber anscheinend muss ich erst das Update von Shopware auf dem Webspace einspielen. Ich melde mich, wenn ich das Update eingespielt habe.

Danke für euere Unterstützung

und schon was erreicht?

Hallo,

leider stecke ich immer noch fest. Ich hab mich dann damit abgefunden, dass es nicht geht und bin weiterhin auf der Version 5 geblieben. Aber nun benötige ich das Update. Ich stecke irgendwie zwischen der Migration. Ich habe noch meinen kompletten Shop in Version 5 aber im Shopware Account sehe ich beide, wobei der 6er im Produktivbetrieb angezeigt wird.

Kann mir Jemand erklären wie ich weiter mache oder kann wäre es möglich, dass ich noch mal von vorne beginne ?

Vielen Dank

LG

Ich glaub ich hab den Fehler gefunden. Der Shop5 liegt direct unter httpdocs aber der Shop 6 liegt in einem Unterverzeichnis in httpdocs. Das sollte höchstwahrscheinlich auch direkt unter httpdocs liegen.

Ich könnte nun versuchen, die Daten aus dem Shop 6 Unterverzeichnis direkt unter httpdocs zu kopieren und die bereits vorhandenen Daten überschreiben oder würde das alles zerstören ?

Das kommt auf deine URL Struktur an. Du kannst bei allen Hosting Anbietern deine URL auf ein bestimmtes Verzeichnis zeigen lassen. Die FTP Struktur ist zunächst nur für deine eigene Ordnung. Da ich deine Struktur nicht kenne, empfehle ich eher alles im Unterverzeichnis zu lassen. Also httpdocs/shopware 6/Dateien und httpdocs/shopware5/Dateien