Shopware 3.5.4

ok ich werd mal anfangen zu laden :thumbup:

[quote=“Stefan Hamann”]Die Application.php wird nicht in Update-Packages mitgeliefert, da diese ja userspezifische Anpassungen haben kann - hier gibt es im Install-Package aber die aktuelle Version - wobei, welche Datenbank-Änderungen meinst du da genau?[/quote] Ich meinte die Änderung, dass man die Host- und DB-Config parameter jetzt nicht mehr in die DB schreiben muss. Das heißt im Umkehrschluss dann, dass die “alte” Application.php trotzdem ohne Probleme mit 3.5.4 läuft? Das wäre ja klasse, denn ich habe die Twolevelcache-Variante drin und würde nur ungern darauf verzichten wollen.

@Revo Was heißt denn vor ein paar Minuten - der Online-Installer mit 3.5.4 steht erst seit ca. 15.30 zur Verfügung

@tschersich Ja, genau. Ansonsten würde unsere Auto-Update Strategie ja zukünftig nicht funktionieren, wenn wir jedes mal die individuelle Konfiguration auseinandernehmen. Das Feature was du meinst ist aber drin - Beispiel gibt es im anderen 3.5.4 Thread.

@Stefan vor ca. 30 Minuten

@Revo Das Online-Installationsscript läuft noch nicht - wir arbeiten dran.

@Stefan, das habe ich mir fast schon gedacht, macht ja nichts war nur ein Test für einen neuen Shop, werde ihn manuell installieren!!

wann wird denn das Online Installationsscript verfügbar sein für 3.5.4? Gruß Kay

[quote=„Lifestyle2010“]wann wird denn das Online Installationsscript verfügbar sein für 3.5.4? Gruß Kay[/quote] Leute, nun drängelt doch nicht so… Die Welt dreht sich auch ohne 3.5.4 jetzt und gleich weiter…

logisch. aber es soll daraus ein neuer shop entstehen und den plante ich schon mai bei den ersten ankündigungen. verständlich das die ungeduld wächst. der alte shop verbleibt auch erstmal so. nur beim neuen soll es schnell gehen, da ich auch nicht mehr so viel zeit habe wie jetzt. Gruß Kay

@Lifestyle2010, warum machst du denn keine manuelle Installation? Es ist ja keine Arbeit die drei änderungen in der SQL-DB selber zu machen, und ein paar Verzeichnisse per Hand auf 777 zu setzen!

wenn ich weiß wie auch nicht das problem. probiere es nachher mal.

Das Online-Installer Script funktioniert nun .

Hab die neue Version auf meinem Testsystem aufgespielt. Nun bin ich auf die Widgets, das neue Ticketsystem und den neuen Plugin Manager gespannt :slight_smile: Erhalte leider folgende Fehlermeldung, Backend und Frontend: [quote]Strict Standards: Declaration of Enlight_Template_TemplateManager::__call() should be compatible with that of Smarty::__call() in /www/htdocs/XXX/engine/Enlight/Enlight/Template/TemplateManager.php on line 3[/quote] Sql-File eingespielt und Daten habe ich binär auf den Server übertragen. Wird einer von euch schlau daraus? :frowning:

[quote=“Stefan Hamann”]Das Online-Installer Script funktioniert nun .[/quote] Also ich habs einmal versucht manuell zu update und einmal hab ich grad das System komplett neu aufgesetzt, bei beiden Varianten kann ich mich nicht einloggen, er laedt zwar zeigt mir dann aber sofort wieder das Einloggsrcipt an.

Kannst du mal einmal Cookies löschen und es dann erneut probieren? Hast du irgendwelche Firefox Plugins aktiv, z.B. Webdeveloper Toolbar oder so?

1 Like

@Michael_F Das neue Ticketsystem kommt als Plugin in Kürze in den Store - das ist also nicht im 3.5.4. Package per default enthalten. Kannst du einmal den Ordner www/htdocs/XXX/engine/Enlight/Enlight/ komplett mit dem aus dem Installationspackage ersetzen - eventuell hast du aus vorherigen Releases noch ältere Dateien dort bzw. irgendein Update nicht komplett durchgeführt? Ansonsten könntest du den Fehler auch umgehen, in dem du das E_STRICT aus der application.php entfernst - aber das wird vermutlich nicht das einzige Problem bleiben, wenn tatsächlich noch ältere Dateien im System sind.

[quote=“Stefan Hamann”]Kannst du mal einmal Cookies löschen und es dann erneut probieren? Hast du irgendwelche Firefox Plugins aktiv, z.B. Webdeveloper Toolbar oder so?[/quote] Wie dumm von mir. Daran lag es, vielen Dank

An den Cookies? Kannst du wegen der Plugins trotzdem mal schauen? Hast du da irgendwas spezielles aktiv?

Ich habe jetzt die komplett saubere Installation genommen. Haette ich ja eh neu machen muesse, weil ich mir doch da was zerschossen hatte wegen dem Grundpreis und den Variablen. Es lag an den Cookies