SEO URLs? Doppelte "title"-Tags, Doppelte Metabeschreibungen

Hallo zusammen, Anfang August dieses Jahres habe ich die Shopware 3.5.4 installiert, und die ersten 3 Wochen hat sich mein Ranking bei Google spürbar verbessert, und die Besucherzahlen haben sich erhöht. Nun passiert das Gegenteil davon, immer mehr Seiten verschwinden aus dem Google Index und die Auffindbarkeit meiner Seiten hat sich extrem verschlechtert. Was ist passiert?? Bei Google Webmaster Toll sind viele Doppelte Metabeschreibungen und Doppelte “title”-Tags, liegt das damit zusammen? Wird man hier vom Google abgestraft? Zum Beispiel für einen Artikel oder Kategorie gibt es mehrere Seiten die Google findet: Kategorie1-Lang?language=de&%3Fper_site=100&?view_as=product_listing_grid Kategorie1-Lang?language=de&%3Fper_site=30&?per_site=100 Kategorie1-Lang?language=de&%3Fper_site=30&?per_site=10 Kategorie1-Lang?language=de&%3Fper_site=30&?view_as=product_listing_grid Kategorie1 Das ist ein Beispiel für eine Kategorie! Manche Artikel Adresse sehen so aus: /0Muster-Artikel.html /Muster-Artikel.html?XTCsid=48c8a3d55677096e4f2b8385e2aeb629 /Muster-Artikel.html?XTCsid=49d321d0f257a2487241985fe323e933 /Muster-Artikel.html Das sind 4 verschiedene Seiten für ein Artikel, dass das Google nicht gefällt ist mir klar. Das sind doch keine echte Seo Urls, wieso werden die so ausgegeben und von Google gefunden? Ich bin immer noch weniger als ein Shopware Anfänger ich habe überhaupt keine Ahnung was hier los ist? Was kann ich machen damit bei Google die Seiten nicht gefunden werden?

Das sieht aber überhaupt nicht nach Shopware-Urls aus? Läuft da eventuell noch ein Xt-Commerce parallel?

Nein, XTCommerce ist vor der Shopware installation auf dem Server gelaufen. Der Shop wurde jedoch komplett gelöscht, auch die Datenbank. Link zu Webseite: www.budokatana.de

Was kann ich tun? Ist es möglich über Google Webmaster Tool die URL-Parameter so zu konfigurieren, dass Google die Seiten ignoriert, oder gibt es noch andere Möglichkeit? Bitte helft mir!

das mit der XTC-ID in der URL habe ich auch - mich hatte das nur kurz gewundert, in der Annahme das muss so :confused:

Hi, wie Stefan schon geschrieben bzw. vermutet hat, die Links die hier aufgelistet werden haben nichts mit Shopware zu tun. Das sind alte Links, die Google früher bei euch erfasst hat. Die sind bei euch noch aus der Zeit wo ihr XT-Commerce eingesetzt habt. Kategorie1-Lang?language=de&%3Fper\_site=30&?per\_site=100 /Muster-Artikel.html?XTCsid=48c8a3d55677096e4f2b8385e2aeb629 Das sind klare Links aus XTC und nicht von Shopware. Bei Shopware sehen diese ganz anders aus. @Testman: Die wirst jetzt sicher abgewertet bzw. sind deine Seite beim Index rausgeflogen, da Google die alten Links von XT ja alle nicht mehr aufrufen kann. Das ist dann also völlig normal, wenn die alten Links nicht SEO-freundlich umgeleitet werden.

Hallo Harald, das ist so nicht ganz richtig. Die Seiten sind alle Aufrufbar, und das dürfte doch gar nicht sein. Wenn ich im Browser /Muster-Artikel.html?XTCsid=48c8a3d55677096e4f2b8385e2aeb629 angebe, dann öffnet der Browser diesen Artikel, der auch unter /Muster-Artikel.html zu finden ist, und diese Adresse bleibt im Fenster sichtbar, wird nicht umgeleitet oder so. Bei der Kategorien ist genau das gleiche. Also wenn das alte Commerce Links seien sollten, wieso können die aufgerufen werden? Es müsste sich doch um 404 Fehlerseiten handeln, das sind sie aber nicht.

[quote=„Testman“]Hallo Harald, das ist so nicht ganz richtig. Die Seiten sind alle Aufrufbar, und das dürfte doch gar nicht sein. Wenn ich im Browser /Muster-Artikel.html?XTCsid=48c8a3d55677096e4f2b8385e2aeb629 angebe, dann öffnet der Browser diesen Artikel, der auch unter /Muster-Artikel.html zu finden ist, und diese Adresse bleibt im Fenster sichtbar, wird nicht umgeleitet oder so. Bei der Kategorien ist genau das gleiche. Also wenn das alte Commerce Links seien sollten, wieso können die aufgerufen werden? Es müsste sich doch um 404 Fehlerseiten handeln, das sind sie aber nicht.[/quote] Ich finde das nicht so verwunderlich. Die Seiten-URL ist identisch geblieben, nur die GET-Parameter ab ? sind anders. Wenn es Shopware wurscht ist, was an GET-Parametern am URL-String hängt und die Seite nur dann modifiziert anzeigt, wenn ein verwertbarer Parameter mitkommt, ansonsten die Standard-Seite anzeigt, ist das so völlig in Ordnung. Du solltest in den Webmaster-Tools den GET-Parameter XTCsid ignorieren lassen.

1 Like

[quote=“tschersich”][quote=“Testman”]Hallo Harald, das ist so nicht ganz richtig. Die Seiten sind alle Aufrufbar, und das dürfte doch gar nicht sein. Wenn ich im Browser /Muster-Artikel.html?XTCsid=48c8a3d55677096e4f2b8385e2aeb629 angebe, dann öffnet der Browser diesen Artikel, der auch unter /Muster-Artikel.html zu finden ist, und diese Adresse bleibt im Fenster sichtbar, wird nicht umgeleitet oder so. Bei der Kategorien ist genau das gleiche. Also wenn das alte Commerce Links seien sollten, wieso können die aufgerufen werden? Es müsste sich doch um 404 Fehlerseiten handeln, das sind sie aber nicht.[/quote] Ich finde das nicht so verwunderlich. Die Seiten-URL ist identisch geblieben, nur die GET-Parameter ab ? sind anders. Wenn es Shopware wurscht ist, was an GET-Parametern am URL-String hängt und die Seite nur dann modifiziert anzeigt, wenn ein verwertbarer Parameter mitkommt, ansonsten die Standard-Seite anzeigt, ist das so völlig in Ordnung. Du solltest in den Webmaster-Tools den GET-Parameter XTCsid ignorieren lassen.[/quote] Danke für den TIPP, das habe ich bereits gestern gemacht jetzt muß ich wohl abwarten.