Probleme mit der Installation (Internal Server Error)

Hallo, wie du der Überschrift entnehmen kannst, habe ich Probleme mit der Installation des Shops bzw. start die überhaupt nicht. Ich habe alle möglichen Versuche gestartet und schon einige Stunden investiert :slight_smile: Hier meine Vorgehensweiße: Shopwaredaten (ungepackt) auf den Webspace hochladen(Binarymode) Dann die Domain/install in den Browser tippen. Der Webspace ist wie nach den Vorgaben eingestellt(zeigt mir das Checktool an) Die einzigen Punkte wo er meckert sind, bei dem Zend-Tool und Ioncube sowie MYSQL. Der Server hat verschiedene Datenbanken aber nur eine, die für den Shop vorgesehen ist hat die aktuelle Version. Was mich stutzig macht ist unter Shopware Verzeichnisse (Bitte setzten Sie bei diesen Ordnern die Dateirechte rekursiv auf 777, da Shopware ansonsten nicht ordnungsgemäß lauffähig ist.) Vor allem, weil die Ordner nicht vorhanden sind. Und unter Shopware-Dateien, weil die komplett Rot sind.(Achtung, wenn die Überprüfung fehlschlägt, liegt es wahrscheinlich daran, dass die Dateien nicht richtig hochgeladen wurden. Die Dateien müssen dann nochmal im Binary-Mode hochgeladen werden. ) Also wenn du mir helfen kannst, dann freue ich mich auf deinen Post. Beste Grüße Andreas

Schade, dass noch keiner eine Idee hat woran es liegen kann. Sagt mal brauche ich für Shopware einen SSH-Zugang? Beste Grüße Andreas

SSH Zugang brauchst du nicht, aber solltest du haben - weil es einfach viel eleganter und schneller geht, auf dem Server Änderungen vorzunehmen. Mit „Internal Server Error“ kommen wir aber nicht weiter. Mach doch bitte mal folgendes: - schau in deine Server-Log Dateien, was da drinsteht und poste das hier - mach mal einen Screenshot vom Installtool und zeig uns den auch. Wenn MySQL beispielsweise rot ist, ist das ein sehr schlechtes Zeichen … lg

Danke für deine Antwort shredding. hier der Link zum Screenshot: Und hier der ein Auszug der Logdatei: 0 /kunden/286701_53498/landlaecheln-shop.de/install/assets/javascript/bootstrap.min.js [19.07.2013 13:51:48] 51e91fb0.468d 286701-ftp 91.35.167.111 U 92556 1 /kunden/286701_53498/landlaecheln-shop.de/install/assets/javascript/jquery-1.8.0.min.js [19.07.2013 13:51:49] 51e91fb0.468d 286701-ftp 91.35.167.111 U 5412 0 /kunden/286701_53498/landlaecheln-shop.de/install/assets/javascript/jquery.installer.js [19.07.2013 13:51:49] 51e91fb0.468d 286701-ftp 91.35.167.111 U 6336 0 /kunden/286701_53498/landlaecheln-shop.de/install/assets/lang/de.php [19.07.2013 13:51:49] 51e91fb0.468d 286701-ftp 91.35.167.111 U 5934 0 /kunden/286701_53498/landlaecheln-shop.de/install/assets/lang/en.php [19.07.2013 13:51:50] 51e91fb0.468d 286701-ftp 91.35.167.111 U 12243 0 /kunden/286701_53498/landlaecheln-shop.de/install/assets/php/Index.php [19.07.2013 13:51:50] 51e91fb0.468d 286701-ftp 91.35.167.111 U 1535 0 /kunden/286701_53498/landlaecheln-shop.de/install/assets/php/Path.xml [19.07.2013 13:51:50] 51e91fb0.468d 286701-ftp 91.35.167.111 U 1154 0 /kunden/286701_53498/landlaecheln-shop.de/install/assets/php/Shopware_Components_Dump.php [19.07.2013 13:51:51] 51e91fb0.468d 286701-ftp 91.35.167.111 U 8691 0 /kunden/286701_53498/landlaecheln-shop.de/install/assets/php/Shopware_Install_Configuration.php [19.07.2013 13:51:51] 51e91fb0.468d 286701-ftp 91.35.167.111 U 7349 0 /kunden/286701_53498/landlaecheln-shop.de/install/assets/php/Shopware_Install_Database.php [19.07.2013 13:51:51] 51e91fb0.468d 286701-ftp 91.35.167.111 U 12185 0 /kunden/286701_53498/landlaecheln-shop.de/install/assets/php/Shopware_Install_License.php [19.07.2013 13:51:52] 51e91fb0.468d 286701-ftp 91.35.167.111 U 11874 0 /kunden/286701_53498/landlaecheln-shop.de/install/assets/php/Shopware_Install_Requirements.php [19.07.2013 13:51:52] 51e91fb0.468d 286701-ftp 91.35.167.111 U 3554 0 /kunden/286701_53498/landlaecheln-shop.de/install/assets/php/Shopware_Install_Requirements_Path.php [19.07.2013 13:51:52] 51e91fb0.468d 286701-ftp 91.35.167.111 U 4548 0 /kunden/286701_53498/landlaecheln-shop.de/install/assets/php/System.xml [19.07.2013 13:51:53] 51e91fb0.468d 286701-ftp 91.35.167.111 U 11208 0 /kunden/286701_53498/landlaecheln-shop.de/install/assets/sql/en.sql [19.07.2013 13:52:07] 51e91fb0.468d 286701-ftp 91.35.167.111 U 791266 14 /kunden/286701_53498/landlaecheln-shop.de/install/assets/sql/sw4_clean.sql [19.07.2013 13:52:08] 51e91fb0.468d 286701-ftp 91.35.167.111 U 82978 1 /kunden/286701_53498/landlaecheln-shop.de/install/assets/styles/bootstrap.min.css [19.07.2013 13:52:08] 51e91fb0.468d 286701-ftp 91.35.167.111 U 9719 0 /kunden/286701_53498/landlaecheln-shop.de/install/assets/styles/styles.css [19.07.2013 13:52:09] 51e91fb0.468d 286701-ftp 91.35.167.111 U 2828 0 Danke für deine Hilfe!

Hey, okay, das ist die falsche Log Datei, ich meinte den Error Log. Bist du dir zunächst mal sicher, dass du das korrekte System Check Tool runtergeladen hast, und nicht das für Shopware 3.5? Die PHP Version, die da als benötigt angegeben wird ist nicht richtig (Shopware braucht mind. 5.3.3) und das mit MySQL ist auch nicht ganz korrekt … Kannst du das bitte mal verifizieren? Richtig wäre das hier: http://wiki.shopware.de/Systemcheck-Too … l_894.html

1 Like

Guten Morgen, das mit der falschen Ceck-Datei war ein super Tipp. Jetzt liegt es nur noch an 3 Sachen: ionCube Loader 4.0.2 0 Auf den Server ist zur Zeit “Zend” installiert, reicht der aus? suhosin.get.max_value_length 2000 0 mod_rewrite 1 0 Die kann ich ja, leicht ändern. Ich teste es gleich aus und gebe dann Feedback. Danke dir!.

Den ionCube Loader brauchst du nur, wenn du verschlüsselte Plugins nutzen willst. PHP ist eine offene Scriptsprache und wenn du Extensions kaufst, kriegst du auch immer den Quellcode. Einige Anbieter sind da irgendwie paranoid und wollen den Code verschlüsseln und da kommt ionCube ins Spiel, der das macht. Meiner persönlichen Meinung nach sollte man das nicht installieren. Du hast keinen Einfluss mehr darauf, was die Extensions machen, ob sie nach Hause telefonieren oder sonst wie in dein System eingreifen. Es gibt ja schon einen Grund, warum du dich für Open Source entschließt, und wenn du dir so was wie ionCube installierst, hättest du ja auch von Anfang an ein proprietäres, geschlossenes System nehmen können.