Neuer Reiter für Produkteigenschaften

Hat vielleicht schon jemand eine Lösung in petto für einen zusätzlichen Reiter im Emotion Template neben dem Tab “Beschreibung” der die “Eigenschaften” des Produktes auflistet? Wäre super nett wenn hier jemand vielleicht ein paar Codes zur Verfügung stellen könnte. Die Lösung für Shopware 3.5 die hier im Forum ist hilft mir irgendwie nicht weiter :frowning:

Hallo, würde mich auch dringend interessieren…

das würde uns auch weiterhelfen :slight_smile:

brauchen wir auch ganz dringend !!!

Hallo beide zusammen, hier gibt es eine Beschreibung als Tutorial im Lab Neuer Reiter auf der Detailseite Funktioniert auch mit der 4 version. Grüße und schönen Abend COCO

[quote=“coco”]Hallo beide zusammen, hier gibt es eine Beschreibung als Tutorial im Lab Neuer Reiter auf der Detailseite Funktioniert auch mit der 4 version. Grüße und schönen Abend COCO[/quote] Hallo coco, habe es probiert und es klappt auch bei mir. Doch leider habe ich dann das Problem, dass sich die linke Spalte nicht mehr ausblendet und sich dadurch die ganzen Informationen des Artikels nach unten verschieben. Jemand eine Idee was das verursachen könnte? Danke vorab! :slight_smile:

Hallo, welche „linke Spalte“ meinst du genau? Gruß Manuel

Hallo elvitas, was meinst du den mit der Linken Seite ? den Inhalt der Beschreibung kannst du ja mit css eingrenzen und anpassen, denke ich. Mit Firebug bekommst du sehr viele hilfreiche Informationen, da musst du bissen rumprobieren. Viele Grüße COCO

[quote=„coco“]Hallo elvitas, was meinst du den mit der Linken Seite ? den Inhalt der Beschreibung kannst du ja mit css eingrenzen und anpassen, denke ich. Mit Firebug bekommst du sehr viele hilfreiche Informationen, da musst du bissen rumprobieren. Viele Grüße COCO[/quote] Ich meine die Linke Navigations-Leite, wo die Kategorien und Informationen (über uns, …) angezeigt werden. Ich denke es liegt an der index.tpl. Denn wenn ich die index.tpl aus dem my_tab oder _local Ordner lösche, dann ist das Layout ganz normal. Mit der index.tpl wird die linke Leiste angezeigt und die Artikel-Beschreibung rutscht unter diese Leiste…

Hallo, also hast du in der Detailseiten-Ansicht die linke Spalte eingefügt, die ja in der 4er Version nicht mehr vorhanden ist. Dann müsstest du die Breite der Tabs und wahrscheinlich die der ganzen Detail-Seite anpassen. Gruß Manuel

Ich hatte heute das gleiche Problem. Die Lösung habe ich eben gefunden. Es liegt offensichtlich an der Vererbung aus dem “_default”-Ordner. So gelangt anscheindend die linke Navigationsbox ungewollt in die Detailseite und zerhaut das Layout. So funktioniert es: {\* Tabnavigation des Mastertemplates erben \*} {extends file="parent:frontend/detail/tabs.tpl"} {\* Detailseite des Mastertemplates erben \*} {extends file="parent:frontend/detail/index.tpl"}

1 Like

[quote=„mtangazaji“]Ich hatte heute das gleiche Problem. Die Lösung habe ich eben gefunden. Es liegt offensichtlich an der Vererbung aus dem „_default“-Ordner. So gelangt anscheindend die linke Navigationsbox ungewollt in die Detailseite und zerhaut das Layout. So funktioniert es: {\* Tabnavigation des Mastertemplates erben \*} {extends file="parent:frontend/detail/tabs.tpl"} {\* Detailseite des Mastertemplates erben \*} {extends file="parent:frontend/detail/index.tpl"}[/quote] Hat wunderbar geklappt!!! Vielen Dank mtangazaji :thumbup:

Ich gehe davon aus, dass du aus dem _default-Ordner erbst, aber möglicherweise ein _emotion Template hast. Dann musst du die Daten aus der style.css vom _default- Ordner die dafür in Frage kommen in dein Stylesheet einbauen und bearbeiten. Ich musste, damit das alles funktioniert, die Detailseite (Breite) um 100 px verkleinern und noch so ein paar andere Zeilen Gruß wimedo

Hi, hat jemand eine Idee, wieso ich, egal welchen Namen ich für den neuen Reiter vergebe immer der Name „Neuer Reiter“ angezeigt wird? emotion_local/frontend/detail/tabs.tpl [code]{* Tabnavigation des Mastertemplates erben *} {extends file=‚parent:frontend/detail/tabs.tpl‘} {* Neuen Reiter fuer die Tabnavigation hinzufuegen *} {block name=„frontend_detail_tabs_related“ append} {if $sArticle.attr4}

  • {se name=‚DetailTabsMyTab‘}Detailansicht{/se}
    {/if} {/block}[/code] Dennoch wird, „Neuer Reiter“ im Frontend angezeigt… (sämtliche Cache wurden geleert) Und gibt es eine Möglichkeit einen formatieren Text über das Backend in den neu erstellen Reiter zu impletieren? Ein entsprechende Artikel-Freitext wurde eingerichtet (.attr4) und wird auch angesprochen, aber leider wird sämtliche Formatierung des Textes „platt“ gemacht… Danke und Grüße

Hallo Sanjan, schau mal im Backend bei den Textbausteinen, ich vermute mal das dort “Neuer Reiter” steht. Einfach da in der Suche eingeben. Welchen Feldtyp haste denn angegeben bei dem Attr4? Gruß Manuel

1 Like

Hi, das mit den Textbausteinen hat wunderbar geklappt, danke! Als Feldtyp habe ich Textarea bzw HTML-Feed getestet, einmal war die Formatierung weg, einmal übernimmt er nur einen geringen Teil des Text und setzt im Backend ein "

Hallo, stelle dort am besten HTML ein, da bist du denke ich am flexibelsten. Dazu musst du dann noch in der Datenbank den Typ ändern. Die Tabelle ist “s_articles_attributes”, da musst du dann bei deinem Attribut den Typ auf “TEXT” ändern. Ich glaube das da standardmäßig varchar(255) hinterlegt ist. Gruß Manuel

Ein hallo an alle. Ich bin hier fleißig am mitlesen. Und ich habe alles so gemacht wie Luhner es beschrieben hat. Bei mir heist der neue Reiter Technische Daten und und nach den genannten Einstellungen kann ich auch mehr als drei Zeilen eingeben. ABER, aus irgendeinem Grund sind nach unbekannter Zeit, ohne jegliche aktive Aktion durch mich im Backend oder an der DB die Zeilen wieder reduziert auf nur noch ein paar. Also der Text wird einfach abgehackt. Dann gebe ich den wieder ein wie er gehört und das bleibt dann auch Zeit X so bis das ganze wieder von vorne los geht. Woran bitte kann das liegen.