Nach update kein login mehr möglich

Hallo,

 

nach dem Update komme ich nicht mehr ins Backend rein es scheint diese fehlercode:

Ups! Ein Fehler ist aufgetreten!

Die nachfolgenden Hinweise sollten Ihnen weiterhelfen.

An exception occurred while executing ‘SELECT t0.id AS id_1, t0.name AS name_2, t0.plugin_name AS plugin_name_3, t0.service AS service_4 FROM webcu_marketplace t0’: SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘t0.service’ in ‘field list’ in vendor/doctrine/dbal/lib/Doctrine/DBAL/DBALException.php on line 131

Stack trace:

 #0 vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(855): Doctrine\DBAL\DBALException::driverExceptionDuringQuery(Object(Doctrine\DBAL\Driver\PDOMySql\Driver), Object(PDOException), 'SELECT t0.id AS...', Array) #1 engine/Library/Doctrine/ORM/Persisters/Entity/BasicEntityPersister.php(914): Doctrine\DBAL\Connection-\>executeQuery('SELECT t0.id AS...', Array, Array) #2 vendor/doctrine/orm/lib/Doctrine/ORM/EntityRepository.php(181): Doctrine\ORM\Persisters\Entity\BasicEntityPersister-\>loadAll(Array, NULL, NULL, NULL) #3 vendor/doctrine/orm/lib/Doctrine/ORM/EntityRepository.php(164): Doctrine\ORM\EntityRepository-\>findBy(Array) #4 custom/plugins/WebcuMarketplaceConnector/Components/MarketplaceConnector.php(72): Doctrine\ORM\EntityRepository-\>findAll() #5 custom/plugins/WebcuMarketplaceConnector/Subscriber/BackendMessage.php(51): WebcuMarketplaceConnector\Components\MarketplaceConnector::getMarketplaceList() #6 [internal function]: WebcuMarketplaceConnector\Subscriber\BackendMessage-\>onBackend(Object(Enlight\_Controller\_ActionEventArgs)) #7 engine/Library/Enlight/Event/Handler/Default.php(91): call\_user\_func(Array, Object(Enlight\_Controller\_ActionEventArgs)) #8 engine/Library/Enlight/Event/EventManager.php(220): Enlight\_Event\_Handler\_Default-\>execute(Object(Enlight\_Controller\_ActionEventArgs)) #9 engine/Library/Enlight/Controller/Action.php(182): Enlight\_Event\_EventManager-\>notify('Enlight\_Control...', Object(Enlight\_Controller\_ActionEventArgs)) #10 engine/Library/Enlight/Controller/Dispatcher/Default.php(549): Enlight\_Controller\_Action-\>dispatch('indexAction') #11 engine/Library/Enlight/Controller/Front.php(222): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp)) #12 engine/Shopware/Kernel.php(215): Enlight\_Controller\_Front-\>dispatch() #13 vendor/symfony/http-kernel/HttpCache/HttpCache.php(486): Shopware\Kernel-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #14 engine/Shopware/Components/HttpCache/AppCache.php(268): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #15 vendor/symfony/http-kernel/HttpCache/HttpCache.php(253): Shopware\Components\HttpCache\AppCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true) #16 engine/Shopware/Components/HttpCache/AppCache.php(105): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>pass(Object(Symfony\Component\HttpFoundation\Request), true) #17 shopware.php(122): Shopware\Components\HttpCache\AppCache-\>handle(Object(Symfony\Component\HttpFoundation\Request)) #18 {main}

 

 

Sollte ich am besten den Back-up wieder einspielen ?

Oder kann man das auch manuell reparieren ?

 

Vielen Dank

 

MfG

Hallo, ich habe die selbe Fehlermeldung.

Gibt es noch eine Rettung?

Vielen Dank

Hallo,

ich konnte das Problem lösen in dem ich ein Backup eingespielt habe.
Schuld an der Misere war wohl das Plugin „webcu_marketplace“, dass wohl nicht ganz kompatibel zur aktuellen Version ist.

MfG

@Waterman333 schrieb:

Hallo,

ich konnte das Problem lösen in dem ich ein Backup eingespielt habe.
Schuld an der Misere war wohl das Plugin “webcu_marketplace”, dass wohl nicht ganz kompatibel zur aktuellen Version ist.

MfG

          Es hat schon seinen Grund warum man vor dem Upgrade alle Plugins deaktivieren und auf konformität prüfen solte.