Mein Shop ist ständig dauerhaft down...

Hallo,

ich bekomme ständig folgende Fehlermeldung, wenn ich meinen Shop aufrufe… oder aber das Bild wird weiss und es wird gar nichts angezeigt:

Fatal error: Uncaught exception ‚Zend_Db_Adapter_Exception‘ with message ‚SQLSTATE[42000] [1226] User ‚******‘ has exceeded the ‚max_user_connections‘ resource (current value: 20)‘ in /var/www/web123876/html/shop/engine/Library/Enlight/Components/Db/Adapter/Pdo/Mysql.php:101 Stack trace: #0 /var/www/web123876/html/shop/engine/Library/Zend/Db/Adapter/Abstract.php(316): Enlight_Components_Db_Adapter_Pdo_Mysql->_connect() #1 /var/www/web123876/html/shop/engine/Library/Zend/Db/Adapter/Pdo/Abstract.php(263): Zend_Db_Adapter_Abstract->getConnection() #2 /var/www/web123876/html/shop/engine/Shopware/Components/DependencyInjection/Bridge/Db.php(45): Zend_Db_Adapter_Pdo_Abstract->exec(‚SET @@session.s…‘) #3 /var/www/web123876/html/shop/cache/proxies/Shopware201504021339ProductionProjectContainer.php(146): Shopware\Components\DependencyInjection\Bridge\Db->factory(‚pdo_mysql‘, Array) #4 /var/www/web123876/html/shop/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Container.php(326): Shopware201504021339Pro in /var/www/web123876/html/shop/engine/Library/Enlight/Components/Db/Adapter/Pdo/Mysql.php on line 101

Vom Webhoster wurde das Limit für die Zugriffe bereits auf 20.000 erhöht, jedoch gibt es weiterhin diese Probleme. Mir wurde gesagt, dass es auf Netzwerkangriffe zurückzuführen sein könnte oder an irgendeinem fehlerhaften Script liegt. Das Problem ist, dass der Shop, selbst wenn er mal verfügbar ist, dermaßen lahm ist, dass eine normale Bearbeitung im Backend schon fast unmöglich ist.

An was könnte es denn noch liegen? Ich bin mit meinem Latein am Ende. Da ich momentan überhaupt keinen Zugriff auf meine Seite habe, kann ich auch nicht sagen, welche Shopware Version ich installiert habe. An ein Update habe ich mich bisher noch nicht heran getraut, weiss auch gar nicht, wie das funktioniert. Vielleicht könnt Ihr mir da auch ein wenig helfen.

Danke im voraus.

Der Hoster sollte doch sehen an den Access Logs und Error Logs wo die Aufrufe her kommen.

ich hatte vor kurzem 2 Aggresive Bots auf dem Shop welcher die Load bis 20 trieb! ein IP Ban hat geholen.

@derkosta schrieb:

Der Hoster sollte doch sehen an den Access Logs und Error Logs wo die Aufrufe her kommen.

ich hatte vor kurzem 2 Aggresive Bots auf dem Shop welcher die Load bis 20 trieb! ein IP Ban hat geholen.

Genau das habe ich dem Hoster auch mitgeteilt, aber der sagt, er könne das nicht einsehen. :frowning: Es kommt ja noch erschwerend hinzu, dass auch meine anderen Seiten dann down sind. Was ich eigentlich gar nicht verstehe. Die liegen zwar auf dem gleichen Server und beim gleichen Hoster, aber unter anderen Domains. Hatte ja schon drauf getippt, dass es am Server liegt… Denn bereits vor Erstellung des Shops, gab es ständig diese Probleme, da aber mit Wordpress.

Habe soeben mal probiert, mich in meine Datenbanken einzuloggen, auch das funktioniert nicht mehr. Für mich ein Zeichen, dass es am Webhoster bzw. Server liegt, oder nicht? Es kam ja schon öfter vor, dass die Seiten eine Stunde down waren, aber heute dauert das Ganze schon seit den frühen Morgenstunden an.

In der Fehlermeldung steht es auch drinn:

‘max_user_connections’ resource (current value: 20)’

Die Einstellung ist derzeit auf 20 Maximale User Verbindungen stehend. Ein Fall für deinen Hoster die Variable der “max_user_connection” (Mal in der Mysql my.cnf schauen) mal ordentlich nach oben zu stellen.

Außer dein Hosting Paket welches du hast gibt nicht mehr her. Dann den Hoster wechseln oder auf ein Höheres Paket wechseln.

Welche Variable hat denn dein Hoster auf angeblich 20.000 gestellt?

@matthiasftl‍ Das weiss ich nicht. :frowning: Letzte Woche schrieb man mir nur, dass von 15.000 auf 20.000 umgestellt bzw. erhöht wurde.
Wie gesagt, ich komme nun auch nicht mehr in meine Datenbanken auf besagtem Server. Ich hätte ja schon längst gewechselt, bekomme aber meine Daten aus 5 Webseiten nicht gesichert, weil der Server immer dermaßen lahmt, dass jegliche Sicherungen abbrechen.

Ach ja, ich habe das Web PROFI Paket hier: http://flatbooster.com/de/webhosting

@catsimo schrieb:

Ach ja, ich habe das Web PROFI Paket hier: http://flatbooster.com/de/webhosting

Server Power : 128M ?

Systemanforderungen für Shopware 5 > http://community.shopware.com/Systemanforderungen_detail_1840.html#PHP-Extensions_.2F_Webserver

Webserver/PHP-Einstellungen

  • memory_limit > 256M*

 das ist bei Dir echt ein bisschen wenig, wenn du nur das Web “Profi” Paket hast.

Gruß Uwe

Beim nächst größeren bzw. größten Paket des Hosters wären es 256M und das Feature Dual-Hosting stünde auch zur Verfügung.
Ob sich dadurch wohl was ändern würde?

Die Preise sind natürlich unschlagbar günstig - aber für eine Shopware Instanz solltest du tatsächlich mehr investieren. Hier würde ich mich an einen der vielen Shopware Partner wenden, die sich im Bereich Hosting (unter anderem) auf Shopware spezialisiert haben. Für ein paar Euro mehr im Monat solltest du keine Probleme und Kopfschmerzen mehr haben.

Viele Grüße

Halte dich von solchen Hostern fern und setze lieber auf verifizierte Shopware Hoster, die sind jeden Cent wert. Viel würde sich mit einem höheren Paket bei deinem jetzigen Hoster nicht ändern, mit Sicherheit ist der Shopwre auch durchschnittlich langsam, vor allem im Backend.

@all, das bringt dem User herzlich wenig, wenn Ihr alle gegen den Hoster was sagt. Ich habe denke ich die Lösung seines Problems bereits hier kund getan, er muss auf seinen Hoster zugehen und in der MySQL Config den Wert für die maximalen Userzugriffe von derzeit eingestellten Wert von 20 mal erhöhen.

Den Wert vom dem hier gesprochen wird, irgendwas auf 20.000 wird die Frage sein, welchen Wert und wo was hochgestellt wurde. Werte gibt es auf dem Server egal, ob im Apachen, PHP oder Mysql zu hauf zu erhöhen.

Also, ran an den Hoster.

@all, das bringt dem User herzlich wenig, wenn Ihr alle gegen den Hoster was sagt

Das sehe ich ein wenig anders. Hier geht es um ein Problem und die Lösung dazu. Ein Problem an der Wurzel anzupacken ist immer die richtige Vorgehensweise.

@steinsoftware‍ , hast du denn die Lösung für das Problem? Im Moment wird doch hier im  Post nur gegen den Hoster gegangen, mein Post war die Lösung für das Problem, also.

@matthiasftl schrieb:

@steinsoftware‍ , hast du denn die Lösung für das Problem? Im Moment wird doch hier im  Post nur gegen den Hoster gegangen, mein Post war die Lösung für das Problem, also.

Du musst doch aber erst mal die Systemvoraussetzung schaffen damit Shopware laufen kann, es ist das gleiche als wenn du mit einem alten Pc unbedingt die neusten Spiele spielen willst und fragst dann in einem anderen Forum warum es nicht geht. 

Ich zB. bin bei auch bei einem Provider und da sind auch nicht super Voraussetzungen, wie sich es manche so vorstellen, aber Shopware läuft da ohne Probleme und für meinen Zweck auch ausreichend.

Hast du mal in den Einstellungen > Systeminfo geschaut ob das alles im „grünen“ Bereich ist?

Gruß Uwe

1 Like

Also ich hatte auch mit dem Shopaufbau bei einem Anbieter mit einem Memorylimit 128 begonnen - weil dort eben schon andere Webseiten von mir liefen. Der Shop war dann zwar erreichbar, aber derart langsam, dass man es keinem User zumuten konnte. Bin dann nach Empfehlungen hier im Forum gewechselt und jetzt super zufrieden. Nicht nur der Shop läuft flott, auch der Kundenservice ist einfach top. Habe derzeit 2 SW Shops und 3 Webseiten dort laufen, 2 weitere Webseiten ziehen in zwei Monaten auch um.

Die Kosten sind absolut im Rahmen und das Geld ist an der Stelle gut investiert.

Also selbst wenn du es durch die Tipps hier schaffst, den Shop dauerhaft erreichbar zu machen, fürchte ich, dass er ebenso langsam daherkrabbelt, wie meiner beim alten Hoster. Nebenbei finde ich bedenklich, dass du die Daten nicht gescheit sichern kannst, weil der Server zu langsam ist…