Lieferadresse nicht akzeptiert: "Bitte beachten Sie, dass wir die aktuell gewählte Lieferadresse"...

Nach einem Update von 5.4.3 auf 5.5.4 bzw. 5.5.6 bekommen Kunden im Menü “Mein Konto” folgenden Hinweis:
“Bitte beachten Sie, dass wir die aktuell gewählte Lieferadresse nicht beliefern, bitte ändern oder erstellen Sie ggf. eine neue Lieferadresse.”

Das betrifft ALLE Kunden, egal ob sie eine von der Rechnungsadresse abweichende Lieferadresse eingetragen haben oder ob das Feld “Lieferadresse” komplett leer ist.

Egal, was man ändert, die Fehlermeldung bleibt.

Bestellungen sind mit diesen Daten problemlos durchführbar, die Meldung erscheint nur, wenn man auf “Mein Konto” klickt. Deutschland ist als Lieferland zugelassen.

Das gleiche Problem haben wir sowohl unter 5.5.4 als auch 5.5.6.

Wir sind ratlos, weiß vielleicht jemand mehr?

Vielen Dank!

Georg

Schau mal in die Länder-Konfiguration.

Dort kannst du sagen, welche Länder zur Lieferung freigegeben sind. Vielleicht hast du auch zweimal Deutschland in der Länder-Liste.

Eine andere Funktion die das macht, gibt es nicht.

Ggf. noch das „Plugin“ für < SW 5.5.3 installiert, und darin im Freitext das Land auf aktiv gesetzt, aber im " echten" Feld ab 5.5.3 nicht ?

@Moritz Naczenski schrieb:

Schau mal in die Länder-Konfiguration.

Dort kannst du sagen, welche Länder zur Lieferung freigegeben sind. Vielleicht hast du auch zweimal Deutschland in der Länder-Liste.

Eine andere Funktion die das macht, gibt es nicht.

Hallo Moritz,

super, dass du noch aktiv bist.

Eigentlich ist in der Länder-Konfig alles gut, ich kann da kein Problem finden:

@sonic schrieb:

Ggf. noch das “Plugin” für < SW 5.5.3 installiert, und darin im Freitext das Land auf aktiv gesetzt, aber im " echten" Feld ab 5.5.3 nicht ?

Auch dir danke für deine Antwort!
Nein, das “Plugin” hatten wir nicht im Einsatz. Wir kamen ja von 5.4.3.

Die Meldung kommt aus dem Template frontend/account/index.tpl:

        {* Shipping error message *}
        {block name=“frontend_account_index_shipping_country_error_message”}
            {if !$sUserData.shippingaddress.country.allowShipping}
                {include file=“frontend/_includes/messages.tpl” type=“error” content="{s name=“AccountShippingCountryNotAllowed”}{/s}"}
            {/if}
        {/block}

Unsere Kunden kommen aus Deutschland und den Nachbarländern, alle sind für den Versand freigegeben.

Weiß vielleicht jemand, wo und warum $sUserData.shippingaddress.country.allowShipping gesetzt (bzw. nicht gesetzt) wird?

Das ist einfach nur der Haken den du in den Grundeinstellungen setzt. Das hängt direkt mit am Land. Würde mal Plugins deaktivieren und nochmal ohne testen. Ansonsten mal in der Datenbank schauen in der s_core_countries ob die Spalte passt.

1 Like

Moritz, ich danke dir!

Das war tatsächlich ein Plugin, natürlich für 5.5.6 freigegeben. Ich werde nun sofort den Hersteller informieren.

Nochmals danke und gute Nacht!

Georg

Das war tatsächlich ein Plugin, natürlich für 5.5.6 freigegeben. Ich werde nun sofort den Hersteller informieren.

 

Mail ist angekommen :slight_smile: und neue Version bereite ich heute vor. Ja beim Plugin war auch die Funktion “Automatische Bugfix-Versions-Kompatibilität” aktiviert, somit wurde es automatisch für 5.5.6 mit freigegeben, was dieses mal aber zu einem Fehler führte. 

Welches Plugin hat den Fehler erzeugt? Wir haben das gleiche Problem. Ich finde aber nicht den “Schuldigen”.

Habe dir eine PM geschickt, möchte hier niemanden an den Pranger stellen.

@georgy93 schrieb:

Habe dir eine PM geschickt, möchte hier niemanden an den Pranger stellen.

@georgy93, magst Du mir da auch mal eine PM senden. Habe denselben Effekt  - danke!

Viele Grüße
Pedda

Hallo,

ich habe zwischenzeitlich mehrere ähnliche Anfragen bekommen, in allen Fällen war aber das seinerzeit bei mir verwendete Plugin nicht die Ursache.

Deswegen und weil der Autor den Fehler SOFORT nach unserer Meldung behoben hat (danke für die schnelle Reaktion) schreibe ich es mal hier rein:

Bei uns war das „DK Autologin 2.0.6“ die Ursache. Mit Version 2.0.7 war der Fehler dann behoben.

Viele Grüße!

Georg