Kundennummer nicht im Kundenkonto??

Hallo, Ist es wirklich so, dass der Kunde in seinem Kundenkonto, seine Kundennummer nicht sieht, oder ist bei mir auf die lokale Installation nur so??? Gruß

Das ist korrekt - die wird standardmäßig nicht ausgegeben. Du kannst die Ausgabe aber in frontend/account/index.tpl hinzufügen - Statt: [code]

{se name=‘AccountHeaderWelcome’}{/se}, {$sUserData.billingaddress.firstname} {$sUserData.billingaddress.lastname}

[/code] Einfach: [code]

{se name=‘AccountHeaderWelcome’}{/se}, {$sUserData.billingaddress.firstname} {$sUserData.billingaddress.lastname} (Ihre Kundennummer: {$sUserData.billingaddress.customernumber})

[/code]

1 Like

Danke Stefan! Habe gerade versucht mit Geany und Filezilla (bearbeiten und hochladen), aber Filezilla zeigt mir: Befehl: TYPE A Antwort: 200 Type set to A Befehl: PASV Antwort: 227 Entering Passive Mode (192,168,178,22,193,205). Befehl: STOR index.tpl Antwort: 550 index.tpl: Permission denied Fehler: Kritischer Dateiübertragungsfehler mache ich irgendwas falsch oder gibts etwas was ich bei .tpl-datei beachten muß? Muss später bei css für die Ausgabe auch etwas verändert werden, oder das was du geschrieben hast reicht? Vielen Dank!

Das sollte reichen - müsstest du dir dann mal im Frontend ansehen, ob die Styles soweit passen! Dann haben die Dateien bei dir die falschen Rechte - die müssten 644 haben, eventuell mal deinen Hoster ansprechen! Wenn du die per FTP hochgeladen hast, solltest du die auch wieder runter laden dürfen :slight_smile:

Danke! Der Shop ist bei mir noch lokal installiert - die Shopware VMware Image??? Gruß

Du hast das Image - dann logge dich mal per Putty dort ein. Dann cd /var/www/ und dort einfach chmod 777 -R * - das ist zwar nicht die optimale Lösung, aber für das lokale VMWare-Image tut das. Es kommt übrigens nächste Woche noch eine aktualisierte Version - damit das korrekt funktioniert, musst du aktuell noch sendmail nach installieren, steht aber auch im Wiki-Artikel!

Danke Stefan! Putty kenne ich noch nicht genau (vieleicht muss ich dann Morgen ausprobieren)! Aber das mit Filezilla verstehe ich nicht - die Dateien werden heruntergeladen (dann bearbeite ich die) und dann beim hochladen wieder auf dem Server, zeigt mir den oben genannten Fehler - komisch? Gruß

Das liegt daran, dass diese Dateien in der VM die falschen Rechte haben - du kannst ja auch mit VMWare-Player direkt auf die Linux Shell - Putty brauchst du also nicht. Dort mit root root einloggen und dann per cd /var/www [Enter] in den Doc-Root wechseln - dort dann chmod 777 -R * [Enter] - danach sollte es direkt gehen!

Hallo Stefan, vielen Dank , dass du mir bis so spät hilfst!!! Wenn ich auf die Linux Shell cd/var/www eingebe zeigt mir: No such file oder directory

Hallo, Super es hat geklappt! Ich hatte einen Tippfehler - habe vergessen die Leerzeichen nach cd :slight_smile: Die Ausgabe in dem Kundenkonto sieht dann so aus: Willkommen, Kundenname (Ihre Kundennummer: 20005) Gruß