Klassen am HTML-Tag nach Update auf Shopware 5.7.16 nicht mehr korrekt

Hallo zusammen,

nach dem Update auf Shopware 5.7.16 haben die folgenden Klassen am HTML-Tag das „has–“ verloren: cssanimations localstorage sessionstorage

Vor dem Update:

<html class="no-js has--history has--localstorage has--sessionstorage has--cssanimations is--chrome is--webkit" lang="de" itemscope="itemscope" itemtype="http://schema.org/WebPage"></html>

Nach dem Update:

<html class="js history cssanimations localstorage sessionstorage is--chrome is--webkit" lang="de" itemscope="itemscope" itemtype="https://schema.org/WebPage">

Das Problem tritt mit einem Kauftheme und mit dem Responsive Theme auf.

Vielleicht hatte jemand schon dieses Problem?
Ich finde leider nicht mal die Stelle, wo diese Klassen gesetzt werden, um nachzuschauen was da passiert.

Liebe Grüße

Auch so:

<html class="js history cssanimations localstorage sessionstorage is--chrome is--webkit" lang="de" itemscope="itemscope" itemtype="https://schema.org/WebPage">

Keine Ahnung, was nun richtig wäre :wink:

Ich nehme an, so wie vor dem Update. Einige Stylings setzen .has–cssanimations voraus.
Z.B der .form–ajax-loader - bei mir zumindest.

Da da kein Block ist, über den man da was einfügen kann, muss es von woanders herkommen.
Guck mal hier:

1 Like

Vielen Dank :slight_smile:
Wir haben also den Beweis, dass Pascal Thesing irgendwie da seine Finger im Spiel hatte :wink: :wink:
Ich weiß nur leider nicht, inwieweit diese Änderung mit meinem Problem etwas zu tun hat und wie ich es beheben kann.

Mal @P.Thesing rufen, und warten, ob er vorbeischauen mag :wink: Ggf. noch bei Slack anfragen.

Edit: Hab ihn auch auf Slack mal engesprochen und nach hier verlinkt.

1 Like

Herzlichen Dank! Hoffentlich gibt es dafür eine Lösung :crossed_fingers:

@NextMike @sonic

Leider war ich das wirklich.

Um das has-- hinzuzufügen, kannst du in der themes/Frontend/Responsive/Gruntfile.js in der modernizr Config einen classPrefix setzen.

https://modernizr.com/docs/

Ich habe dafür auch mal ein Ticket erstellt:
SW-26996

Ich wünsche euch noch schöne Festtage aus Schöppingen.

1 Like

Internes Ticketsystem? :wink:
https://issues.shopware.com/issues/SW-26996

Hi Pascal,
es müsste relativ wichtig sein, das mal zu fixen. Komme leider mit der Doku nicht klar, ich weiß nicht wo das mal hingehört:

{
  "classPrefix": "foo-",
  "feature-detects": ["dom/hidden"]
}

Gibt es seitens Shopware schon einen Anhaltspunkt, wann das gefixt werden würde?

Liebe Grüße

Recht frisch:

1 Like