Kein Backend nach Installation Shopware 4

Hallo, ich bin relativ neu in dem Bereich und versuche gerade Shopware 4 auf mein Webspace zu installieren. Ich habe auf dem Webspace Prestashop laufen und wollte jetzt auf Shopware wechseln. Ich bekomme die Installation soweit hin und das Frontend funktioniert mit Unterseiten und mod_rewrite funktioniert im Fontend auch. Allerdings habe ich kein Backend. Ich habe schon diverse Foren durchsucht und verschiedene .htaccess Varianten probiert. Ich bin langsam am verzweifeln. Der Webspace liegt bei 1&1, die php.ini ist in allen Verzeichnissen vorhanden. Es gibt allerdings auch keine Ordner “Backend” im Webspace nach der Installation. Ist das normal? Ich hoffe ihr könnt mir helfen. Vielen Dank im Voraus

Ist die .htaccess vorhanden? Ist Shopware in einem Unterverzeichnis installiert? Einen Ordner /backend gibt es nicht. Ebenso keine index.php, da das alles durch die shopware.php geregelt wird. Bekommst du einen Fehler oder nur eine weiĂźe Seite im Backend? Was sagt der php / apache o. nginx Error Log?

Hallo, ich habe Shopware in ein Unterverzeichnis „/shop“ installiert. Die Domain wird allerdings direkt auf dieses Verzeichnis verwiesen. Die .htaccess liegt ebenfalls in diesem Verzeichnis. Ich bekomme nur eine weiße Seite mit und nach einiger Zeit Fehler: Netzwerk Zeitüberschreitung. Wie komme ich an den php / apache o. nginx Error Log? .htaccess:
RewriteEngine on

RewriteBase /

Https config for the backend

RewriteCond %{HTTPS} !=on
RewriteRule backend/(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

RewriteRule shopware.dll shopware.php
RewriteRule files/documents/.* engine [NC,L]
RewriteRule backend/media/(.*) media/$1 [NC,L]

RewriteCond %{REQUEST_URI} !(/(engine|files|templates)/)
RewriteCond %{REQUEST_URI} !(/media/(archive|banner|image|music|pdf|unknown|video)/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ shopware.php [PT,L,QSA]

Fix missing authorization-header on fast_cgi installations

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

# Block access to VCS directories
RedirectMatch 404 /\.(svn|git|hg|bzr|cvs)(/|$)
# Staging-Rules start #SetEnvIf Host „staging.test.shopware.in“ ENV=staging DirectoryIndex index.html DirectoryIndex index.php DirectoryIndex shopware.php # Disables download of configuration
# Deny all requests from Apache 2.4+.

Require all denied

# Deny all requests from Apache 2.0-2.2.
<ifmodule>
    Deny from all
</ifmodule>

# Enable gzip compression
AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/json


ExpiresActive on
ExpiresDefault „access plus 1 month“
FileETag None

Header append Cache-Control „public“
Header unset ETag


# Disables auto directory index
Options -Indexes

Options -MultiViews

php_value memory_limit 128M

php_value max_execution_time 120

php_value upload_max_filesize 20M

php_flag phar.readonly off
php_flag magic_quotes_gpc off
php_flag session.auto_start off
php_flag suhosin.session.cryptua off
php_flag zend.ze1_compatibility_mode off
# AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php

Der error log liegt meist in /var/log Zusätzlich evtl. auch noch direkt in deinem FTP/home Verzeichnis. Alternativ hier einmal den Hoster nach dem Log fragen. Bei welchen Hoster bist du denn? 1und1 oder Allinkl machen manchmal ein paar Probleme. Welche PHP Version setzt du ein? mod_rewrite ist auf dem Host aktiviert? Verwendest du denn Apache oder nginx?

Hoster ist 1und1 Apache mod_rewrite ist aktiviert PHP Version 5.5 Finde auf dem FTP ein /log Verzeichnis jedoch kein error log. lediglich ftp.log und sftp.log sind vorhanden. Wenn ich das backend aufrufen will ist der link auch immer https://…. ich habe allerdings kein ssl aktiviert, könnte es damit zusammenhängen? Edit: die mod_rewrite wird in der Installation nicht erkannt sie funktioniert allerdings i im Forntend.

1 Like

Das habe ich auch schon versucht, ändert aber nichts. Das Backend bleibt unerreichbar. Allerdings ändert sich dadurch auch das https:// nicht in http://. Im Browser wird weiterhin https://www.***.de/shopware.php/backend/ angezeigt. EDIT: So nachdem ich nun SSL Aktiviert habe läuft alles. Vielen Dank für deine Hilfe!