Installation zum xten

Hallo Community, nachdem ich lokal einen Shop innert Minuten aufgesetzt habe, klappt das auf dem LiveSpace überhaupt nicht. Der Systemcheck meckert nicht - alles grün (iOnCube Version 4.0.7, PHP 5.3.5) Hab es zuerst manuell versucht, danach den Onlineinstaller versucht, das gleiche Spiel. Interessanterweise kann ich in der Installationsroutine die Datenbank, wie auch das Rootverzeichnis auswählen, die Installation läuft erfolgreich durch, trotzdem bekomme ich ->The requested URL /backend/index.php was not found on this serverYou don’t have permission to access / on this server

Hallo ! Hast du während der Installation den Lizenzvorgang ausgeführt ? http://www.pamou.ch/shopware.php Ruf den Link mal auf ! [quote]Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. Keine gültige Lizenz gefunden in Shopware/Plugins/Default/Core/Shop/Bootstrap.php on line 0[/quote] Sollte die index.php wirklich fehlen…keine Erklärung dafür…aber lade die mal per ftp hoch…was passiert dann, wenn du http://www.pamou.ch/engine aufrufst ? lg klaus

Probiere den Aufruf mal über www.deinshop.de/backend/index

[quote=“klausm”]Hallo ! Hast du während der Installation den Lizenzvorgang ausgeführt ? http://www.pamou.ch/shopware.php Ruf den Link mal auf ! [quote]Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. Keine gültige Lizenz gefunden in Shopware/Plugins/Default/Core/Shop/Bootstrap.php on line 0[/quote] Sollte die index.php wirklich fehlen…keine Erklärung dafür…aber lade die mal per ftp hoch…was passiert dann, wenn du http://www.pamou.ch/engine aufrufst ? lg klaus[/quote] Hallo Klaus, ist ja logisch, dass keine Lizenz vorhanden ist - komm ja nicht mal ins Backend da die dafür notwendige Seite nicht aufgerufen werden kann. Kann also den Lizenzierungsprozess gar nicht starten. Mittlerweile hab ich da noch ein SSL-Zertifikat mit im Spiel. Auch hab ich den Shop in ein Unterverzeichnis /shop gepackt. Die Installation verlief über den Onlineinstaller - reibungslos! Wenn ich https://www.pamou.ch/shop/engine.php aufrufe kommt folgende Meldung: --> The requested URL /shop/engine.php was not found on this server. Wenn ich https://www.pamou.ch/shop/backend/index.php aufrufe kommt folgende Meldung: --> The requested URL /shop/backend/index.php was not found on this server. Und wenn ich https://www.pamou.ch/shop/ aufrufe bekomme ich diese Meldung: --> You don’t have permission to access /shop/ on this server. Im letzten Punkt liegt also irgendwo ein Berechtigungs problem. Ich hab den Eindruck, dass diese Meldungen alle was mit falschen / fehlenden Berechtigungen zu tun hat; kann mich aber auch täuschen. Ich weiss nun nicht, wie ich das lösen kann, - oder wie ich das nun angehen soll. Will da nicht willkürlich an den Dateiberechtigungen herumschrauben.

Hi, anscheinend hat dein Server kein mod_rewrite bzw. unterstützt die .htaccess-Datei nicht. Du kannst das Backend aber über folgende Url aufrufen: https://www.pamou.ch/shop/shopware.php/backend/auth Mit dieser Url wird kein mod_rewrite im Backend mehr benötigt. Für den Frontend müsstest du dann noch in den SEO-Einstellungen die mod_rewrite-Unterstützung deaktivieren. Dann sollte das auch funktionieren. Viele Grüße Heiner

1 Like

[quote=„rocky“]Hi, anscheinend hat dein Server kein mod_rewrite bzw. unterstützt die .htaccess-Datei nicht. Du kannst das Backend aber über folgende Url aufrufen: https://www.pamou.ch/shop/shopware.php/backend/auth Mit dieser Url wird kein mod_rewrite im Backend mehr benötigt. Für den Frontend müsstest du dann noch in den SEO-Einstellungen die mod_rewrite-Unterstützung deaktivieren. Dann sollte das auch funktionieren. Viele Grüße Heiner[/quote] Genau das war’s ! Herzlichen Dank :sunglasses:

leider zu früh gefreut - komme wohl ins Backend, konnte mod_rewrite deaktivieren - aber alles bleibt beim alten. Mittlerweile hab ich schon alle Arten von Installationen durchgeführt - über den Systemcheck wird mir alles grün angezeigt (ausser bei mod_rewrite). Auch im Backend unter den Systeminfos alles auf grün. Langsam aber sicher verliere ich die Geduld :sunglasses: DB-Verbindung scheint ok zu sein. Controller und Skeleton werden auch nicht geladen hab ich gerade bemerkt. Shop wieder direkt in den Root abgelegt - egal was ich nun anstelle - Status Quo.

Kannst du mir mal deine Zugangsdaten an forum@shopware.de schicken? FTP + PHPMyAdmin + Shopware Backend Dann schaue ich mal, wo es harkt.

[quote=“Stefan Hamann”]Kannst du mir mal deine Zugangsdaten an forum@shopware.de schicken? FTP + PHPMyAdmin + Shopware Backend Dann schaue ich mal, wo es harkt.[/quote] Mail ist raus - und Danke im voraus :wink:

Wir haben doch schon längst festgestellt wo der Fehler liegt. Du hast kein mod_rewrite/keine .htaccess-Unterstützung bei dir. :wink: edit: Vielleicht fehlt auch nur die .htaccess-Datei bei dir. Laut Hoster-FAQ wird mod_rewrite in jedem Hosting-Packet unterstützt. :wink:

[quote=“rocky”]Wir haben doch schon längst festgestellt wo der Fehler liegt. Du hast kein mod_rewrite/keine .htaccess-Unterstützung bei dir. :wink: edit: Vielleicht fehlt auch nur die .htaccess-Datei bei dir. Laut Hoster-FAQ wird mod_rewrite in jedem Hosting-Packet unterstützt. ;)[/quote] Also, gemäss meinem Provider: mod_rewrite ist für sämtliche Kunden eingeschaltet, dies schon seit Jahren…Die .htaccess liegt im Original (Shopware) vor. Alles komisch…

Kann das nicht auch mit der Übertragung beim Hochladen der Dateien zusammenhängen!? Wie wurden die Daten übertragen? Binär oder ascii?

[quote=„user_one“]Kann das nicht auch mit der Übertragung beim Hochladen der Dateien zusammenhängen!? Wie wurden die Daten übertragen? Binär oder ascii?[/quote] Das Ganze wurde im binären Modus via FileZilla (neuste Version) hochgeladen.

Es klappt! Nachdem sich mein Provider mit der Sache auseinandergesetzt hat funktionierts. Auszug des Mails, bzw. die Lösung des Problems: [quote]Zusätzlich habe ich .htaccess gleich korrigiert, folgende Option war nicht erlaubt: #Options -Indexes (Indexes sind per default ausgeschaltet, änderbar via Controlpanel. Aber eben, absolut irrelevant für Shopware.) [/quote] Seit dieser Änderung klappt es nun auch im Backend :smiley: