[gelöst] Sitemap wird nicht aktualisiert

Hallo zusammen, ich habe vor ein paar Tagen manche Kategorien in meinem Shop umbenannt, und den einen oder anderen Artikel verschoben. Nun ist mir aufgefallen, dass immer noch die alte Sitemap beim Aufruf von www.meinshop.de/sitemap.xml erstellt wird. Den Cache im backend habe ich mehrmals gelöscht. Jemand eine Idee an welcher “Schraube” ich drehen muss? :slight_smile:

Hat denn wirklich niemand eine Idee? :cry: Ich glaube google wird das auf dauer nicht lustig finden :wtf: edit: Ich habe in Grundeinstellungen -> Seo/Router-Einstellungen ein paar Veränderungen vorgenommen. So habe ich z.B. die “Seo-Url Artikel Template” abgekürzt, damit die URL’s des Produktes ohne Kategorien angezeigt werden. Kann das Einfluss auf die Generierung der Sitemap haben? Muss ich in den Sitemap Dateien etwas ändern?

Hat denn wirklich niemand einen Tip?! :cry:

Habe nun den Fehler gefunden. Ich habe ganz am Anfang eine Sitemap generiert, eine Datei sitemap.xml erzeugt und diese in mein Hauptverzeichnis gepackt :quite: Nach dem ich die Datei gelöscht habe, war shopware in der Lage wieder eine aktuelle Sitemap zu generieren. Wie ich gelesen habe, gehört die sitemap.xml nicht als Datei hochgeladen, sondern wird immer dynamisch generiert. Ein Link bei den google webmastertools zu /sitemap.xml ist der einzig richtige Weg. Grüße!

2 Likes

ich hab das gleiche Problem wie Du - der Unterschied: ich hab keine sitemap.xml selbst hochgeladen ich würde wirklich gerne wissen warum Shopware steinalte Kategorien indexiert :frowning: Peter

Hallo Peter, auf zwei identische Posts habe ich dir schon geantwortet. Jetzt postest du unter den dritten Post mit dem selben Thema. Zudem ist der Post hier ur-alt. Bitte konzentriere das Problem bzw. die Anfrage am besten auf einen Post, damit auch andere einen Überblick behalten können. Danke :wink: Ich schließe den Post hier, da er auch bereits als gelöst markiert war Sebastian