Überflüssige URLs in der sitemap.xml

Hallo zusammen,

seitdem wir auf Shopware 5.5.6 aktualisiert haben, haben wir ein Problem mit der neuen Sitemap.
Hier tauchen nun URLs wie die folgende auf:

https://{shopurl}/blog/index/sCategory/64

Hier wird das Blog Layout aufgerufen mit der entsprechenden Kategoriebeschreibung. Dies wird dadurch dass sowohl die URL über den Blog Controller als auch die normale Kategorie URL in der Sitemap enthalten ist auch bei Google indexiert.

Wir wollen die genannten URLs über den Blog Controller aber nicht von Google indexieren lassen, da hier identischer Content angezeigt wird, wie auf der Kategorieseite selbst (Duplicate Content usw.)

Gibt es eine Möglichkeit das abzuschalten oder ähnliches?

Vielen Dank im Voraus.

Das gibt’s ein Ticket für Shopware Issuetracker 

Voten nicht vergessen :slight_smile:

1 Like

Ist mit 5.5.7 behoben

PS: Hab das Ticket geschlossen

1 Like

Also auch nach dem Update auf Version 5.5.7 (aktuell nur im Dev-System) enthält die Sitemap nach wie vor diverse unnötige Adressen wie die folgende:

        https://www.shopwareshop.de/blog/index/sCategory/350
    
    
        2018-11-06
    
    
        weekly
    
    
        0.5

Ist das Problem mit 5.5.7 doch nicht behoben oder muss man hier noch irgendwelche Einstellungen vornehmen?
Ich habe da bisher nichts dazu finden können im Backend.

 

Zusätzlich erhalte ich beim Aufruf der Mobile-Sitemap unter {shopurl}/sitemap_mobile.xml eine leere Seite, obwohl im Backend die Generierung der mobilen Sitemap aktiviert ist. (sowohl unter 5.5.6 als auch unter 5.5.7)

Hast du die Sitemap auch neugeneriert?

 

Sitemap ist unter Cache/Performance im Tab Einstellungen -> Sitemap bei Aktualisierungsstrategie auf „Live“ eingestellt.
Habe aber auch schon mehrfach die Sitemap über den Button auf der gleichen Seite neu generiert. Trotzdem keine Änderung.

Die mobile Sitemap scheint am eigenen Template zu liegen, wenn Responsive verwendet wird, funktioniert die mobile Sitemap wieder.
Bei der normalen Sitemap.xml bleiben aber auch im Responsive die überflüssigen URLs vorhanden.

Kannst du mal schauen Ob es bei dir auch so wie hier aussieht shopware/CategoryUrlProvider.php at 5.5 · shopware/shopware · GitHub ?

Ja, ist bei uns so in der Entwicklungsumgebung mit Version 5.5.7 absolut identisch

Ok ich hab das Problem gefunden, warum diese nach dem Update auf 5.5.7 noch vorhanden waren.
Ich hätte einfach nur die SEO-URLs neu generieren sollen statt die Sitemap, dann verschwinden die URLs auch aus der Sitemap  Foot-in-Mouth

Danke für die Unterstützung :slight_smile: