[gelöst] BILLSAFE - Rückleitung bei abgelehntem Einkauf

Hallo zusammen, ich bin heute nachmittag die Checkliste zur “Abnahme BILLSAFE-Anbindung” Punkt für Punkt durchgegangen. Ein Fehler trat im Sandbox-Modus in Szenario 2 - Schritt 3 auf. [quote]Szenario 2 - Abgelehnter BillSAFE Einkauf Schritt 1 Tätigen Sie folgenden Test-Einkauf: • 2 x einen beliebigen Artikel (A) • 1 x einen weiteren beliebigen Artikel (B) • 1x Versandkosten © Käuferdaten: Frau Vorname Nachname Wfghjgasse 5 49084 Odfghjkl vorname{at}billsafe.de Schritt 2 Wählen Sie die Zahlart BillSAFE. Schritt 3 Schließen Sie die Transaktion auf der BillSAFE Seite (Payment Gateway) ab. # Zahlartenauswahl Ihres Shops wird erneut angezeigt – BillSAFE erscheint darin nicht mehr[/quote] Die Rückleitung auf die Zahlartenauswahl im Shopware-Shop wurde nicht durchgeführt. Ich erhielt folgende Meldung… siehe Screenshot: Ist dieser Fehler bekannt? Liegt der Fehler eurer Meinung nach an BILLSAFE oder am Shopware-Shopsystem? Ich nutze die aktuellste Shopware-Version 3.5.5. Ich weiß nicht wo ich ansetzen soll um die Fehlermeldung weg zu bekommen.

Servus, öhm, das ist normal so, der Button rechts ist doch der “Zahlungsart ändern” Button. Die Fehlermeldung siehst Du weil Du in der Sandbox bist, da werden auch die Fehlermeldungen angezeigt, das passiert im Livebetrieb nicht. Von daher, ist normal so. P.S. von wann stammen die Updatedaten für Deinem Shop? Shopware hat nachdem sie 3.5.5 veröffentlicht haben, noch ein paar Fehler in der BillSAFE Schnittstelle behoben und eine aktualisierte Version ins Downloadpaket gesteckt, ohne ihm eine neue Versionsnummer zu geben. Von daher, lad Dir sicherheitshalber das Plugin noch mal neu hoch aus den aktuellen Downloaddaten. Behobene Fehler: - netto Kundengruppen konnten nicht einkaufen - Maskierung von HTML Sonderzeichen (z.B. " wurde zu &quote; in Artikelnamen ) mfg, Holger

1 Like

Hallo Holger, vielen Dank für die Info. Die Beschreibung in der Checkliste „Zahlartenauswahl Ihres Shops wird erneut angezeigt – BillSAFE erscheint darin nicht mehr“ war auch etwas irreführend. Ich werde dies nun nochmal im Livebetrieb testen und schauen ob die Fehlermeldung nicht mehr auftaucht. Das Auto Update zu 3.5.5 habe ich erst vor 3 Tagen durchgeführt. Ich geh mal stark davon aus, dass darin das aktuelle BillSAFE Plugin enthalten war. Die Versionsnummer ist die 1.5.0. Im Community Store ist nur die 1.4.0 erhältlich…

Servus, Version 1.5.0 passt, das sollte die neuste Version sein die Shopware anbietet. 1.4.0 war die mit den angesprochenen Fehlern. mfg, Holger