Formulare werden nicht mehr versendet

Moin, ich war jetzt länger nicht am Shop dran und wurde heute von einen Kunden darauf aufmerksam gemacht, dass ein Fehler kommt.

"Ups! Ein Fehler ist aufgetreten!

Wir wurden bereits über das Problem informiert und arbeiten an einer Lösung, bitte versuchen Sie es in Kürze erneut. "

 

Am Shop wurde nichts geändert!
Habe nun selber mal getestet, dies betrift alle Formulare, Newsletter, nichts geht mehr raus vom Shop.

Gehostet ist der Shop bei Ionos(1&1), dort habe ich gerade auch schon angerufen und gefragt ob etwas an den PHP einstellungen geändert wurde, leider nein.

Ich habe jetzt keinen Anhaltspunkt mehr, vielleicht hat ja hier einer eine Idee.

 

Vielen Dank im Vorraus

 

Mit deiner Aussage:

nichts gehr mehr raus vom Shop

beziehst du dich auf die E-Mails korrekt? Hast du deine Mail-Konfiguration bereits überprüft?

1 Like

Genau, es werden vom Shop keine E-Mails mehr versendet, weder an die Kunden ( Newsletter ) noch an die hinterlegten E-Mail Adressen der Formulare.

Was meinst du mit Mail-Konfiguration? Im Backend unter Grundeinstellungen -> Mailer?
Da stehen die Standartwerte drin und als Methode “mail”

Das letzte Update von Shopware konnte ich leider nicht machen, da der Betreiber nicht die entsprechende MySQL version verwendet.

Alles klar,

Schau nochmal hier in die Dokumentation vom Mailer. https://docs.shopware.com/de/shopware-5-de/einstellungen/e-mails#mailer

Ich weiß jetzt nicht was genau in deinem Ionos Paket enthalten ist, aber gegebenenfalls musst du noch einen Mailserver einrichten oder sofern du einen hast, dessen Daten im Mailer hinterlegen. 

Des Weiteren müsstest du noch die SMTP Einstellungen vornehmen. 

Wenn ich als Methode “mail” stehen habe, muss ich trotzdem SMTP ausfüllen? Hat bisher auch immer so funktioniert.
SMTP habe ich gerade von IONOS eingetragen funktioniert trotzdem nicht, weiß aber auch nicht ob ich einen Mailserver habe.

Kann ich auch einen Externern Mailserver verwenden oder muss ich den von IONOS nehmen?

Schau nochmal hier in die Dokumentation vom Mailer. https://docs.shopware.com/de/shopware-5-de/einstellungen/e-mails#maile

Auf der Seite die ich da verlinkt hatte, hast du unten ein paar Beispiele wie man das verbinden kann. Da ist auch eines für 1&1. Bin mir nun aber nicht sicher inwiefern man das für Ionos übertragen kann auch wenn es der gleiche Anbieter ist. Wenn Ionos dir SMTP Konfigurationen anbietet und das in deinem Paket enthalten ist, brauchst du ja eigentlich keinen externen Mailserver.

Danke, habe gerade geschaut und die Daten für IONOS eingetragen und auf SMTP gestellt, der Port ist für das Hosting gesperrt, 25 ist offen, beides versucht, immer noch gleicher Fehler

Die Fehlermeldung wäre ja generell interessant. Die steht normalerweis eim Log.

Zend_Mail_Protocol_Exception: Requested action not taken: mailbox unavailable invalid DNS MX or A/AAAA resource record in /engine/Library/Zend/Mail/Protocol/Abstract.php:420 Stack trace:
#0 /engine/Library/Zend/Mail/Protocol/Smtp.php(258): Zend_Mail_Protocol_Abstract->_expect(Array, 300)
#1 /engine/Library/Zend/Mail/Transport/Smtp.php(203): Zend_Mail_Protocol_Smtp->mail('info@uspart-ser...')
#2 /engine/Library/Zend/Mail/Transport/Abstract.php(343): Zend_Mail_Transport_Smtp->_sendMail()
#3 /engine/Library/Zend/Mail.php(1176): Zend_Mail_Transport_Abstract->send(Object(Enlight_Components_Mail))
#4 /engine/Library/Enlight/Components/Mail.php(358): Zend_Mail->send(Object(Zend_Mail_Transport_Smtp))
#5 /engine/Shopware/Controllers/Frontend/Forms.php(133): Enlight_Components_Mail->send()
#6 /engine/Shopware/Controllers/Frontend/Forms.php(651): Shopware_Controllers_Frontend_Forms->commitForm()
#7 /engine/Shopware/Controllers/Frontend/Forms.php(89): Shopware_Controllers_Frontend_Forms->handleFormPost('5')
#8 /engine/Library/Enlight/Controller/Action.php(193): Shopware_Controllers_Frontend_Forms->indexAction()
#9 /engine/Library/Enlight/Controller/Dispatcher/Default.php(549): Enlight_Controller_Action->dispatch('indexAction')
#10 /engine/Library/Enlight/Controller/Front.php(222): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp))
#11 /engine/Shopware/Kernel.php(202): Enlight_Controller_Front->dispatch()
#12 /vendor/symfony/http-kernel/HttpCache/SubRequestHandler.php(102): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)
#13 /vendor/symfony/http-kernel/HttpCache/HttpCache.php(448): Symfony\Component\HttpKernel\HttpCache\SubRequestHandler::handle(Object(Shopware\Kernel), Object(Symfony\Component\HttpFoundation\Request), 1, true)
#14 /engine/Shopware/Components/HttpCache/AppCache.php(268): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL)
#15 /vendor/symfony/http-kernel/HttpCache/HttpCache.php(238): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true)
#16 /vendor/symfony/http-kernel/HttpCache/HttpCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true)
#17 /engine/Shopware/Components/HttpCache/AppCache.php(143): Symfony\Component\HttpKernel\HttpCache\HttpCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true)
#18 /vendor/symfony/http-kernel/HttpCache/HttpCache.php(181): Shopware\Components\HttpCache\AppCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true)
#19 /engine/Shopware/Components/HttpCache/AppCache.php(116): Symfony\Component\HttpKernel\HttpCache\HttpCache->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)
#20 /homepages/7/d603124875/htdocs/dev_1/shopware.php(122): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request))

 

 

Das ist die Fehlermeldung aus dem log

mailbox unavailable invalid DNS MX or A/AAAA resource record

Da ist ja bereits ein Hinweis was fehlerhaft sein könnte. Scheinbar ist die Konfiguration nicht ganz vollständig oder nicht korrekt. 

Kann ich diese Konfiguration überhaupt ändern, ist doch Sache von IONOS oder nicht? Habe die Domain angelegt schon vor über einem Jahr, nichts verändert und plötzlich gehts nicht mehr?

auf DNS Einstellungen habe ich keinen Zugriff zumindest noch nie eine Möglichkeit gesehen

„Requested action not taken: mailbox unavailable  invalid DNS MX or A/AAAA resource record“ steht auch noch in den Logs

Genau, direkt an den Hosting-Provider mit der Fehlermeldung

Zend_Mail_Protocol_Exception: Requested action not taken: mailbox unavailable invalid DNS MX or A/AAAA resource record

 

Ja laut Support, wird dies seit gestern geprüft, mal sehen was sich ergibt

Ionos gibt da Hilfe:

Wäre dann 550

Mit einem link zum Shop könnte ich genaueres sagen, oder Du probierst es selbst aus: https://intodns.com/

@kulli schrieb:

Ionos gibt da Hilfe:

https://www.ionos.de/hilfe/e-mail/postmaster/smtp-fehlermeldungen-der-11-ionos-mailserver/

Wäre dann 550

Mit einem link zum Shop könnte ich genaueres sagen, oder Du probierst es selbst aus: https://intodns.com/

Danke, shopdomain ist https://uspart-service.shop
intodns habe ich schon gemacht, kann mit den Werten allerdings nichts anfangen.
Ich habe den Support von Ionos diese Fehlermeldung Freitag gesendet, dann wollten die ein Screenshot von den Shopmailer-Einstellungen.

Den Hilfebeitrag von Ionos habe ich schon gefunden, weiß allerdings leider nicht was ich da ändern muss, damit es wieder geht

 

Insgesamt kann ich keine schwerwiegenden Fehler erkennen; Das übliche Durcheinander bei gemeinsam genutzten IP-Adressen. Deswegen gibt es hier auch nur immer einen aktuellen Status; das kann sich schnell wieder ändern
Das Ablaufdatum TTL ist sehr kurz gesetzt; 300 sec. und Dmarc gar nicht, aber üblich bei Spamschleudern wie ionos. Beides ist erstmal auch kein “Fehler”.

Test-smtp geht fast nicht, weil die Antwortzeit des Servers zu lahm ist. Das könnte übrigens auch den Fehler auslösen: Das System kann die mail nicht auslösen, weil der Server zu lahm ist, bzw. zu intensiv genutzt wird.

Hier nochmal die Standart-Einstellungen:

smtp ist aber immer besser, weil ??  Das sieht dann ungefähr so aus:

1 Like

Vielen Dank für deine Bemühung bei dem Problem.
Ich hatte es ganze Zeit Problemlos über mail laufen, wie im ersten Bild, dies klappt aber seit ein paar Wochen von heute auf morgen nicht mehr. ( Vermute IONOS hat was in den Einstellungen geändert.

SMTP sieht wie folgt aus: 

Nach Telefonischer Absprache soll hier Port 25 genutzt werden.

 

Habe es gerade nochmal über mail getestet und es kommt folgenden Fehlermeldung:
 

Zend_Mail_Transport_Exception: Unable to send mail. in /engine/Library/Zend/Mail/Transport/Sendmail.php:134 Stack trace:
#0 /engine/Library/Zend/Mail/Transport/Abstract.php(343): Zend_Mail_Transport_Sendmail->_sendMail()
#1 /engine/Library/Zend/Mail.php(1176): Zend_Mail_Transport_Abstract->send(Object(Enlight_Components_Mail))
#2 /engine/Library/Enlight/Components/Mail.php(358): Zend_Mail->send(Object(Zend_Mail_Transport_Sendmail))
#3 /engine/Shopware/Controllers/Frontend/Forms.php(133): Enlight_Components_Mail->send()
#4 /engine/Shopware/Controllers/Frontend/Forms.php(651): Shopware_Controllers_Frontend_Forms->commitForm()
#5 /engine/Shopware/Controllers/Frontend/Forms.php(89): Shopware_Controllers_Frontend_Forms->handleFormPost('5')
#6 /engine/Library/Enlight/Controller/Action.php(193): Shopware_Controllers_Frontend_Forms->indexAction()
#7 /engine/Library/Enlight/Controller/Dispatcher/Default.php(549): Enlight_Controller_Action->dispatch('indexAction')
#8 /engine/Library/Enlight/Controller/Front.php(222): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp))
#9 /engine/Shopware/Kernel.php(202): Enlight_Controller_Front->dispatch()
#10 /vendor/symfony/http-kernel/HttpCache/SubRequestHandler.php(102): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)
#11 /vendor/symfony/http-kernel/HttpCache/HttpCache.php(448): Symfony\Component\HttpKernel\HttpCache\SubRequestHandler::handle(Object(Shopware\Kernel), Object(Symfony\Component\HttpFoundation\Request), 1, true)
#12 /engine/Shopware/Components/HttpCache/AppCache.php(268): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL)
#13 /vendor/symfony/http-kernel/HttpCache/HttpCache.php(238): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true)
#14 /vendor/symfony/http-kernel/HttpCache/HttpCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true)
#15 /engine/Shopware/Components/HttpCache/AppCache.php(143): Symfony\Component\HttpKernel\HttpCache\HttpCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true)
#16 /vendor/symfony/http-kernel/HttpCache/HttpCache.php(181): Shopware\Components\HttpCache\AppCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true)
#17 /engine/Shopware/Components/HttpCache/AppCache.php(116): Symfony\Component\HttpKernel\HttpCache\HttpCache->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)
#18 /homepages/7/d603124875/htdocs/dev_1/shopware.php(122): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request))
#19 {main}

Kann aber auch nichts mit dieser Fehlermeldung anfangen

Nimm den hostnamen (message-id) mal raus.

Vergiss zwischendrin bei den Tests nicht den Cache zu leeren

port 587 könsnte auch noch probieren…ist aber glaube ich seitens ionos zu.

Du könntest noch SSL mit port 465 probieren.

1 Like

Cache wird immer brav geleert nach jeder Änderung.

Sagt dir die Fehlermeldung die bei mail rausgehauen wird etwas?

 

Unable to send mail.

 sagt mir nicht viel, unterrscheidet sich aber von derr ursprünglichen „mailbox unavailable“

1 Like