Fehlermeldung beim Update auf 6.5

Hallo zusammen
vielleicht hat jemand diese Fehlermeldung beim Update auf 6.5

In InstallRecipesCommand.php line 58:

[Symfony\Component\Console\Exception\RuntimeException]
Cannot run „sync-recipes --force“: git not found.

Jemand eine Ahnung wie ich das auflösen kann?

Danke vorab für jede Idee

1 Like

git fehlt bei Dir auf dem System.

Viele Grüße

Ah - ok
und was muss ich da jetzt machen? Provider oder was soll ich da anstossen :slight_smile:

Hallo,

git installieren oder wenn Du den Server nicht selbst administrierst, den Hoster kontaktieren.

1 Like

Super - danke dir.
Werde ich morgen dem Hoster so weitergeben

Warum steht das dann nicht in den Systemanforderungen? Das Update ist jetzt halb durchgelaufen und hat den /bin Ordner gelöscht, so dass ich ohne Backup jetzt im Regen stünde, weil ohne den der Installer den Dienst verweigert.

Es hatte auch schon abgebrochen, weil Dateirechte nicht stimmten. Wieso prüft das der Installer nicht als erstes bevor er loslegt? Da bin ich anderes gewöhnt.

Der Upgrade-Prozess hat bei mir in SW 6 noch nie auf Anhieb funktioniert. Über den Browser gibt’s dann oft noch nicht mal eine (brauchbare) Fehlermeldung.

1 Like

Kann dein Missmut verstehen.
Ich habe beim Hoster angerufen und der meinte ich müsste nun einen SSH durchführen und dann mit der Konsole einspielen!
Ich denke das werde ich mal am W.ende testen. schon ärgerlich was da alles gemacht werden muss um ein Update zu fahren was eigentlich auch über das Backend im Browser funktionieren sollte.

Bei welchem der hier genannten Hosting-Partner seid Ihr denn? Das passende Hosting für Deinen Shopware-Shop | Shopware Ggf. sollten wir dort nochmal mit jemandem reden.

Hi Marco,
unser Shopware ist bei UDMEDIA gehostet.
Hier ist das Problem mit GIT, das nicht installiert ist.

Okay, danke. Ich kümmere mich drum.

Super,
vielleicht kannst du ja dann hier Bescheid geben, was dabei rumgekommen ist.
Sonst könnte es peinlich werden, wenn ich da anrufe und fragen stelle die schon längst erledigt sind :slight_smile:
Aber wie auch immer … Danke

Klasse … Können im vHost kein Git freischalten. Ich find die neue Update-Datei allgemein sehr … „bescheiden“. Als Entwickler habe ich absolut keine Kontrolle mehr über das, was im Hintegrund passiert. Da war ZIP auf Server laden, entpacken und dann URL aufrufen wesentlich einfacher und sicherer! SSH Zugriff habe ich eh auf den Server, wegen der bin/console Befehle, es ergibt also nicht mal wirklich Sinn, dafür jetzt eine Routine-Datei zu verwenden.

Kann aktuell nicht mal ein Update von 6.5.0 auf 6.5.1 durchführen, absolut Sch…ade, außerdem Zeit- und Nerven raubend.

Sehr gute Frage, auf die ich auch gerne eine Antwort hätte. Auch PHP-Einstellungen, wie z.B.: opcache.memory_consumption:256M werden in der Doku nicht erwähnt. Auch, dass ein DB-Nutzer inzwischen SUPER-Rechte, oder zumindest log_bin_trust_function_creators benötigt, muss doch eigentlich irgendwo erwähnt werden!?

@celal Habt Ihr das Problem gelöst? Wenn ja wie? Hat euer Provider Git freigeschaltet?

LG;LA

Hallo @littleAmused,

git sollte eigentlich Standard sein. Wir haben dazu bei uns bereits ein eigenes tool auf der SSH Umgebung laufen, dass Shopware 6 in der aktuellsten Version installiert. Hier ein kleiner Einblick:

	# Installiere Shopware 6 via composer (Ordner sollte leer sein)
	php8.2 /usr/bin/composer create-project -q shopware/production $_path

VG Rico von enerspace.de :wink:

Hallo zusammen,

ich hoffe es ist okay, wenn ich direkt bei diesem Eintrag kommentiere - ich habe auch eine Frage dazu.

Ich will das Update von 6.4 auf 6.5 zunächst bei uns auf dem Testsystem durchführen, um es zu testen. Ich hatte dabei leider einige Probleme und habe unterschiedliche PHP-Ausführungsdateien verwendet und habe immer folgende Fehlermeldungen erhalten:

Security Alert! The PHP CGI cannot be accessed directly.

This PHP CGI binary was compiled with force-cgi-redirect enabled. This
means that a page will only be served up if the REDIRECT_STATUS CGI variable is
set, e.g. via an Apache Action directive.

For more information as to why this behaviour exists, see the manual page for CGI security.

For more information about changing this behaviour or re-enabling this webserver,
consult the installation file that came with this distribution, or visit
the manual page.


Zweite Fehlermeldung nach erneutem Anlauf:

Run Update preparations
�{„success“:true}

Kann mir hier jemand weiterhelfen? Ich weiß nicht mehr, was ich noch versuchen kann. Habe auch versucht, das Update in kleinen Schritten durchzuführen und nicht direkt auf die aktuellste Version . auch das hat nicht funktioniert.

Danke bereits im Voraus!! :slight_smile:

Ich bekomme ebenfalls die Fehlermeldung Cannot run ‚sync-recipes --force‘: git not found. Mein Provider behauptet aber steif und fest Git sei installiert

git ist auf dem System bereits installiert:
root@server2:~# git --version
git version 2.30.2

Was mache ich also falsch? Muss evt. ein Pfad geändert werden, damit Git gefunden wird?

Hallo,

lass doch bitte einmal den Hoster prüfen, ob im PHP PHP: Predefined Constants - Manual (insbesondere „DIRECTORY_SEPARATOR“) auf „/“ gesetzt ist.

Wenn nicht, dann wird zum Prüfen auf Git ein Befehl (where git anstatt von which git) genutzt, der zu keinem Ergebnis und der genannten Meldung kommen wird.

„Where git“ wird nur verwendet, wenn das zugrundeliegende System als Windows interpretiert wird. Das ist zum Beispiel der Fall, wenn der DIRECTORY_SEPARATOR falsch gesetzt wurde und dann würde dieser Fehler erscheinen.

Vielleicht hilf der Hinweis weiter.

VG Benjamin

1 Like

Vielen Dank für den Tipp. Leider hat das nicht geholfen. Das scheint nicht das Problem zu sein.

Der Hoster schreibt:

DIRECTORY_SEPARATOR ist auf „/“ gesetzt. Prüfen können Sie das, in dem Sie eine PHP-Datei mit folgendem Inhalt erstellen:

<?php echo DIRECTORY_SEPARATOR; ?>