Fehler bei Installation Shopware 4.0.2 -> Datenbank konfig.

Guten Abend, ich versuche schon seit Stunden Shopware 4 auf meinem 1&1 Server zu installieren :frowning: SystemprĂŒfung ist wunderbar durchgelaufen und alles auf OK! Leider komme ich bei Schritt 3 einfach nicht weiter :thumbdown: Obwohl alle Daten RICHTIG eingegeben sind erhalte ich folgende Meldung Database-Error!: SQLSTATE[HY000] [2002] Connection refused DB Host = localhost:/tmp/mysql5.sock Port = 3316 (habe noch einige DB unter MySQL4 laufen daher nicht 3306) DB User = dbo*********** Passwort = ************** DB Name = db************ Laut 1&1 Support stimmen alle angaben und Verbindung zur Datenbank sollte problemlos funktionieren! Habt Ihr eine Idee woran das liegt? GrĂŒĂŸe aus NĂŒrnberg, Daniel PS: Shopware 3.5 lĂ€uft ohne Probleme (in einem anderen Verzeichnis) auf dem Server! Server ist ein 1&1 Managed Server

Das gleiche Problem hab ich auch, wĂ€re echt super, wenn jemand dazu nen Lösungsansatz hĂ€tte. Habe dazu schon etwas gefunden, kann es aber nicht wirklich umsetzen
 Siehe hier: Also in der config.php habe ich den Host auf Localhost gesetzt und den Wert $DB_SOCKET ="/tmp/mysql5.sock"; hinzugefĂŒgt. Anschließend in der application.php das db-array ergĂ€nzt um ‘unix_socket’ => $DB_SOCKET Und siehe da, es geht :slight_smile: Vielleicht hilft es Dir ja weiter.

Hi, der neue Installer unterstĂŒtzt noch keine Db-Socket-Angabe. Daher kann das Script auch keine Db-Verbindung aufbauen. Versuche es doch mal mit dem Online-Installer: http://wiki.shopware.de/Shopware-4-Inst 
 l_874.html Der hat eine Socket-UnterstĂŒtung und sollte auch mit Shopware 4 funktionieren. Heiner

1 Like

[quote=“Heiner Lohaus”]Hi, der neue Installer unterstĂŒtzt noch keine Db-Socket-Angabe. Daher kann das Script auch keine Db-Verbindung aufbauen. Versuche es doch mal mit dem Online-Installer: http://wiki.shopware.de/Shopware-4-Inst 
 l_874.html Der hat eine Socket-UnterstĂŒtung und sollte auch mit Shopware 4 funktionieren. Heiner[/quote] Hallo Heiner, und wo bekomme ich die “alte” Version 1 des Installers her? Über eine Link zum Download wĂ€re ich dir dankbar. GrĂŒĂŸe aus NĂŒrnberg, Daniel

Stimmt. Hier der richtige Link: http://wiki.shopware.de/Installation-mi 
 l_534.html

[quote=„Heiner Lohaus“]Hi, der neue Installer unterstĂŒtzt noch keine Db-Socket-Angabe. Daher kann das Script auch keine Db-Verbindung aufbauen. Versuche es doch mal mit dem Online-Installer: http://wiki.shopware.de/Shopware-4-Inst 
 l_874.html Der hat eine Socket-UnterstĂŒtung und sollte auch mit Shopware 4 funktionieren. Heiner[/quote] Habe ich probiert aber er kann auch mit dem Installer keine Verbidung zum Datenbankserver aufbauen
 So langsam bin ich der Verzweiflung nah


Hi, was genau hast du den da eingetragen? Kannst du mir einmal die Zugangsdaten zukommen lassen? Dann schaue ich mir das einmal an. eMail-Adresse: forum@shopware.de Heiner

[quote=„Heiner Lohaus“]Hi, was genau hast du den da eingetragen? Kannst du mir einmal die Zugangsdaten zukommen lassen? Dann schaue ich mir das einmal an. eMail-Adresse: forum@shopware.de Heiner[/quote] Guten Morgen Heiner, also bei mir ist`s genau das gleiche Problem! Habe gestern Abend ganze 2 Stunden mit dem 1&1 Support versucht eine Lösung zu finden - keine Chance! Bei der online Version kommt ebenfalls „Keine Verbindung zur Datenbank“ obwohl alle Daten 100% richtig eingetragen sind. Woran kann das liegen? GrĂŒĂŸe aus NĂŒrnberg, Daniel

[quote=“Avatronic”] Guten Morgen Heiner, also bei mir ist`s genau das gleiche Problem! Habe gestern Abend ganze 2 Stunden mit dem 1&1 Support versucht eine Lösung zu finden - keine Chance! Bei der online Version kommt ebenfalls “Keine Verbindung zur Datenbank” obwohl alle Daten 100% richtig eingetragen sind. Woran kann das liegen? GrĂŒĂŸe aus NĂŒrnberg, Daniel[/quote] Servus Daniel. Wie Du sicher gelesen hast, habe ich dasselbe Problem und ich muss Dir leider mitteilen, daß eine Installation von Shopware 4 bei 1und1 nicht möglich ist. Die Datenbankversion bei 1und1 ist nicht passend. Hier mal ein Auszug aus der Antwortmail von 1und1: “Wir haben nochmals recherchiert und können Ihnen nun die Ursache fĂŒr die Fehlermeldung nennen: Das verwendete Shop-System “ShopWare 4” benötigt als Systemvoraussetzung MySQL 5.1. Auf unseren Managed-Servern können Sie derzeit nur MySQL 5.0.92 nutzen Wenn Sie zwingend diese MySQL-Version benötigen, besteht nur die Möglichkeit einen Root-Server zu nutzen. Wir bedauern sehr, dass wir Ihnen dieses Mal keine andere Lösung anbieten können.” Ich kann Dir also nur raten, den Hoster zu wechseln, das werden wir nĂ€mlich auch in Angriff nehmen.