Einige Artikel im Backend nicht bearbeitbar

Hallo,

wir haben (Shopware 5.6.6) seit kurzem ein paar Artikel (bekannt sind derzeit nur 2) die im Backend nicht bearbeitbar sind.

Während sich alle anderen Artikel normal mit dem Stift bearbeiten lassen, laden bei diesen beiden Artikeln die Werte im Formular nicht und oben steht drüber: „Artikeldetails: Neuer Artikel“.

In der Console gibt es folgenden JavaScript Fehler:

Weil er keine records zurück bekommt:

 

Im Network-Tab bekommt er aber eine erfolgreiche Rückgabe der Daten des Artikels, daher wundert es mich dass es hier keine Records geben soll.

 

Hat jemand eine Idee was das Problem sein könnte und/oder wie ich es lösen könnte?

Leider finde ich im Apache Error Log gar keine Fehlermeldung. Kann ich da noch irgendwas machen?

Habe jetzt folgende Anleitung durchgeführt: Shopware 5 - Tutorials & FAQs - Reparatur der Foreign Keys

 

Lief ohne Fehler durch, hat scheinbar weder negative noch positive effekte gehabt

 

Für Hilfe wäre ich euch sehr dankbar.

wir haben das gleiche Problem! Hat einer eine Lösung?

In der Regel kommt so etwas nicht aus heiterem Himmel. Wurde etwas verändert? Ein Update von Shop gemacht, oder Plugins aktualisiert? Versucht mal komplett den Cache zu leeren?

Hallo,

wir haben herausgefunden, dass das Produkt, das nicht mehr aufgerufen werden konnte, in der s_articles_similar oder/und in der s_articles_relationships, mindestens einen Artikel hat, der kaputt ist. Mit kaputt meine ich, dass dort ein Artikel ist der in s_articles eine main_detail_id hat, die aber zu keinem s_articles_details führt (der Eintrag existiert da einfach nicht)

Wie es dazu kommt weiß ich nicht.

Das Löschen des entsprechenden Artikels aus der relationships und/oder similar Tabelle hat geholfen.