Artikelimport - Kategoriezuordnung

Ich setze mich gerade mit dem Import/Export Advanced auseinander.
Beim Import der Artikel wir die zugewiesene Kategorie, die der SEO-Kategorie entspricht und eine Unterkategorie ist, mit importiert.
In der Importdatei steht nur die eine Kategorie-ID dieser Unterkategorie.
Nach dem Import werden im Backend beim neuen Artikel unter dem Reiter Kategorien > zugewiesene Kategorien 2 Kategorien angezeigt.
Eine davon ist die zugewiesene Unterkategorie und die andere irgendeine Unterkategorie.
Im Feld SEO-Kategorie wird diese „irgendeine“ Unterkategorie angezeigt.

Im Frontend ist der Artikel allerdings nur in der importierten Unterkategorie angezeigt.

Hab ich was falsch gemacht oder ist da irgendwo ein Bug?

Ich habe mir gerade mal die IDs der Artikel angesehen.
In der s_articles hat der letzte angelegte Artikel die ID 1629, was auch auch mit dem Datum des zuletzt angelegten Artikels ĂĽbereinstimmt.

In der s_articles_details passt es auch, wenn ich nach articleID aufsteigend sortiere, ist die ID 1629 der letzte Eintrag.

Sortiere ich aufsteigend nach der articleID in der s_articles_categories - in der die Zuordnung der articleID zur categoryID gemacht wird - sollte die ID 1629 ja eigentlich auch als letztes stehen, oder?
Oder hab ich da ein Verständnisproblem?

Bei uns kommen nach der ID 1629 noch viele weitere Einträge und ich weiß nicht, woher die kommen.
Wenn ich jetzt einen neuen Artikel importiere und der bekommt die ID 1630, landet der natürlich in der falschen Kategorie, was das Problem aus meinem ersten Posting erklären würde.

Deshalb die Bitte: Kann das mal jemand in seiner Datenbank prĂĽfen?

Hallo,

bei uns ist das so, wie von Dir erwartet.

Hast Du mal versucht den Kategoriebaum neu aufzubauen?

1 Like

Du meinst, bei euch ist es so, dass die ID des zuletzt angelegten Artikels auch der letzte Eintrag in der s_articles_categories ist, wenn Du nach der articleID sortierst?

Nein, den Kategoriebaum hab ich noch nicht neu aufgebaut.
Hilft das denn dabei, die articleIDs die sich nach der eigentlich letzten befinden, zu löschen?

@drakon schrieb:

 

Hast Du mal versucht den Kategoriebaum neu aufzubauen?

Das wĂĽrgt. :wink:
Danke fĂĽr den Tipp. :slight_smile:

Ähm, gibt es sowas wie „Kategoriebaum neu aufbauen“ auch für die Bilder?
Da hab ich das gleiche Problem: in der s_articles_img kommen bei der aufsteigenden Sortierung nach articleID nach der ID 1629 noch viele weitere IDs. DĂĽrften aber eigentlich nicht, weil das der neueste Artikel ist.

@simplybecause schrieb:

Du meinst, bei euch ist es so, dass die ID des zuletzt angelegten Artikels auch der letzte Eintrag in der s_articles_categories ist, wenn Du nach der articleID sortierst?

Ja, genau so.

Zu den Bilder kann ich leider nicht direkt weiter helfen. Aber da gehen  bei mir die articleIDs auch nicht über die Nummer des neuesten Artikels hinaus.

Okay, danke fĂĽr die Info.
Ich hab eine Vermutung, woran das liegt.
Ich werd in der s_articles_categories mal ein paar Einträge löschen und schauen, was passiert.
Wenn nichts passiert, hoffe ich, dass das beim Anlegen von neuen Artikeln nicht wieder von vorne losgeht.