500 Internal Server Error nach Domainänderung

Hi! Wir haben unseren SW6 Shop aufgebaut, dieser ist bei Mittwald gehostet und war die ganze Zeit unter shopware.projektnummer.webspaceconfig.de erreichbar.

Nun haben wir dem Mittwald Projekt unsere Domain hinzugefügt, diese Zeigt auch auf /shopware/public.

Wenn wir die Domain aufrufen bekommen wir den Fehler

"Oops! An Error Occurred

The server returned a „500 Internal Server Error“.

Something is broken. Please let us know what you were doing when this error occurred. We will fix it as soon as possible. Sorry for any inconvenience caused."

Das Backend ist über diese Domain jedoch ganz normal erreichbar. Auch ist die Domain in dem Verkaufskanal eingetragen, einmal als http und einmal als https. In der .env haben wir die Domain auch abgeändert.

Weiß jemand rat?

Mir hat bei so einem Fehler schon mal geholfen den kompletten Cache zu löschen, also nicht nur mit bin/console sondern auch mit

rm -R var/cache/*

Morgen! Das haben wir mal ausprobiert. Hat leider nicht geholfen. Ich habe in der .env mal den dev Modus aktiviert und bekomme als Fehlermeldung:
Unable to find a matching sales channel for the request: https://www.unseredomain.de/". Please make sure the domain mapping is correct.

Ist das richtig dass dort Anführungszeichen hinter der Domain angezeigt werden?

Unter den Domains in dem Verkaufskanal sind beide Domains eingetragen, also sowohl https://unseredomain.de als auch https://shopware.projektnummer.webspaceconfig.de

:roll_eyes::roll_eyes::roll_eyes::roll_eyes::roll_eyes:

Es lag an dem www. vor der Domain. Sobald wir das eingetragen haben in dem Verkaufskanal hat es funktioniert. Also statt https://unseredomain.de steht da jetzt https://www.unseredomain.de

1 Like