Wiedermal Probleme nach Update

Nachdem ich mich mich jetzt länger um das Update gedrückt habe, musste ich es heute dann doch machen.
Somit wieder das alt bekannte Problem. Frontend zerschossen. www.onlineshop.hanfino.kaufen

  1. Fehlercode aus dem Log
    Enlight_Controller_Exception: Unauthorized in /engine/Shopware/Plugins/Default/Backend/Auth/Bootstrap.php:209 Stack trace:
    #0 /engine/Library/Enlight/Event/Handler/Plugin.php(149): Shopware_Plugins_Backend_Auth_Bootstrap->onPreDispatchBackend(Object(Enlight_Controller_ActionEventArgs))
    #1 /engine/Library/Enlight/Event/EventManager.php(214): Enlight_Event_Handler_Plugin->execute(Object(Enlight_Controller_ActionEventArgs))
    #2 /engine/Library/Enlight/Controller/Action.php(137): Enlight_Event_EventManager->notify(‚Enlight_Control…‘, Object(Enlight_Controller_ActionEventArgs))
    #3 /engine/Library/Enlight/Controller/Dispatcher/Default.php(530): Enlight_Controller_Action->dispatch(‚ajaxSecurityChe…‘)
    #4 /engine/Library/Enlight/Controller/Front.php(223): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp))
    #5 /engine/Shopware/Kernel.php(189): Enlight_Controller_Front->dispatch()
    #6 /vendor/symfony/http-kernel/HttpCache/HttpCache.php(491): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)
    #7 /engine/Shopware/Components/HttpCache/AppCache.php(268): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL)
    #8 /vendor/symfony/http-kernel/HttpCache/HttpCache.php(258): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true)
    #9 /engine/Shopware/Components/HttpCache/AppCache.php(105): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true)
    #10 /www/htdocs/w010e387/onlineshop.hanfino.kaufen/shopware.php(118): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request))
    #11 {main}

 

  1. Ist mir aufgefallen das in der Systeminfo bei Memory nur 64M angezeigt werden. Trotz Anpassung der htaccess auf 265M

 

Beim letzten mal half nur die Backup Einspielung des Hosters und somit Verlußt von 14 Tagen Daten.
Hoffe jetzt nochmal auf Eure Hilfe. DANKE

Zusätzlich wird noch ein Browserfehler in der Konsole ausgegeben;
Laden fehlgeschlagen für das

Noch einen Fehler im Browser gefunden der im Backend nicht ersichtlich ist:

Fatal error : Allowed memory size of 67108864 bytes exhausted (tried to allocate 2097160 bytes) in /www/htdocs/w010e387/onlineshop.hanfino.kaufen/vendor/oyejorge/less.php/lib/Less/SourceMap/Generator.php on line 297

Die Meldung im Eigangspost hat nichts mit dem Frontend zu tun, sondern entsteht wenn eingeschränkte Benutzer im Backend arbeiten. Das hat damit also nix zu tun.

Dein letzter Post wird die Ursache sein - du hast im Theme-Manager das generieren der SourceMap aktiviert. Das ist für den Produktivbetrieb nicht vorgesehen. Gehe mal in den Theme-Manager und passe die folgenden Einstellungen an:

  • Compiler Caching deaktvieren: nein
  • CSS SOurce Map erstellen: nein
  • CSS komprimieren: ja
  • JavaScript komprimieren: ja

Das kannst du oben über den Button Einstellungen im Theme-Manager definieren.

1 Like
  1. Ist mir aufgefallen das in der Systeminfo bei Memory nur 64M angezeigt werden. Trotz Anpassung der htaccess auf 265M

Na ja, Du kannst in die .htaccess auch 8096 MB eintragen, wenn dein Server aber nur 64 MB  hat, ist das so was von egal. Und das besagt auch die Fehlermeldung

 

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 2097160 bytes) in /www/htdocs/w010e387/onlineshop.hanfino.kaufen/vendor/oyejorge/less.php/lib/Less/SourceMap/Generator.php on line 297

nur 64 MB Speicher zur Verfügung, will aber mehr MB nutzen.

Gruß