Wie kann ich Plugins wieder updaten?

Hallo ,

aus dem Backend heraus will ich Plugins updaten, muss mich mit Shopware ID und PW anmelden und bekomme die Fehlermeldung:

Die Authentifizierung auf dem SBP Server ist fehlgeschlagen: UsersException-4

Zugangsdaten sind korrekt, kann mich über den Account anmelden, nicht aber aus dem Backend.

Ich kann jetzt nicht sagen, wie lange das Problem schon besteht, habe mich gearde das erste mal dort eingeloggt.

Habe deswegen schon bei Shopware angerufen, ich möge doch Shopware kaufen, dann kann man mir helfen, oder hier ans Forum wenden.

Gemacht, getan (Shopware nicht gekauft Wearing-Sunglasses), irgendwelche Ideen?

Shopware 5.5.2

Habe deswegen schon bei Shopware angerufen, ich möge doch Shopware kaufen, dann kann man mir helfen, oder hier ans Forum wenden.

Der Login in SW hat ja wohl nichts mit dem Support der Software zu tun. Vielleicht wurde hier etwas mißverstanden. Wenn die Domain registriert ist, dann sollte auch der Login gehen und diese Frage muss Shopware beantworten.

Hast du mal das PW geändert und nochmal versucht?
Domain passt zu der im Account hinterlegten?

2 Likes

Danke, das war es. Ich musste das PW noch mal neu setzen, dann hats geklappt.

Ich habe das gleiche Problem allerdings geht es trotz PW änderung nicht.

Hatte gerade das gleiche Problem - Shopware Backend über www aufrufen. Dann ging es. Jedenfalls bei mir mir. bzw. das Backend exakt so aufrufen wie es im Account bei SW registert ist bzw. als Host im Backend eingetragen wurde.

Hallo,
auch heute gibt es immer noch wen, der das Problem hat.
Alle oben beschriebenen Lösungen funktionieren nicht.

Der Fehler bleibt bestehen und ich komme nicht in meinen Account durch den Fehler rein.

Schon schade, dass nach so langer Zeit immer noch solche Fehler nicht behoben wurden sind…

Grüße

Gleiches Problen hier:
Ich kann weder den JTL Connector updaten, noch mein Theme. Zugangsdaten stimmen, Shop ist im Shopware Account authentifiziert. Alle Vorschläge in diesem Thread habe ich ausprobiert, ohne Erfolg.
Immer kommt die gleiche Fehlermeldung, wie im Eingangsbeitrag.

Ich muss (!) den JTL Connector updaten, weil der aktuell Probleme bereitet.
Was kann ich tun?

Hat den niemand eine Lösung?

Probier bitte mal aus, ob Du Dich unter account.shopware.com mit Deinen Zugangsdaten anmelden kannst. Falls nicht, setzt Du bitte dort Dein Passwort zurück. Falls ja, kannst Du Dir dort ernstfalls die Updatepakete als zip herunterladen und in Deinen Shop einspielen.

Wenn Du Dich unter der o.g. URL anmelden kannst, das jedoch über den Shop nicht funktioniert, schau bitte nach, ob im Shop unter Settings => Shops die Domain eingetragen ist (mit/ohne www), die auch im Account hinterlegt ist.

Moin Marco!
Mit den Zugangsdaten kann ich mich auf der Shopware-Seite einloggen. Die sind also korrekt.

Zu deinem Punkt:
„… Shop unter Settings => Shops die Domain eingetragen ist …“

Du meinst hier das Shop-Backend?
Da habe ich unter den Einstellungen nicht den Unterpunkt ‚Shops‘. Den Unterpunkt habe ich unter dem Pfad:
Einstellungen > Grundeinstellungen > Shopeinstellungen > Shops
Ist der Pfad korrekt?
Hier habe ich als Host und Hostalias die Shop-URL ohne www. Im Shopware Account ist die URL mit www hinterlegt. Wenn ich die URL im Shopware-Account ändern möchte und das www wegnehmen, kommt die Meldung, dass die Domain bereits registriert ist.

EDIT:

Ich vermute, dass einer meiner Vorgänger bereits einen Account bei Shopware angelegt hat, und deswegen unsere Domain ohne www registriert ist. Allerdings gibt es keine Zugangsdaten mehr. Da läuft auch die Funktion „Passwort vergessen“ ins Leere.

Gibt es eine Möglichkeit, die Jungs und Mädels von der Shopware-Account Seite zu erreichen? Die einzige Möglichkeit, die ich finde, ist ein Support-Ticket. Allerdings muss ich für diese Funktion tief in die Tasche greifen … und ich benötige keinen Support für den Shop, sondern für die Account Seite. Würde - wenn vorhanden - nämlich gerne unseren alten Account löschen lassen.

Hallo @McWorse,

ja, ich meinte das sog. „Backend“ (das will mir gar nicht so recht über die Lippen gehen :slight_smile:)

Versuch dort mal bitte die Domain mit www zu hinterlegen, dann dürfte der Zugriff zu dem Account, der funktioniert und er für Dich erreichbar ist, klappen.

Ich hab parallel intern Bescheid gegeben, allerdings ohne jede Zusage, dass da etwas klappt.

Schlägt alles fehl, lade Dir bitte die Update-Dateien aus dem Shopware-Account herunter.

Herzlichen Dank Marco!
Das war der sachdienliche Hinweis, der das Problem gelöst hat!
:slight_smile:

Jruß,
McW.

Das war ein Pyrrhussieg.
Da die Shopadresse ohne www in allen Plugins hinterlegt und verknüpft ist (und ich es dort nicht ändern kann), habe ich mit der o.g. Lösung nahezu den kompletten Shop zerschossen. Zahlung ging nicht mehr, Warenkorb ging nicht mehr - und wer weiß, was noch.

Da muss also eine andere Lösung her.
Wäre toll, wenn jemand von Shopware mal Kontakt aufnehmen könnte, denn entweder muss unser alter Account deaktiviert werden, oder jemand müsste mir mal die Zugangsdaten geben. Oder wenigstens die Mailadresse, mit der Registrierung stattgefunden hat, damit ich das „Passwort vergessen“ anstoßen kann.
Wir haben hier keine Daten dazu. Und auch keinen Weg, die rauszufinden.

Dank dem freundlichen Hinweis eine Shopware Mitarbeiterin läuft es. Die Lösung war einfach:

Ich musste mich mit meinen Login-Daten im Backend im Plugin-Manager unter „Meine Einkäufe“ anmelden. Das hat mit meinen neuen Zugangsdaten funktioniert.

Also nicht bei einem Plugin-Update anmelden (dann kommt der im Eingangsposting beschriebene Fehler), sondern erst unter „Meine Einkäufe“ anmelden, und danach klappt es auch mit den Plugin-Updates.
:slight_smile:

EDIT:

Pustekuchen. Klappt noch immer nicht.
Da hat man die Faxen aber auch langsam dicke…
:expressionless:

Moin Moin @McWorse,

du kannst dich am besten direkt an unseren Vertrieb wenden mit der Anfrage deine beiden Accounts mal gerade zu ziehen um hier die Verwirrung weg zu bekommen, die Kollegen können dir da weiter helfen. Allerdings muss natürlich eindeutig sein, dass du Besitzer der Domain bist, daher am besten direkt Kontakt aufnehmen und das Thema über den richtigen Kanal klären:

Solltest du dazu noch Rückfragen haben, kannst du mir auch gern schreiben und ich versuch dich an die richtigen Ansprechpartner weiter zu reichen!
Grüße,
Tim

1 Like

Ich finde hier keine Funktion, wie ich dir eine PN schicken kann, timbrns. Deswegen auf diesem Weg: Erstmal Danke und ich gerade habe die Kontaktfunktion genutzt.

Nachdem unser neuer Account mit unserem alten Account zusammengelegt wurde, funktioniert die Anmeldung im Backend wieder und ich kann die Updates ziehen.

Danke an die Jungs und Mädels von Shopware!
:slight_smile:

2 Likes