Update auf 6.2 fehlgeschlagen...Backup korrupt :-(

Hallo zusammen,

mir ist gerade leider der Supergau passiert. Ich sichere eigentlich stündlich die Datenbank und habe somit ohne groß zu überlegen das Update von 6.1.6 auf 6.2 gestartet. Das ist fehlgeschlagen… Kein Problem! ich habe ja ein Backup! Nix da…meine DB Sicherungen waren leer! Und es war auch noch ein produktives System…ich könnt mich so ärgern…

Folgender Fehler kommt wenn ich jetzt auf Recovery gehe /recovery/update/index.php

Uncaught Error: Class 'ComposerAutoloaderInitShopwareRecovery' not found in /homepages/46/xxx/htdocs/shopware-6/vendor/shopware/recovery/Common/vendor/autoload.php:7 Stack trace: #0 /homepages/46/xxxx/htdocs/shopware-6/vendor/shopware/recovery/autoload.php(32): require_once() #1 /homepages/46/d346729057/htdocs/shopware-6/vendor/shopware/recovery/Update/index.php(3): require_once('/homepages/46/d...') #2 /homepages/46/xxx/htdocs/shopware-6/public/recovery/update/index.php(6): require_once('/homepages/46/d...') #3 {main} thrown in /homepages/46/xxx/htdocs/shopware-6/vendor/shopware/recovery/Common/vendor/autoload.php on line 7

 

Ich hoffe mir kann jemand weiterhelfen um die Kuh vom Eis zu bekommen.

 

VG Frank

Lade das Update Paket runter und entpack es einmal. Dann rufst du /recovery/update/ auf und machst das Update weiter.

https://www.shopware.com/de/changelog/

https://docs.shopware.com/de/shopware-6-de/update-guides/shopware-aktualisieren-updaten?category=shopware-6-de/update-guides

1 Like

Danke für die schnelle Antwort. Welche Ordner muss ich aus dem Download hochladen? Alle?

Alle

DANKE VIELMALS! Auf den zweiten Versuch hat das dann geklappt.

Da geht einem der Ar… ordentlich auf Grundeis wenn das Backup kein Backup ist :-P.