Update 6.4.3.0 Dashboard summiert Bestellungen und Umsatz auf

Hi zusammen,

ich habe das Update auf die aktuelle Version 6.4.3.0 durchgeführt. Das hat alles soweit funktioniert, bis auf das Dashboard im Backend. Dort werden seit dem Update die Bestellungen und der Umsatz in den Grafiken immer auf den heutigen Tag aufsummiert. Habe dazu mal einen screenshot beigefügt.

Es ist nicht so, dass ab heute die Bestellungen wieder „normal“ angezeigt werden, also dem Tag zugeordnet und dann in der Grafik dargestellt. Sie werden immer auf den aktuellen (heutigen) Tag aufsummiert. Auf dem Bild ist die Anzahl der Bestellungen am heutigen 10.08.2021 41. Kommen morgen 2 dazu, steht der Punkt am 11.08.2021 auf 43 und am 10.08. auf 0 usw. Das Gleiche passiert bei der Grafik zum Umsatz.

Kennt das Problem jemand und gibt es eine Lösung dazu? Wäre super.

Danke schonmal.

Guck mal in diesem Thread, da ist die Rede davon dass die default Timezone der DB nicht sitzt:

Ob das dein Problem ist müsstest du dann mal prüfen. Ist ein Ansatz…

Hi Jörg,

danke für die Info, denke aber das passt. Lt. Developer doku sollte hier „UTC“ oder „Europe/Belin“ stehen. Oder muss hier auf „Europe/Berlin“ geswitcht werden?

Thx

Ich habe dasselbe Problem beim Update von Version v6.4.2.1 auf v6.4.3.0.

Ich habe das Update bisher nur in meiner lokalen Umgebung getestet. Ich verwende in der lokalen Umgebung MAMP Pro mit PHP 7.4.16 und MySQL 5.7.32. Die Default Timezone war tatsächlich nicht gesetzt, was jedoch bisher auch kein Problem war. Ich habe die Default Timezone daraufhin in der my.cnf wie folgt gesetzt:

[mysqld]
default-time-zone = "+02:00"

Server wurde neugestartet und die Einstellung erfolgreich getestet:

mysql> SELECT @@global.time_zone;
+--------------------+
| @@global.time_zone |
+--------------------+
| +02:00             |
+--------------------+
1 row in set (0.00 sec)

mysql> SELECT NOW();
+---------------------+
| NOW()               |
+---------------------+
| 2021-08-12 11:21:28 |
+---------------------+
1 row in set (0.00 sec)

Auch in der phpinfo sieht alles richtig aus:

Ich habe daraufhin auf ein Backup zurückgesetzt und das Update erneut mit der korrekt gesetzten Default Timezone durchgeführt. Der Fehler tritt leider weiterhin auf.

@AndreHerking Du schriebst im anderen Thread:

Das mit der Statistik ist tatsächlich bekannt wenn beim Hoster die Default-Timezone der Datenbank nicht gepflegt ist - dagegen kann man entsprechend etwas tun wenn der Hoster dies korrigiert.

Was genau ist mit „nicht gepflegt“ gemeint bzw. in welchem Zusammenhang ist euch der Fehler bekannt?

Moin,

ich habe den Fehler auch nach dem Update auf 6.4.x.
Bei mir sieht die phpinfo auch korrekt aus :thinking:

Grüße
Matthias

Auch wir haben im Shop das selbe Problem nach dem Update.
Unser Server ist ebenfalls richtig konfiguriert.

SW Version 6.4.3.0

Hier steht alles auf UTC und wir haben das Problem auch.
Der Defekt ist mit dem Update auf 6.4.3.0 aufgetreten, vorher hat die Statistik sinnvolle Daten angezeigt

Ich habe nochmal Rücksprache mit der Entwicklung gehalten - es wird hier in der nächsten Version voraussichtlich einen Fix geben:

Ihr könnt diesen jetzt auch manuell einpflegen sofern es dringend nötig ist. Ansonsten auf das nächste Update warten.

3 Likes