Umfrage: Wer nutzt Paginierung mit rel=“next“ und rel=“prev“?

Hi Zusammen,

ich würde gerne mal eine Umfrage hier im Forum machen (leider gibt es Abstimmungen als solches ja nicht):

Laut Google und den SEO Experten sollte man die Kategorieseiten Paginierung mit rel=“next“ und rel=“prev“ 
realisieren:

https://www.seokratie.de/seitenpaginierung/
https://support.google.com/webmasters/answer/1663744?hl=de

Aber so gut wie kein Shopware Shop, den ich kenne verwendet rel=“next“ und rel=“prev“. Sogar der BVB Shop 
macht dies nicht und der BVB macht ja fast immer alles richtig :slight_smile:

ALSO MEINE FRAGE:

Verwendet Ihr zur Kategoriepaginierung:

(A) die Shopware Standardmethode mit Canonical von den Unterseiten p>1 auf die Hauptseit p=1

(B) die rel=“next“ und rel=“prev“ Method, wie von allen SEOs empfohlen?

Warum habt Ihr Euch so entschieden?

Danke und viele Grüsse,

Jens

P.S.: Wenn man in Shopware rel=“next“ und rel=“prev“ zu Paginierung einstellt, werden auf den Kategorieseiten keine Canonicals mehr
verwendet, was die SEO Onpage Tools (Ryte) einem um die Ohren hauen.

 

Ich habe jetzt einen prominenten Shopware Shop gefunden, bei em rel=“next” und rel=“prev” gesetzt wird:

Allerdings zeigen dabei alle Canonicals auf die erste Seite, was man eigentlich nach den SEOs nicht so machen sollte.

Noch ein Nachgedanke:

Bei infinite Scrolling macht rel=„next“ ja eigentlich keinen Sinn oder? Man hat ja klassischerweise keinen Link zur nächsten Seite …

Euronics ist aber noch eine Shopware 4 - da gab es noch keine Core-Funktion, die haben das wohl selbst gebaut. Natürlich macht as nur Sinn bei paginierten Seiten, nicht bei Infinite Scrolling.

1 Like

@frimipiso schrieb:

Verwendet Ihr zur Kategoriepaginierung:

(A) die Shopware Standardmethode mit Canonical von den Unterseiten p>1 auf die Hauptseit p=1

(B) die rel=“next“ und rel=“prev“ Method, wie von allen SEOs empfohlen?

Warum habt Ihr Euch so entschieden?

Infinite Scrolling ist deaktiviert.
p=1: der canonical-tag enthält die Kategoriestartseite (keine Parameter), mit “index,follow”
p=2 und folgende: kein canonical-tag, nur rel=“prev” und rel=“next” mit “noindex,follow”

Warum? Weil es so korrekt sein soll. :wink:

1 Like

@simplybecause schrieb:

@frimipiso schrieb:

 

Infinite Scrolling ist deaktiviert.
p=1: der canonical-tag enthält die Kategoriestartseite (keine Parameter), mit „index,follow“
p=2 und folgende: kein canonical-tag, nur rel=„prev“ und rel=„next“ mit „noindex,follow“

Warum? Weil es so korrekt sein soll. :wink:

P=2 und folgende: stehen bei uns auf:„index,follow“

Früher gabe es mal diese Einstellung im SEO-Router, aber ist nicht mehr vorhanden:

Die Listing-Unterseiten werden in diesem Fall von Google erfasst aber nicht indexiert. Sofern das Verhalten nicht gewünscht ist, kannst Du im neuen Shopware 5 SEO-Router die Option „Paginierten Inhalt indexieren“ aktiveren.

Wo kann ich die Unterseiten auf noindex setzen?

 

1 Like

Das wird im Template, Einstellung und als Textbaustein geregelt.

  • Theme: Bare/frontend/index/header.tpl
  • Theme: Bare/frontend/plugins/seo/index.tpl 
  • Textbaustein: IndexMetaRobots
  • Einstellungen: SEO-Routereinstellungen: SEO-NoIndex-Queries § 

@Gesundwürzen‍

@,brettvormkopp,

 

  • Theme: Bare/frontend/index/header.tpl <== wurde nichts verändert
  • Theme: Bare/frontend/plugins/seo/index.tpl <== wurde nichts verändert
  • Textbaustein: IndexMetaRobots <== wenn ich auf noindex,follow setze, wirkt sich das doch dann auf alle Seiten, einschließlich der Startseite aus?
  • Einstellungen: SEO-Routereinstellungen: SEO-NoIndex-Queries (p) <== sPage,sPerPage,sSupplier,sFilterProperties,p,n,s,f  <= Schalter f ist gesetzt,

Schau mal in die SEO-Router-Einstellungen unter “SEO-Noindex-Querys”. Da sollte eigentlich der Parameter p stehen.
Die Verwendung von rel=“prev/next” hab ich im Router deaktiviert und dafür ins Template eingefügt, weil bei aktivierter Funktion die Sache icht funktioniert hat, wenn ich mich recht erinnere.

@Gesundwürzen‍
Im Googleindex findet man aber Seiten mit p=1&o=swag_default_sort&n=12 oder ?p=1&o=5&n=12 von Deiner Domain.
Nicht falsch verstehen, ich will hier nichts lostreten.

neuen Shopware 5 SEO-Router die Option “Paginierten Inhalt indexieren” aktiveren.

Hmm, wir haben die 5.3.7, die Option gibt es dort aber nicht.
Nicht, das ich sie haben will, aber wurde die Option nicht wieder entfernt?

Ich glaub, das hängt mit der Aktivierung der Option “prev/next-Tag auf paginierten Seiten benutzen” zusammen.

Schalter  „p“ ist drinnen.

Keine Ahnung, woher diese Seiten kommen, ich möchte ja die Unterseiten auf noindex setzen.
neuen Shopware 5 SEO-Router die Option „Paginierten Inhalt indexieren“ aktiveren. <== diese Einstellung fehlt bei der aktuellen 5.4.1

Aber wie komme ich manuell an diese Einstellung wieder ran?

 

Die Option wurde einfach irgendwann umbenannt, damit die leichter verständlich ist.

warum greift diese Option dann nicht mehr, bzw. werden jetzt die Unterseiten standardmäßig auf noindex oder auf index gesetzt? 

Die Shopware-Implementierung ist wie folgt:

Kategorie-URL ohne p-Parameter:

index, follow + Canonical + next (prev kann es ja nicht geben)

Kategorie-URL mit p-Parameter

noindex, follow + kein Canonical + next/prev

 

Das funktioniert auch genau so, hatte es nochmal in einer 5.4.1 gegengetestet.

Worüber man jetzt natürlich streiten kann ist die URL mit p=1 - weil die ist ja gleichbedeutend mit einer Kategorie-URL wenn es keine Einkaufswelt gibt. Dazu gibt es glaube auch schon ein Ticket, damit man da nochmal drüberschaut.

hallo Moritz,

leider funktioniert das so bei uns nicht. 
 

Kategorie-URL mit p-Parameter

index, follow + kein Canonical + next/prev

es ist kein SEO-Plugin o. ä. installiert, das die Parameter eventuell überschreibt. Auch keine eigenen Erweiterungen…
Kann ich in der Datenbank ansetzen, um den Schalter zu ändern?

 

Das hat mit der Datenbank nichts zu tun, also irgendwas wird da bei euch wohl überschrieben. Mal das Standard-Theme geprüft?
Lädst du ggf. die Paginierten Seiten per Ajax nach? Das könnte ein Problem sein.

Hier funktioniert das:

http://mnaczenski.shopwaretest.de/kochlust-provence/

http://mnaczenski.shopwaretest.de/kochlust-provence/?p=2

Lädst du ggf. die Paginierten Seiten per Ajax nach? Das könnte ein Problem sein.

Kannst du mich bitte aufklären, was es damit auf sich hat? Und wie bzw. wo kann ich das beeinflussen?

Ich habe jetzt den Fehler ausgemacht, aber ich verstehe es nicht.
Dieser Code steht in meinem theme in:plugins/seo:
 

{extends file="parent:/frontend/plugins/seo/index.tpl"}
{block name='frontend_index_header_meta_description'}
{if $SeoMetaDescription}{$SeoMetaDescription|truncate:250:"...":true}
{else}{$smarty.block.parent}
{/if}
{/block}

Aber was hat das mit dem index,follow zu tun?

Wer kann mir das erklären?
Ich will doch nur die Länge der meta-description verändern?

 

Das sollte eigentlich nichts damit zu tun haben. Ich habe das auch geändert.

@Gesundwürzen schrieb:

Ich habe jetzt den Fehler ausgemacht, aber ich verstehe es nicht.
Dieser Code steht in meinem theme in:plugins/seo:
 

{extends file=„parent:/frontend/plugins/seo/index.tpl“}
{block name=‚frontend_index_header_meta_description‘}
{if $SeoMetaDescription}{$SeoMetaDescription|truncate:250:"…":true}
{else}{$smarty.block.parent}
{/if}
{/block}

Aber was hat das mit dem index,follow zu tun?

Wer kann mir das erklären?
Ich will doch nur die Länge der meta-description verändern?

 

Also in meiner Datei im eigene Theme steht:

{extends file="parent:frontend/plugins/seo/index.tpl"}

{block name='frontend_index_header_meta_description'}
	{if $SeoMetaDescription}{$SeoMetaDescription|truncate:500:"...":true}{else}{$smarty.block.parent}{/if}
{/block}

 

Ich habe es auf 500 Zeichen gesetzt.

Nach dem Ändern Cache komplett leeren (nicht nur das schnelle leeren), und Theme neu kompilieren.