Suche funktioniert nicht

Sehr geehrte Damen und Herren, Leider habe ich ein massives Problem mit der Artikelsuche. Es handelt sich heirbei um die Standardsuche ohne Erweiterungsplugin. Wenn ich einen Suchbegriff eingebe (z.B. Grau) und diesen nicht mit des Drückens der Taste „Enter“ bestätige, werden mir alle Artikel korrekt in einem dropdown-menu angezeigt. Sobald ich aber die Eingabetaste nach dem Suchen drücke, springt er (egal was man im Suchfeld eingibt) immer auf den selben Artikel… Mit freundlichen Grüßen, Karl Koch

Hallo, ein solches Verhalten kann durch einen oder mehrere unvollständige/defekte Artikel hervorgerufen werden. Die Umleitung auf einen Artikel findet immer dann statt, wenn eine Artikelnummer zutrifft. Da in diesem Fall bei jeder Suchanfrage auf die selbe Detailseite geleitet wird, so deutet das auf eine fehlende “ordernumber” in der Datenbanktabelle s_articles_details hin. Am besten einmal die Tabelle s_articles_details öffnen und sortieren nach der Spalte ordernumber. Ich gehe davon aus, dass dort mindestens eine Zelle keine [b]ordernumber /b besitzt. Dort sollte dann eine ordernumber definiert werden. Danach sollte dann auch die Suche wieder klappen :wink: Sebastian

2 Likes

VielenVielenVielen Dank Eine ordernumber hat in der Datenbank gefehlt - jetzt gehts wieder. Mit freundlichen Grüßen, Karl Koch

Hallo,

ich habe das gleiche Problem, aber anscheinend nur bei einer bestimmten Suchabfrage. Ordernumber habe ich bereits in der Datenbank geprüft. Es gibt keinen leeren Eintrag. Kennt jemand noch eine andere Ursache?

ähnliches hier… order numer ist überall gesetzt - leider wird trotzdem manches nicht gefunden

Die Suche ist ein Kapitel für sich und muss auf die jeweiligen Shop-Bedürfnisse angepast werden. Siehe dazu Grundeinstellungen -> Suche / Relevanzen