Shopware6 Installation bei ONE.COM nicht möglich? proc_open Issue

Leider erhalte ich beim Update auf die Version 6.5.0.0. einen Fehler:
LogicException('The Process class relies on proc_open, which is not available on your PHP installation.

Nach Rücksprache bei ONE.COM soll SW6 hier nicht installierbar sein (hier das Mail des Supports:
"Ole (One.com)

11. Aug. 2023, 09:25 MESZ

Guten Tag,

vielen Dank für Ihre Nachricht in unserem Chat.

Gerne sende ich Ihnen die Information aus unserer Technikabteilung erneut per E-Mail bezüglich der Installation von Shopware6.

Eine Installation von Shopware6 ist bei uns auf unseren Servern leider nicht möglich. „Proc_open“ ist auf unseren Servern tatsächlich deaktiviert. Die Installation benötigt ebenfalls Redis und kann node.js verwenden, was beides ebenfalls nicht auf unseren Servern unterstützt wird. Das tut mir leid."

Macht jemand hier die gleiche Erfahrung?

VG Christoph

Afaik ist node.js und redis nicht wirklich nötig. Es bleibt also nur das nicht vorhandene proc_open als Problem.

Imho ist das kein Sicherheitsproblem bei richtig konfigurierten Systemen. Man kann es sich aber auch einfach machen und das einfach deaktivieren. Wenn der Hoster es partout nicht aktivieren will, wechsel den Hoster und teil ihnen vielleicht mit dass ihre Systeme noch sicherer werden wenn sie php ganz abschalten!

2 Likes

OK, danke, werde nochmals wg. proc_open insistieren…

Hallo
hast du eine Möglichkeit gefunden SW6 bei one.com zu installieren? Ich scheitere ebenfalls gerade an der proc_open Problematik.

danke

Hallo Marcel, da scheint wohl tatsächlich nur ein Providerwechsel zu helfen…
VG Christoph