[Gelöst]Migrationsassistent lässt sich nicht installieren

Hallo zusammen,

was mache ich falsch? Bekomme den Migrationsassistent im Backend nicht installiert. Wenn ich auf “Installieren” klicke, tut sich garnichts. 

Hi Hifibau,

was sagt denn die Entwickler-Konsole des Browsers dazu?
Ist irgendwas Fehlerhaft etc?

Gruß

Krispin

same here, übrigens auch beim PayPal plugin (lokale testumgebung, nightly build)… console sagt:

vendors-node.js?1570521808:46 POST https://sw6.test/api/v1/_action/plugin/install?pluginName=SwagMigrationAssistant 424
(anonymous) @ vendors-node.js?1570521808:46
e.exports @ vendors-node.js?1570521808:46
UnBK.e.exports @ vendors-node.js?1570521808:30
Promise.then (async)
CgaS.l.request @ vendors-node.js?1570521808:24
l. @ vendors-node.js?1570521808:24
(anonymous) @ vendors-node.js?1570521808:24
value @ app.js?1570521808:1
onInstallPlugin @ app.js?1570521808:1
click @ VM86:3
Xe @ vendors-node.js?1570521808:41
n @ vendors-node.js?1570521808:41
o._wrapper @ vendors-node.js?1570521808:41
vendors-node.js?1570521808:30 Uncaught (in promise) Error: Request failed with status code 424
    at LYNF.e.exports (vendors-node.js?1570521808:30)
    at Rn+g.e.exports (vendors-node.js?1570521808:30)
    at XMLHttpRequest.d.onreadystatechange (vendors-node.js?1570521808:46)
LYNF.e.exports @ vendors-node.js?1570521808:30
Rn+g.e.exports @ vendors-node.js?1570521808:30
d.onreadystatechange @ vendors-node.js?1570521808:46
Promise.then (async)
onInstallPlugin @ app.js?1570521808:1
click @ VM86:3
Xe @ vendors-node.js?1570521808:41
n @ vendors-node.js?1570521808:41
o._wrapper @ vendors-node.js?1570521808:41

scheint ein version mismatch zu geben:

{"errors":[{"code":"0","status":"424","title":"Failed Dependency","detail":"Required plugin\/package \u0022shopware\/core 6.0.0+ea1.1\u0022 does not match installed version 9999999-dev.","trace":"#0 \/Users\/Nils\/Projects\/sw6\/development\/platform\/src\/Core\/Framework\/Plugin\/Requirement\/RequirementsValidator.php(130): Shopware\\Core\\Framework\\Plugin\\Requirement\\RequirementsValidator-\u003EcheckRequirement(Array, \u0027shopware\/core\u0027, \u00279999999-dev\u0027, Object(Shopware\\Core\\Framework\\Plugin\\Requirement\\RequirementExceptionStack))\n#1  ...

 

Hallo,

ihr benutzt offensichtlich die Entwicklerversion von Github. Über den Store könnt ihr aber nur Plugins für die Release Versionen von Shopware ziehen. Also auch über den First-Run-Wizard. 
Da die Entwicklung momentan noch sehr viele Brüche mit sich bringt, können wir nicht sicherstellen, dass eine ältere Version von PayPal oder dem Migration Assistent noch auf dem aktuellen Master funktioniert. Daher gibt es dort diese Einschränkunen. 
Beide Plugins findet ihr aber auf Github. Dort sollte der aktuelle Master-Stand auch immer kompatibel mit dem Shopware Plaform Master-Stand sein.

Viele Grüße aus Schöppingen

cool Michael Telgmann

1 Like

…dann sage ich mal vielen Dank für die Info  Thumb-Up

Hallo,

ich habe auch das Problem, dass ich keine Plugins installieren kann. Ich habe SW6 über die Shopware Seite geladen. v6.0.0 Early Access 1.1

Die Entwicklerkonsole sagt:

vendors-node.js?1570705149:46 GET https://domain.url/api/v1/_action/store/download?language=de-DE&pluginName=SwagMigrationAssistant 500 (Internal Server Error)
(anonymous) @ vendors-node.js?1570705149:46
e.exports @ vendors-node.js?1570705149:46
UnBK.e.exports @ vendors-node.js?1570705149:30
Promise.then (async)
CgaS.l.request @ vendors-node.js?1570705149:24
l. @ vendors-node.js?1570705149:24
(anonymous) @ vendors-node.js?1570705149:24
value @ app.js?1570705149:1
downloadPlugin @ app.js?1570705149:1
click @ VM819:3
Xe @ vendors-node.js?1570705149:41
n @ vendors-node.js?1570705149:41
o._wrapper @ vendors-node.js?1570705149:41
vendors-node.js?1570705149:30 Uncaught (in promise) Error: Request failed with status code 500
    at LYNF.e.exports (vendors-node.js?1570705149:30)
    at Rn+g.e.exports (vendors-node.js?1570705149:30)
    at XMLHttpRequest.d.onreadystatechange (vendors-node.js?1570705149:46)

Liegt da ein falsche Serverkonfiguration vor?

Vielen Dank

Mark Mager

Hallo Mark,

die genaue Fehlermeldung wäre hilfreich. Kannst du mal in den Log Files schauen, ob du da was findest?

Viele Grüße aus Schöppingen

cool Michael Telgmann

Hallo Michael,

ich finde im ServerLog folgendes:

1.Calling function ‘check_phpini_changes’ from plugin ‘webserver_plugin’ raised by action ‘server_plugins_loaded’.

und

2. Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock

die kommen im Minutentakt. 

Ich bin mir aber nicht sicher ob das überhaupt was mit SW6 zu tun hat?!?

Gruß Mark

Hallo Mark,

kannst du mal im Ordner von Shopware schauen unter “var/log” ?

Viele Grüße aus Schöppingen

cool Michael Telgmann

Da ist nur eine prod.log drin mit folgendem Inhalte:

[2019-10-10 11:27:45] request.INFO: Matched route "frontend.cms.page". {"route":"frontend.cms.page","route_parameters":{"_route":"frontend.cms.page","id":null,"XmlHttpRequest":true,"_controller":"Shopware\\Storefront\\Controller\\CmsController::page"},"request_uri":"https://domain.url/widgets/cms","method":"GET"} []
[2019-10-10 11:27:45] app.DEBUG: #1 Rule detection: Customers from USA with priority 100 [] []
[2019-10-10 11:27:45] app.DEBUG: #2 Rule detection: Cart >= 0 with priority 100 [] []
[2019-10-10 11:27:45] app.DEBUG: #3 Rule detection: Cart >= 0 (Payment) with priority 100 [] []
[2019-10-10 11:27:45] app.DEBUG: #4 Rule detection: Sunday sales with priority 2 [] []
[2019-10-10 11:27:45] app.DEBUG: #5 Rule detection: All customers with priority 1 [] []
[2019-10-10 11:27:45] php.CRITICAL: Argument 1 passed to Shopware\Storefront\Controller\CmsController::page() must be of the type string, null given, called in /var/www/clients/client1/web1/web/sw6/vendor/symfony/http-kernel/HttpKernel.php on line 151 {"exception":"[object] (Symfony\\Component\\Debug\\Exception\\FatalThrowableError(code: 0): Argument 1 passed to Shopware\\Storefront\\Controller\\CmsController::page() must be of the type string, null given, called in /var/www/clients/client1/web1/web/sw6/vendor/symfony/http-kernel/HttpKernel.php on line 151 at /var/www/clients/client1/web1/web/sw6/vendor/shopware/storefront/Controller/CmsController.php:48)"} []
[2019-10-10 11:27:45] request.CRITICAL: Uncaught PHP Exception TypeError: "Argument 1 passed to Shopware\Storefront\Controller\CmsController::page() must be of the type string, null given, called in /var/www/clients/client1/web1/web/sw6/vendor/symfony/http-kernel/HttpKernel.php on line 151" at /var/www/clients/client1/web1/web/sw6/vendor/shopware/storefront/Controller/CmsController.php line 48 {"exception":"[object] (Symfony\\Component\\Debug\\Exception\\FatalThrowableError(code: 0): Argument 1 passed to Shopware\\Storefront\\Controller\\CmsController::page() must be of the type string, null given, called in /var/www/clients/client1/web1/web/sw6/vendor/symfony/http-kernel/HttpKernel.php on line 151 at /var/www/clients/client1/web1/web/sw6/vendor/shopware/storefront/Controller/CmsController.php:48)"} []

 

Ich habe gerade nochmal den Einrichtungsassistenten gestartet.

Ich kann das PayPal Modul nicht konfigurieren, es erscheint die Fehlermeldung: Konfiguration fehlgeschlagen.

Und ich kann auch keine Demodaten installieren.

Das scheint doch eher auf ein Problem mit der Datenbank zu sein.

Und ich kann auch keine Demodaten installieren.

…geht bei mir auch nicht. Ich denke ich werde die ganze Testumgebung noch mal löschen und neu installieren. Wer weis was bei der 1. Installation schief gelaufen ist. 

So, habe SW 6 (v6.0.0 Early Access 2) noch mal komplett neu installiert. Mein Problem, das ich den Migrationsassistent im Backend nicht installiert bekomme, besteht immer noch.

Hat jemand Shopware v6.0.0 Early Access 2 bereits an laufen bekommen, wo sich der Migrationsassistent im Backend installieren lässt? Beim Klick auf den Button tut sich gar nichts :-( 

Bei mir läufts…

Versteh ich nicht  Undecided Hast du das während der Installationsroutine von Shopware 6 installiert, oder im nachhinein?

Ich habe das EA2 Update gemacht, dann ging nichts mehr, PlugIns in der Datenbank deaktiviert, lief wieder, Update des PlugIns gemacht und aktiviert. Dann musste ich noch das 5.5 PlugIn im ‚alten‘ Shop aktualisieren.

Frage…was für eine Domain muss ich hier eingeben? Die sw6.hifibau.de ist eine Sub-Domain die auf den Liveshop hifibau.de weiter leitet…komme einfach nicht weite  Crying

Da ich immer noch mit meinem Problem des Migration Assistent kämpfe, habe ich jetzt mal eine einfache Frage?

Was passiert bei Euch wenn ihr auf dem Button klickt? Sollte hier nicht das Plugin starten um die Möglichkeit zu haben eine Verbindung herzustellen?

An der Stelle kannst du den Migrationsassistenten laden und installieren, bzw. aktualisieren. Die Einrichtung und der Verbindungsaufbau funktioniert dann über Einstellungen > Plugins > Migrationsassistent.

1 Like

Leider finde ich das Plugin nicht in meiner Übersicht. Beim suchen unter “Meine Plugins” rödelt der immer weiter. Bekomme auch nach dem Klick auf “Installieren” keinerlei Rückmeldung das dass Plugin installiert ist.