s_core_snippets > Export CSV

Hallo, ich würde mir gerne die Textbausteine exportieren, leider kommt aber beim export nicht alles in die Tabelle. Die Aufteilung (am Beispiel der ersten Zeichen) sieht wie folgt aus: namespace;name;value-en\_GB-1;dirty-en\_GB-1;value-de\_DE-1;dirty-de\_DE-1;value-en\_GB-3;dirty-en\_GB-3;value-fr\_FR-4;dirty-fr\_FR-4 'backend/activate/skeleton;'WindowTitle;'Cache leeren;'0;'Cache leeren;'0;;;; 'backend/analytics/view/main;'toolbar/update;'Aktualisieren;'0;'Aktualisieren;'0;;;; Wie man sieht wird nur der deutsche Text exportiert, obwohl der englische (wenn man es sich im Backend ansieht und über die mySQL Datenbank) auch vorhanden ist. Weiß jemand hierfür eine Lösung? Viele Grüße, Tobias

*push* - ist das bei jedem von euch so? Oder kommen auch die englischsprachigen Texte beim Export? Grüße, Tobias

Hallo, in meinem Demoshop wird auch die englische Übersetzung mit exportiert. Hast du das mal im Demoshop probiert? www.shopwaredemo.de/backend Moritz

1 Like

Hallo, du hast recht, hier passt es: namespace name value-de\_DE-1 dirty-de\_DE-1 value-en\_GB-1 dirty-en\_GB-1 value-nl\_NL-1 dirty-nl\_NL-1 value-en\_GB-2 dirty-en\_GB-2 backend/abo\_commerce/abo\_commerce/view/main list/column\_customer\_group Kundengruppe 0 Customer group 0 Echt seltsam. naja, dann werde ich wohl den englischen Text aus dem Demoshop mal nehmen ums mir korrekt in meinen Shop zu importieren bzw. ums ins (im Anschluß) ins französische übersetzen zu lassen. Besten Dank! Tobias

Hey Tobias, was brauchst du denn? http://store.shopware.com/swag978520396 … reich.html Für Frankreich/Französisch gibt es von uns auch kostenlose Internationalisierungserweiterungen http://store.shopware.com/search?sSearc … alisierung Sebastian

1 Like

Hi Sebastian, das ist super, hab ich gar nicht entdeckt (hatte nach französisch im Plugin-Manager gesucht). Klasse, vielen Dank!! Schöne Grüße, Tobias

Leider habe ich nun noch immer ein seltsames Phänomen bei den Textbausteinen. Und zwar gibt es dort mehrere Menüzungen: [list] Default / de_DE Default / en_GB Default / fr_FR [color=red]English / en_GB Französisch / fr_FR[/color] [/list] Die rot markierten sind leer, aber leider greift hierauf der Shop zu. Wie kann ich die als Default bezeichneten Sprachen auch tatsächlich als Default setzen? In den Grundeinstellungen -> Shops sind jeweils die Sprachen angegeben. Vielen Dank für eure Hilfe, Tobias

*push* Kann mir jemand erklären, warum (wie beschrieben) beim Sprachenwechsel auf Englisch oder Französisch nicht die jeweiligen Default-Werte (die einen ordnungsgemäßen Inhalt haben) verwendet werden, sondern die anderen leeren Sprachdefinitionen? Quasi im Frontend ist dann kein Übersetzter Text zu sehen! Grüße, Tobias

Hallo, die Lokalisierung der Shops ist aber auf jeden Fall korrekt bei dir? Schau dir sonst mal die Konfiguration in der Shopware-Demo (www.shopwaredemo.de/backend) an. Wüsste nicht, warum er das bei dir nicht anzeigen sollte, dass ist ein Standard, der in jedem Shop eig. funktioniert. Grüße Moritz

Hallo Moritz, ja, die Lokalisierung ist richtig eingestellt. Ich hab nun die Sprachen in den Grundeinstellungen gelöscht (mit Ausnahme von DE) und wieder neu angelegt. Jetzt klappt es. Keine Ahnung woran sich das System verschluckt hat. Eventuell, weil die Daten durch einen Magento Import generiert wurden?! Grüße, Tobias