Probleme mit Artikeleigenschaften - Vergleich zw. Gruppen

Hallo zusammen, habe heute mit den Eigenschaften rumprobiert und bin dabei auf folgendes Problem gestossen. Ich habe einen Pool aus z.B. 20 Eigenschaften angelegt und des Weiteren zwei Gruppen (z.B. Waschmaschine (A) und Waschtrockner (B)). Die Gruppen A und B teilen sich die Eigenschaften 1-16, d.h. die Eigenschaften kommen bei beiden vor und wurden beiden Gruppen zugeteilt. Eigenschaft 17+18 kommt nur bei A vor, 19+20 nur bei B. Wenn ich jetzt Artikel aus A und B vergleiche hätte ich eigentlich erwartet das der Shop die in beiden Gruppen vorkommenden Eigenschaften 1-16 automatisch erkennt und richtig gegenüberstellt. Bei den exklusiven Eigenschaften wäre ich davon ausgegangen das er diese dann einfach dranhängt bzw. die Felder für 17+18 bei Gruppe A füllt und bei der Gruppe B einfach leer lässt da dort nicht vorhanden. Statt dessen mixt der Shop bei meinem Produktvergleich alles wild durcheinander so dass am Ende gar nichts passt, d.h. bei Gruppe A steht das Gewicht in Zeile 2, bei B jedoch in Zeile 10 usw. Ist das ein Fehler oder ist es nicht vorgesehen zwischen 2 Gruppen zu vergleichen? Stand jetzt funktioniert der Vergleich bei mir nur wenn ich innerhalb einer Gruppe bleibe.

*schieb*…:slight_smile:

Hast du da evtl. mal einen Screenshot, der das ganze verdeutlichen könnte?

Hi Sebastian, klar…:slight_smile: Die Eigenschaften Gewicht, Maße oder Leistung kommen z.B. bei beiden Gruppen vor, werden aber nicht gegenübergestellt sondern tauchen verschoben auf.

*nochmals schieb*…:sunglasses:

Das System kann hier nicht erkennen, dass es sich um Werte handelt, die in beiden Gruppen vorkommen. Da du 2 komplett getrennte Eigenschaftsgruppen miteinander vergleichst, können diese auch nicht gegenüber gestellt werden. Artikel eines gleichen Typs, z.B. Kaffe-Vollautomat, sollten alle auf die gleichen Eigenschaftsgruppe zurückgreifen. Das System vergleicht ja nicht die “Bezeichnungen” der Eigenschaften aus unterschiedlichen Gruppen.

1 Like

Hallo Sebastian, ok, alles klar…:frowning: Ich bin davon ausgegangen das das System, eben weil man z.B. die Eigenschaft „Gewicht“ im Optionsfeld nur einmal anlegt und dann quasi nur (z.B.) in Gruppe1 und Gruppe2 verschiebt, erkennt das es in beiden Gruppen die gleiche Eigenschaft „Gewicht“ ist. Ich habe meine Gruppen bewusst recht spezifisch angelegt um zu vermeiden das ich später einen Wulst von Eigenschaften habe der zum größten Teil für den Kunden nicht relevant ist und nur unübersichtlich wird. Beispiel (um beim Thema Kaffee zu bleiben): Vergleich zwischen Gruppe „Kaffeevollautomat“ und „Kapsel / Pad Maschine“. Beide Gruppen für den Kunden irgendwo „artverwandt“ da erstmal „Kaffeemaschine“, jedoch eigentlich grundverschieden. Eigenschaften die für die eine Gruppe wichtig sind (Mahlwerk, Bohnenbehälter usw.) sind bei der anderen schlicht nicht da…ich hatte gehofft das dann zumindest die „Schnittmenge“ der zwei Gruppen (Gewicht, Farbe, Größe etc.) gegenübergestellt wird.

ich häng mich da mal dran … hab das jetzt auch mit 2 unterschiedlichen Gruppen getestet - und das ist echt wild was da raus kommt!! ich habe mal als Test DVDs mit Dessous vergleichen - keine Eigenschaft der einen Gruppe gibt es bei der anderen Gruppe. Ok, ich gehe davon aus, das wird so schnell keiner machen, aber ein Bug ist es trotzdem :slight_smile: Seht selbst: Lösungen könnt ich mir vorstellen - beim Vergleich zweier verschiedener Gruppen, werden keine Eigenschaften angezeigt - Es werden nur Eigenschaften angezeigt, die beiden Gruppen zugeordnet sind - oder optimal: es funktioniert, dass die Werte einfach in der richtigen Zeile stehen :slight_smile: DANKE lg thomas

nach dem motto: „bilder sagen mehr als tausend worte“ :slight_smile: -->so sollte das ganze aussehen: DANKE lg thomas

Danke für deinen Screenshot. Ich habe das bereits als Ticket aufgenommen. Falls ich dir vorab eine Lösung bereitstellen kann, werde ich das hier direkt posten, bzw. die Lösung in das Ticket packen und darauf verweisen :wink:

1 Like

DANKE … (p.s. bin noch beim „auf herz und nieren testen“ - bis ich live gehe dauert das eh noch seine zeit - mir reicht es momentan schon, wenn ich weiss „es wird behoben“ :-)) lg und schönes wochenende thomas

Gibt es hier schon eine Lösung? Ich stehe gerade vor dem gleichen Problem, ein TracTicket habe ich nicht gefunden.

Weil ich gerade wieder drübergestolpert bin: der bug ist auch in der neuen version 3.5.5 noch immer vorhanden edit: hier das ticket dazu gefunden: http://trac.shopware.de/trac/ticket/5501 lg thomas

Hallo, ich müsste die Box Vergleiche etwas breiter haben. Durch die langen Namen der Eigenschaften verschiebt sich leider alles. Wenn ich 4 Artikel vergleiche, hängt einer immer ganz unten. Woran kann das liegen? Und noch was: Wenn ich die Artikeleigenschaften anlege, erscheine diese über dem Text in der Artikelbeschreibung. Wie kann ich das ausblenden?? Das möchte ich dort nicht haben. Habe dafür einen neuen Reiter angelegt. Oder aber umleiten auf den neuen Reiter. Ich hoffe es kann mir jemand helfen, den hier bin ich absolut überfragt! EDIT: Problem gelöst!

Hallo Zusammen, hat das Problem aktuell noch jemand? Leider funktioniert der Track-Link nicht und nachdem ich nun schon fast ne Stunde das Forum durchsucht habe finde ich sonst niemand mehr mit dem ungelösten Problem, dass sich die Werte zu den Eigenschaften verschieben (ich meine damit nicht die Höhe der Felder) LG Jochen

Hallo, Ich stehe aktuell vor dem gleichen Problem wie der Artikelersteller. Wenn es hierfür eine Lösung gibt, wäre ich sehr dankbar, wenn diese hier geteilt werden könnte. Das Problem scheint ja schon länger zu bestehen…

Hallo, das hier behandelte Thema sollte in der aktuellen Version auf jeden Fall nicht vorkommen können. Die gesamte Darstellung, speziell mit verschiedenen Gruppen, wurde komplett überarbeitet. Sebastian