Problem bei erneuten installieren von PayPal nach Änderung der PayPal-API

Hallo,

 

da sich bei PayPal laut Shopware die API geändert hat, konnten in unserem Shop die Kunden nicht mehr mit PayPal bezahlen (Endlosschleife im Abschluss der Zahlung).

Wir haben nun, wie in der Beschreibung steht, das PayPal-Plugin deinstalliert, das neue Plugin heruntergeladen, und versucht, es zu installieren. Hierbei trat ein Fehler mit folgender Meldung auf…

Plugin-Manager

Plugin PayPal Payment konnte nicht erfolgreich installiert werden.
[Semantical Error] The annotation „@creation_date“ in class TrustedShopsDataModel was never imported. Did you maybe forget to add a „use“ statement for this annotation?

An was liegt das und wie kann das Problem behoben werden?

 

Viele Grüße

Wilhelm Walker

Hi Wilhelm,

das Problem ist hier scheinbar ein Dritt-Anbieter Plugin, welches Trusted Shops in deinem Shop integriert. Dieses wurde ich mal deaktivieren/deinstallieren und dann noch mal die Installation des Paypal Plugins versuchen.

Viele Grüße aus Schöppingen

cool Michael Telgmann

Was könnte das für ein PlugIn sein? In den Bildern 1 und zwei habe ich die Liste der aktiven Plugins.

 

 

 

Was merkwürdig ist, in den inaktiven Plugins findet sich die alte Version asu 2013 von PayPal. …

 

Wenn ich das Update von PayPal fahren will kommt folgende Meldung…

 

 

Wenn ich das Plugin aus 2013 aktivieren möchte, dann kommt dese Meldung…

 

 

 

 

 

 

@walker-vertrieb schrieb:

Wenn ich das Plugin aus 2013 aktivieren möchte, dann kommt dese Meldung…

 

image

Hallo,

zumindestens diese Meldung konnten wir bei uns beseitigen, indem wir dieses Plugin einfach neu installiert hatten und dann funktionierte es auch wieder, siehe: http://forum.shopware.com/discussion/35436/paypal-plugin-version-3-0-1-laesst-sich-nicht-auf-version-3-3-7-aktualisieren .

Beste Grüße

Sebastian

leider hat das alles nichts geholfen. Ich habe eine zweite Installation gefunden und beide per FTP geöscht.

Danach das Plugin neu hochgeladen. Über den Manager wieder gelöscht und neu hochgeladen.

Bei der Aktivierung kam folgende Meldung:

 

Plugin-Manager

Plugin PayPal konnte nicht erfolgreich installiert werden.
[Semantical Error] The annotation “@creation_date” in class TrustedShopsDataModel was never imported. Did you maybe forget to add a “use” statement for this annotation?

 

Was könnte noch versucht werden?

 

Viele Grüße

Wilhelm

Hallo,

hast du einfach mal das TrustedShops-Plugin neu installiert (und den Shop Cache etc. gelöscht)? Weil da ja schließlich steht, dass das Model von TrustedShops (TrustedShopsDataModel) die Annotation nicht hat, die es scheinbar haben müsste, somit scheint ja dieses Plugin den Fehler zu verursachen, der sicherlich nach der Installation, wo er den Cache leeren will, kommt.

Beste Grüße

Sebastian

1 Like

Hallo Sebastian,

danke für die Hilfe! Hat jetzt super geklappt (wer lesen kann ist im Vorteil - ich war wirklich etwas blind, denn dass der Fehler aus Trusted-Shop kam, das hatte ich völlig übersehen).

Nochmals herzlichen Dank und viele Grüße

Wilhelm