Problem bei der Installation

Hallo,

bei der Installation baut sich die Seite zum Bestätigen der AGB nicht auf.

domain.de/recovery/install/index.php/license

Es erscheint nur: sitemap.html?error=403

Was mache ich falsch?

Auf der vorherigen Seite mit den Systemvoraussetzungen scheint noch alles soweit gut zu sein.
Einziger Mangel; memory_limit Warnung 512M 256M

Kann mir jemand helfen?

schwer zu sagen, was die Ursache ist.
403 bedeutet sinngemäß, dass die Seite zwar vorhanden ist, du aber keine Berechtigung hast.
Zu geringes Memory Limit erzeugt eine andere Fehlermeldung, soltest du trotzdem dann mal hochsetzen.

Evtl. blockt deine Firewall was, oder manchmal können es auch Browsererweiterungen sein (diese deaktivieren, Cache löschen).

1 Like

Vielen Dank, 

Das hat leider noch keinen Erfolg gebracht.

Ich habe es von verschiedenen Rechner und mit verschiedenen Browsern versucht - ohne Erfolg.

Das Memory Limit konnte ich per .htaccess erhöhen

 

@frezno schrieb:

schwer zu sagen, was die Ursache ist.
403 bedeutet sinngemäß, dass die Seite zwar vorhanden ist, du aber keine Berechtigung hast.
Zu geringes Memory Limit erzeugt eine andere Fehlermeldung, soltest du trotzdem dann mal hochsetzen.

Evtl. blockt deine Firewall was, oder manchmal können es auch Browsererweiterungen sein (diese deaktivieren, Cache löschen).

Worum geht es denn hier genau, Neuinstallation oder Update und wenn ja welche Version? Sicher, dass es sich hierbei um Shopware 6 oder nicht doch eher um Shopware 5 handelt?

Es geht um eine Neuinstallation von 6.3.4.1.

Du hast auch auf das /public Verzeichnis umgeleitet? Einen Link bzw. Fehlerlog hast du nicht?

Es geht direkt auf das /public-Verzeichnis,

die ersten beiden Installationsseiten funktionieren ja auch.

https://www.spiel-und-stift.de

Auf Anhieb würde ich auf die .htaccess tippen. Ist diese vorhanden bzw. korrekt hinterlegt?

In /public gibt es keine .htaccess,

In /public/recovery/install habe ich die .htaccess lediglich um eine Zeile zum memory limit erweitert.

    RewriteEngine On

    RewriteRule .* - [E=MOD_REWRITE:1]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^(.*)$ index.php [QSA,L]

    # Set REQUEST_SCHEME (standard environment variable in Apache 2.4)
    RewriteCond %{HTTPS} off
    RewriteRule .* - [E=REQUEST_SCHEME:http]

    RewriteCond %{HTTPS} on
    RewriteRule .* - [E=REQUEST_SCHEME:https]


DirectoryIndex index.php

DirectoryIndex index.php


    Options -MultiViews



    RewriteEngine On

    RewriteCond %{REQUEST_URI}::$1 ^(/.+)/(.*)::\2$
    RewriteRule ^(.*) - [E=BASE:%1]

    # Sets the HTTP_AUTHORIZATION header removed by Apache
    RewriteCond %{HTTP:Authorization} .
    RewriteRule ^ - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{ENV:REDIRECT_STATUS} ^$
    RewriteRule ^index\.php(?:/(.*)|$) %{ENV:BASE}/$1 [R=301,L]

    # If the requested filename exists, simply serve it.
    # We only want to let Apache serve files and not directories.
    RewriteCond %{REQUEST_FILENAME} -f
    RewriteRule ^ - [L]

    # Rewrite all other queries to the front controller.
    RewriteRule ^ %{ENV:BASE}/index.php [L]



    
        RedirectMatch 302 ^/$ /index.php/
    


php_value memory_limit 512M

 

Vielleicht liegt gerade dort das Problem, bei mir ist unter /public nämlich eine .htaccess vorhanden.

Bei mir gibt es da eine .htaccess.dist:

# BEGIN Shopware
# The directives (lines) between "# BEGIN Shopware" and "# END Shopware" are dynamically generated. Any changes to the directives between these markers will be overwritten.

DirectoryIndex index.php


    Options -MultiViews



    RewriteEngine On

    RewriteCond %{REQUEST_URI}::$1 ^(/.+)/(.*)::\2$
    RewriteRule ^(.*) - [E=BASE:%1]

    # Sets the HTTP_AUTHORIZATION header removed by Apache
    RewriteCond %{HTTP:Authorization} .
    RewriteRule ^ - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{ENV:REDIRECT_STATUS} ^$
    RewriteRule ^index\.php(?:/(.*)|$) %{ENV:BASE}/$1 [R=301,L]

    # If the requested filename exists, simply serve it.
    # We only want to let Apache serve files and not directories.
    RewriteCond %{REQUEST_FILENAME} -f
    RewriteRule ^ - [L]

    # Rewrite all other queries to the front controller.
    RewriteRule ^ %{ENV:BASE}/index.php [L]



    
        RedirectMatch 302 ^/$ /index.php/
    



    
        Header set Content-Security-Policy "script-src 'none'"
    


# END Shopware

 

Die habe ich zusätzlich zu der .htaccess auch dort liegen. Sichere die .htacess.dist doch mal, und lege diese zusätzlich als .htaccess in den public Ordner.

Das hilft leider auch nicht.

Mist, ich würde dir da echt gerne helfen und überlege auch, woran es liegen könnte? Die Rechte stimmen auch alle? Ist eine sitemap.xml vorhanden, bei der eventuell die Rechte nicht stimmen?

Jetzt klappt es doch! Woran lag es?

An meiner Blödheit:

Ich habe das Shopware Verzeichnis und sämtliche Unterordner nach .htaccess durchsucht und diese überprüft,

nur das übergeordnete Hauptverzeichnis nicht.

 

Vielen Dank für die Hilfe und die investierte Zeit.

Kein Problem, ich war jetzt auch mit meinem Latein am Ende, hauptsache jetzt läuft alles. :wink:

1 Like