Pluginmanager zeigt Fehler an

Hallo, habe seit heute das Problem das beim Aufruf des Pluginmanagers folgender Fehler angezeigt wird: Plugin-Liste konnte wegen eines defekten Plugins nicht geladen werden Fehler-Protokoll: Zend Optimizer not installed This file was encoded by the Zend Guard. In order to run it, please install the Zend Optimizer (available without charge), version 3.0.0 or later. Seeing this message instead of the website you expected? This means that this webserver is not configured correctly. In order to view this website properly, please contact the website’s system administrator/webmaster with the following message: The component “Zend Optimizer” is not installed on the Web Server and therefore cannot service encoded files. Please download and install the Zend Optimizer (available without charge) on the Web Server. Note: Zend Technologies cannot resolve issues related to this message appearing on websites not belonging to Zend Technologies. What is the Zend Optimizer? The Zend Optimizer is one of the most popular PHP plugins for performance-improvement, and has been available without charge, since the early days of PHP 4. It improves performance by scanning PHP’s intermediate code and passing it through multiple Optimization Passes to replace inefficient code patterns with more efficient code blocks. The replaced code blocks perform exactly the same operations as the original code, only faster. In addition to improving performance, the Zend Optimizer also enables PHP to transparently load files encoded by the Zend Guard. The Zend Optimizer is a free product available for download from Zend Technologies. Zend Technologies also developed the PHP scripting engine, known as the Zend Engine. Bitte beheben Sie den Fehler oder löschen Sie das fehlerhafte Plugin! Interessant ist das ich mit dem ioncube loader arbeite und auch installiert habe Bis letzte Woche ging noch alles, seit heute leider nicht mehr. Habe auch schon den Tip befolgt wenn der Hoster ( in diesem Fall 1und1) die PHP Version ändert und habe entsprechende Zeilen in die Plugin.php datei eingetragen. Der Fehler besteht leider weiter. Auf dem Server läuft PHP Version 5.2.17 Installiert ist Shopware 3.5.6 Rev. 8280 Wer kann mir bei dem Problem helfen?

Hallo, Konntest du das Problem bereits lösen? Die Meldung besagt, dass wohl eine Datei oder Plugin bei dir installiert wurde, welches mit Zend verschlüsselt wurde. Zend ist aber bei dir nicht installiert. Wenn du bei 1und1 bist, so musst du ggf. nach jeder Installation eines Plugins die Systemvoraussetzungen prüfen und in den jeweiligen Ordnern anpassen. Bei 1und1 ist das ja nicht sauber global möglich. (Siehe viele Themen hier im Forum)

Hallo, nein bis jetzt konnte ich es nicht lösen. Mit Systemvoraussetzungen meinst du da ob ich die php.ini datei dort mit rein kopiert habe? Als letztes habe ich das Amazonpayment Plugin installiert.

Hi, dann würde ich das Plugin entweder vom Server einmal löschen oder überall die ini reinkopieren.

1 Like

Das Löschen hat den gewünschten Erfolg gebracht. Versuche das Plugin mal erneut zu installieren. Melde mich sobald ich näheres dazu sagen kann.

Hi, wichtig ist auf jeden Fall, dass die richtige Version des Plugins installiert wird. Zusätzlich muss dann jeweils die php.ini dort hinkopiert werden, damit die Viraussetzungen dann in dem neuen Pluginverzeichnis passen. Das Problem tritt bei 1und1 ja immer auf, wenn neue Verzeichnisse angelegt werden.

Das Plugin scheint es nur in der einen Version zu geben “amazoncba35z.Zip” (SW 3.5.3 | Plain ). Es ist wohl nur für den Zend optimizer.

Für alle die danach suchen: Hier der Thread wo man das aktuelle Modul für Ioncube herunterladen kann: programmierung-f13/zahlen-uber-amazon-plugin-lauft-nicht-t2843-10.html?hilit=amazon Der anfängliche Fehler taucht damit auch nicht mehr auf. Vielen Dank für die Hilfe!!!