Plugin : DHL Integration (shopware)

Hallo Tobi,

so wie ich es im Kopf habe ist es nicht vorgesehen mehrere Pakete pro Bestellung zu versenden, das heißt, wenn du ein Label für eine Bestellung erstellt hast kannst du kein weiteres mehr machen.

Das ist nicht nur bei Pakete über 31,5 kg sondern auch bei Teilliefeungen, wo man auf Intraship ausweichen muss.

Es gibt ja noch ein weiteres  aber kostenpflichtiges Plugin von einem anderen Hersteller, was dann mehr kann.

Gruß Uwe.

 

Es gibt irgendwie noch immer Probleme bei der Packstation-Auswahl:

Wenn bei uns ein Kunde eine Packstation sucht, auswählt und seine Postnummer einträgt und danach auf “Nächster Schritt” klickt, passiert nichts mehr.

In der Console bekommen wir die Fehlermeldung:

“POST https://shop.beetfreunde.de/dhl/saveShipping 503 (Service Unavailable)”

Hat jemand eine Idee, woran das liegen könnte, oder kennt das Problem?

Hat sich Shopware schonmal zur Zukunft dieses Plugins geäußert? Für uns fehlen hier leider wichtige Funktionen wie die Teillieferung / mehrere Labels pro Bestellung & der Versand ins Nicht-EU Ausland. Wird das in absehbarer Zeit, (also 3-6 Monate) integriert? 

Sonst würden wir auf den VIISON Adapter wechseln, der diese Funktionen bereits sehr gut integriert.

Shopware : Könnt ihr da etwas sagen?

Hallo,

@dreitags‍ von unserer Seite gibt es da aktuell keinerlei Planungen das Plugin weiter auszubauen.

Sebastian

Hallo allerseits,

bei uns wurden die Unterkonten im GKP der DHL neu strukturiert und somit ist unser Account nicht mehr der Nutzergruppe “STANDARD_GRUPPENPROFIL” zugeordnet. Dies hat zur Folge, dass beim Übertragen der Daten die folgende Meldung geworfen wird

Es ist ein Fehler aufgetreten: Unknown group profile

In den Einstellungen ist die Nutzergruppe leider nicht auswählbar. Wird dem Account wieder die alte Gruppe zugewiesen, funktioniert alles bestens, nur ist das leider keine Lösung.

Die DHL schiebt die Schuld auf das Plugin, gab mir jedoch den Tipp, als erstes einfach einen neuen User anzulegen und es dann nochmal zu testen. Leider auch erfolglos.

An der Gruppe selbst liegt es auch nicht, die Labelerstellung im Portal funktioniert.

Hat jemand einen Vorschlag, wie das gelöst werden kann?

Vielen Dank!

Hallo,

ich habe mich durch alle Diskussionen zu diesem Thema gearbeitet. Leider ohne Erfolg. Ich habe Shopware Version 5.1.3, DHL Integration Plugin 1.1.19.

  1. Label wird nicht gedruckt

Im Backend kann ich Sendungen an DHL übertragen, aber nicht drucken. Eine Sendungsnummer wird erstellt. Ich markiere die Bestellung, klicke auf “Ausgewählte Labels drucken”, die Sanduhr erscheint und dann passiert nichts mehr. In Intraship kann ich das Label problemlos ausdrucken. Pop-up Blocker sind deaktiviert, im DHL Geschäftskundenportal stehen die Druckeinstellungen auf PDF und Common Label, welches das übliche A5 Label ist. Ich habe Firefox, Internet Explorer und Chrome probiert. Nichts funktioniert.

  1. Packstation und Postfiliale nicht auswählbar

Im Frontend werden im Checkout keine Auswahlmöglichkeiten für Packstation und Postfiliale angezeigt. Die durch das Plugin neu generierte Versandart DHL Versand ist aktiviert, meine alten bisherigen Versandarten sind deaktiviert.

Wer teilt mit mir sein Wissen und kann helfen?

Beste Grüße,
Caroline

@dreitags schrieb:

Hallo zusammen,

ich versuche die Postnummer in den Transaktionsmails auszugeben, weiß jemand wie das geht?

Es geht mir nicht um sORDER, sondern die Status-Updates.

{$sOrder.attributes.swag_dhl_address->postNumber}

funktioniert schonmal nicht.

Ich stehe aktuell vor dem gleichen Problem. Ein Kunde meinte, dass ohne die Postnummer das Paket nicht an der Packstation ankommen wird. Zuerst dachte ich, was der von mir will, weil auf dem Etikett die Postnummer ist, nur in der Versandbestätigung ist die Adresse der Packstation ohne Postnummer hinterlegt. 

Jetzt würde mich auch das korrekte Attribut interessieren, damit ich die Postnummer auch in den Bestellstatus-Mails unterbringen kann.

Danke. 

Hallo,

seit ein paar Tagen haben wir das gleiche Problem wie GCIbrandlab.

Kunde legt Artikel in den Warenkorb > geht zur Kasse > meldet sich mit seinem oder neuen Daten an > wählt seine Zahlungsart aus und die entsprechende Postfiliale/Packstation > bei Klick auf WEITER bleibt er hängen und erhält dann folgende Meldung sobald er zurück zur Startseite geht und beliebigen Link anklickt:

Fatal error: Cannot use object of type stdClass as array in xxxxxx/engine/Shopware/Plugins/Community/Frontend/BestitAmazonPaymentsAdvanced/Classes/Config.php on line 1453
503 Service Unavailable

Danach hilft nur das Browserfenster schliessen oder die Cookies zu löschen.

Im Firebug wird folgendes hierzu ausgeworfen wenn man auf WEITER klickt:

“NetworkError: 503 Service Temporarily Unavailable - https://www.teestop.de/dhl/saveShipping

 

Welches Zahlungsmittel spielt dabei keine Rolle. Deaktivieren wir Postfiliale und Packstation und gehen über Standard DHL Versand funktioniert alles.

Besten Dank vorab!

Stefan

@teestop schrieb:

Hallo,

seit ein paar Tagen haben wir das gleiche Problem wie GCIbrandlab.

Kunde legt Artikel in den Warenkorb > geht zur Kasse > meldet sich mit seinem oder neuen Daten an > wählt seine Zahlungsart aus und die entsprechende Postfiliale/Packstation > bei Klick auf WEITER bleibt er hängen und erhält dann folgende Meldung sobald er zurück zur Startseite geht und beliebigen Link anklickt:

Fatal error: Cannot use object of type stdClass as array in xxxxxx/engine/Shopware/Plugins/Community/Frontend/BestitAmazonPaymentsAdvanced/Classes/Config.php on line 1453
503 Service Unavailable

Danach hilft nur das Browserfenster schliessen oder die Cookies zu löschen.

Im Firebug wird folgendes hierzu ausgeworfen wenn man auf WEITER klickt:

“NetworkError: 503 Service Temporarily Unavailable - https://www.teestop.de/dhl/saveShipping

 

Welches Zahlungsmittel spielt dabei keine Rolle. Deaktivieren wir Postfiliale und Packstation und gehen über Standard DHL Versand funktioniert alles.

Besten Dank vorab!

Stefan

Das Packstation oder Postfiliale im Zusammenhang mit dem Amazon-Plugin Probleme macht hatte ich vor einiger Zeit schon gelesen, weiß aber nicht ob es sich mit den Updates gebessert hat.

Ich denke aber das eher das Amazon-Plugin mit den Feldern der Packstation und der Postfiliale nichts anfangen kann.

Uwe

Ich habe schon alle Plugins für Zahlungsmöglichkeiten deaktiviert/ deinstalliert und nur auf Vorkasse umgestellt, aber der Fehler tritt auch hier wieder auf. Testhalber auch auf einen anderen Webserver installiert mit gleichem Ergebnis.

Gruss

Stefan

@teestop schrieb:

Ich habe schon alle Plugins für Zahlungsmöglichkeiten deaktiviert/ deinstalliert und nur auf Vorkasse umgestellt, aber der Fehler tritt auch hier wieder auf. Testhalber auch auf einen anderen Webserver installiert mit gleichem Ergebnis.

Gruss

Stefan

Ich hatte das nur geschrieben das du in deinem Post  den Fehler angegeben hattest.

Fatal error: Cannot use object of type stdClass as array in xxxxxx/engine/Shopware/Plugins/Community/Frontend/BestitAmazonPaymentsAdvanced/Classes/Config.php on line 1453
503 Service Unavailable

und das ist ja nur eindeutig das Amazon-Plugin 

@useg schrieb:

@teestop schrieb:

Ich habe schon alle Plugins für Zahlungsmöglichkeiten deaktiviert/ deinstalliert und nur auf Vorkasse umgestellt, aber der Fehler tritt auch hier wieder auf. Testhalber auch auf einen anderen Webserver installiert mit gleichem Ergebnis.

Gruss

Stefan

Ich hatte das nur geschrieben das du in deinem Post  den Fehler angegeben hattest.

Fatal error: Cannot use object of type stdClass as array in xxxxxx/engine/Shopware/Plugins/Community/Frontend/BestitAmazonPaymentsAdvanced/Classes/Config.php on line 1453
503 Service Unavailable

und das ist ja nur eindeutig das Amazon-Plugin 

 

Das ist richtig, aber auch wenn Amazon - Plugin deaktiviert und deinstalliert ist erscheint eine ähnliche Meldung nur eben mit paypal oder sofortüberweisung. Der Pfad ist dann der des entsprechenden Zahlungsmittels.

Auch wenn alle Zahlungsoptionen (PayPal, Amazon, Sofort) deaktiviert und deinstalliert sind, nur noch Vorkasse möglich ist, hängt sich das ganze auf und die Meldung im Firebug gibt wie oben beschrieben die Meldung 503 zurück. Schalte ich Packstation und Postfiliale im DHL Plugin ab funktioniert alles.

 

@teeshop‍,

ich habe es jetzt noch mal bei mir probiert und auch ich habe das gleiche Problem

POST https://www.meine Url.de/dhl/saveShipping 503 (Service Unavailable)

Ich kann  icht mal sagen ab wann es so ist, man prüft ja nicht ständig den kompletten Shop wenn mal ein Update kommt und in der Log steht auch nichts.

Gibt es denn gar keine Plugins die ohne Ärger funktionieren.  Thumb-down

Wäre ich mal bei modified geblieben. Wearing-Sunglasses

Alle die das Plugin nutzen sollten mal schauen ob es noch funktioniert.

In Checkout Versandart zur Postfiliale oder Packstation auswählen und auf weiter klicken, dann passiert nicht außer in den Dev-Tools ein 503 Fehler.

Drücke ich dann auf F5 kommt die Meldung.

Fatal error : Cannot use object of type stdClass as array in  /www/htdocs/abcdefg/mein-Order/engine/Shopware/Plugins/Community/Frontend/SofortPayment/Bootstrap.php  on line  207
503 Service Unavailable

Hatte bei Zahlart Paypal ausgewählt.
Shopware 5.1.5
DHL-Plugin 1.1.19

 

Uwe

 

@useg schrieb:

@teeshop‍,

ich habe es jetzt noch mal bei mir probiert und auch ich habe das gleiche Problem

POST https://www.meine Url.de/dhl/saveShipping 503 (Service Unavailable)

Ich kann  icht mal sagen ab wann es so ist, man prüft ja nicht ständig den kompletten Shop wenn mal ein Update kommt und in der Log steht auch nichts.

Gibt es denn gar keine Plugins die ohne Ärger funktionieren.  Thumb-down

Wäre ich mal bei modified geblieben. Wearing-Sunglasses

Alle die das Plugin nutzen sollten mal schauen ob es noch funktioniert.

In Checkout Versandart zur Postfiliale oder Packstation auswählen und auf weiter klicken, dann passiert nicht außer in den Dev-Tools ein 503 Fehler.

Drücke ich dann auf F5 kommt die Meldung.

Fatal error : Cannot use object of type stdClass as array in  /www/htdocs/abcdefg/mein-Order/engine/Shopware/Plugins/Community/Frontend/SofortPayment/Bootstrap.php  on line  207
503 Service Unavailable

Hatte bei Zahlart Paypal ausgewählt.
Shopware 5.1.5
DHL-Plugin 1.1.19

 

Uwe

 

Hallo Uwe,

gibt es bei dir schon neue Erkenntnisse warum das DHL Plugin diesen Fehler auswirft? Allen Anschein nach sind wir die einzigen die diesen Fehler erhalten.

Gruss

Stefan

@teestop‍,

ich glaube nicht das wir die einzigen sind, die meisten lesen nur das Forum oder kommen her, wenn Sie selbst einen Fehler feststellen und eine Antwort brauchen.

Da ich hier fast jeden Eintrag lese finde ich auch Sachen, die ich selbst bei mir noch nicht festgestellt habe und beim Nachstellen bemerke, das auch bei mir der Fehler so auftritt.

Ich finde es auch nicht so professionell gelöst, denn das ganze müsste schon bei der abweichenden Lieferadresse zu finden sein und nicht da wo es jetzt eingebunden ist,

Durch die ganzen Scripte, die sich gegenseitig in die Quere können sind Fehler von vornherein nicht auszuschließen, da jeder Plugin Entwickler nur sein Plugin prüft und nicht das zusammenspiel mit vielen anderen die auf der gleichen Seite eingebunden sind, kann er ja auch nicht. Shopware ist eben ein echtes Script-Monster. Frown

Theoretisch müsste ein Ticket erstellt werden in dem der Fehler angezeigt wird, lässt sich das dann aber von Entwickler nicht nachstellen, da vielleicht ein anderer Script eines anderen Plugin dazwischenfunkt, wird das Ticket geschlossen.
​Zum Schluss bleibt nur die Möglichkeit das Plugin nicht zu nutzen oder einige Funktionen der Plugins abzustellen.

Uwe

 

 

@Michael Telgmann schrieb:

Hallo bikerstock,

wir haben das mit DHL so vereinbart, dass sie vom Plugin die Rechnungssumme bekommen und dann die 2€ selbst dazurechnen, da sie diese 2€ ja eh einbehalten. So bekommt man genau den Rechnungsbetrag zurück und hat nichts mit den 2€ zu tun. Für die Kunden sollte dann ein Hinweis bei der Zahlungsart „Nachnahme“ reichen, dass der Postbote 2€ mehr einkassiert, als der eigentliche Rechnungsbetrag ist. (zzgl. 2,00 Euro Nachnahmegebühren).
Am einfachsten wäre es also für dich, deine Zahlungsart anzupassen, so dass du die 2€ nicht berechnest.
Ansonsten müsstest du eine kleine Code-Änderung vornehmen. Es müsste reichen in der Datei \SwagDhl\Controllers\Backend\Dhl.php die Methode getOrdersAction() Zeile
89 zu ändern.

$data[$key][‚invoiceAmount‘] = $order[‚invoiceAmount‘] - 2;

Der Rechnungsbetrag, der an DHL geschickt wird, wird einfach um 2 verringert. Darauf natürlich keine Gewähr und auf eigenes Risiko! :wink:

Die Antwort ist zwei Jahre alt. Inzwischen gibt es das neue Geschäftskundenportal, bei dem, nicht wie bei Intraship üblich, die 2,-€ von DHL automatisch aufgeschlagen werden. Ist das noch keinem aufgefallen, dass er bei Verwendung der Shopware DHL-Integration jedesmal 2,-€ zu wenig von DHL überweisen bekommt oder ist es nur bei mir so, dass die 2,-€ nicht automatisch aufgeschlagen werden und auch so (Rechnungsbetrag inkl. 2,-€ Aufschlag) auf dem DHL-Etikett stehen?

Schon einer getestet, ob das DHL Plugin auf SW 5.2 läuft?

Das würde mich auch interessieren. Bis jetzt gab es zumindest noch kein Update von Showpare dazu

dito

Hallo zusammen,

die DHL Integration ist (noch) nicht mit Shopware 5.2 kompatibel. 

Viele Grüße aus Schöppingen

cool Michael Telgmann