PayPal Sofortige Zahlungsbestätigung schlägt fehl seit Update

Seit dem Update auf Shopware 5.2.2 und gleichzeitig PayPal-Plugin 3.4.0 schlägt die automatische Zahlungsbestätigung (IPN) seitens PayPal fehl, im PayPal-Konto sammeln sich die Fehlermeldungen diesbezüglich an.

Hat noch jemand außer mir dieses Problem und/oder weiß, woran es liegen kann? Im Logfile sind keine Fehler verzeichnet und im Access-Log sieht man, dass regelmäßige Abfragen auf die Bestätigungs-URLs mittels HTTP POST mit einem HTTP 200 Statuscode beantwortet wurden. Die Webserver-Responnse kann ich leider nicht im Log sehen:

xxx.xxx.xxx.xxx - - [19/Jul/2016:10:57:01 +0200] “POST /payment_paypal/notify?session-1=1e5ffddfdfdnqegf2uksdfyffosfd7805isi0ev906&__shop=1 HTTP/1.1” 200 4657 “-” “PayPal IPN ( https://www.paypal.com/ipn )” shop.smarticular.net (https://shop.smarticular.net)

Danke für eure Hilfe!

Bei uns ist es das selbe Problem. Ich bekomme seit dem Update regelmäßig Emails, dass ich diese URL updaten soll. Ich habe bei PayPal nachgeschaut und die sofortige Zahlungsbestätigung ist und war deaktiviert.

Weiß jemand Rat?

So sieht die Email aus von Paypal (ich die Buchstabenzahlenkombi ausgeixt):

Bitte überprüfen Sie den Server, der für sofortige Zahlungsbestätigungen von PayPal zuständig ist. Sofortige Zahlungsbestätigungen an den/die folgende(n) URL(s) sind fehlgeschlagen:

https://www.shabby-world.de/payment_paypal/notify?session-1=xxxxxx__shop=1

https://www.shabby-world.de/payment_paypal/notify?session-1= xxxxxx __shop=1

https://www.shabby-world.de/payment_paypal/notify?session-1= xxxxxx __shop=1

https://www.shabby-world.de/payment_paypal/notify?session-1= xxxxxx __shop=1

https://www.shabby-world.de/payment_paypal/notify?session-1= xxxxxx __shop=1

https://www.shabby-world.de/payment_paypal/notify?session-1= xxxxxx __shop=1

Wenn Sie diese URL nicht erkennen, nutzen Sie vielleicht einen Serviceprovider, der die sofortige Zahlungsbestätigung in Ihrem Namen verwendet. Bitte wenden Sie sich mit den oben genannten Informationen an Ihren Serviceprovider. Wenn dieses Problem weiterhin besteht, könnten die sofortigen Zahlungsbestätigungen für Ihr Konto deaktiviert werden.

@shabby schrieb:

Bei uns ist es das selbe Problem. Ich habe bei PayPal nachgeschaut und die sofortige Zahlungsbestätigung ist deaktiviert. Ich würde somit auf einen Fehler im PayPal Plugin tippen…

Weiß jemand Rat?

Soweit ich weiß, überschreibt das Plugin beim API-Call die im PayPal-Account hinterlegten Standardeinstellungen. Leider habe ich auch keinen Weg gefunden, die IPN in den Plugin-Settings zu deaktivieren.

Viel lieber wäre mir jedoch, wenn die IPN wie vor dem Update funktioniert! Lesen hier @Shopware Entwickler mit und können den Fehler reproduzieren? 

Ich habe vielleicht die Lösung gefunden. Es könnte sein, wenn sich ein Subshop im System befindet, bei uns der Point of sale, der die Position 1 hat (shop=1) sollten dort die PayPal Daten gelöscht werden. Ich schaue nun mal, ob ich morgen immer noch eine Mail bekomme…

@shabby schrieb:

Ich habe vielleicht die Lösung gefunden. Es könnte sein, wenn sich ein Subshop im System befindet, bei uns der Point of sale, der die Position 1 hat (shop=1) sollten dort die PayPal Daten gelöscht werden. Ich schaue nun mal, ob ich morgen immer noch eine Mail bekomme…

Wir haben nur einen einzigen Shop und nur einen Satz PayPal-Daten :/ 

auch ich habe seit dem Update exakt das gleiche Problem.

Vor gut fünf Tagen bekam ich die ersten Mails von PayPal mit dieser Warnung “sofortige Zahlungsbestätigung fehlgeschlagen”.

Also habe ich das Plugin noch einmal sauber installiert. Leider ohne Erfolg.

Ich hatte schon die Befürchtung, dass es ein Einzelfall sei aber offenbar sind da doch mehrere von betroffen.

Mit PayPal habe ich schon gesprochen und denen das Problem detailliert geschildert.

hat jemand schon eine Lösung für das Problem? Bisher konnte mir PayPal leider noch nicht weiterhelfen.

Seit heute gibt es eine neue Shopware-Version (5.2.3). Hat die schon jemand installiert und geprüft, ob damit der Fehler vielleicht behoben ist? Laut Revision-History sieht es leider nicht danach aus.

Problem weiter ungelöst, Paypal sendet täglich Mails zu fehlgeschlagenen Bestätigungen. Wie meldet man einen solchen Fehler an den Shopware-Support?

Bei uns ist auch das selbe Problem. Auch nach Update auf 5.2.3. ändert sich nichts. Heute kam schon wieder eine Email von Paypal. Hier sollte seitens Shopware schnellstens gehandelt werden.

Oder hat jemand schon eine andere Lösung gefunden?

 

@mknap schrieb:

Seit heute gibt es eine neue Shopware-Version (5.2.3). Hat die schon jemand installiert und geprüft, ob damit der Fehler vielleicht behoben ist? Laut Revision-History sieht es leider nicht danach aus.

Problem weiter ungelöst, Paypal sendet täglich Mails zu fehlgeschlagenen Bestätigungen. Wie meldet man einen solchen Fehler an den Shopware-Support?

Fehler, Bugs oder Sicherheitslücken kannst du hier melden:

https://issues.shopware.com/

1 Like

Hallo zusammen,

die Problematik ist uns bekannt und wir sind gerade dabei zu analysieren, wie es zu diesen Fehlern kommen kann. Wir arbeiten mit Hochdruck daran, euch schnellstmöglichst eine Lösung bereit zustellen.

Viele Grüße aus Schöppingen

cool Michael Telgmann

1 Like

Hallo,

leider fehlt uns in diesem Zusammenhang noch die “Nachstellbarkeit”, was die Behebung des Verhaltens deutlich erschwert.

Um die Ursache möglichst schnell zu identifizieren, wäre es daher super, wenn ihr ein Auge auf die Paypal-Bestellungen haben könntet.
D.h. im Klartext: Wir müssen das Verhalten irgendwie nachstellen können - gibt es irgendwelche auffälligen Gemeinsamkeiten?

Könnt ihr folgende Punkte noch einmal verifizieren / bestätigen?

  • Das Verhalten tritt nur auf, wenn PayPal und PayPal PLUS gleichzeitig aktiviert sind?
  • Trotzdem sind nur Classic-Bestellungen betroffen (Also über das normale PayPal Modul, bspw. Paypal Express Bestellungen)
  • Das Verhalten wird erst ab Shopware 5.2.2 ausgelöst?

Gruß,
Patrick

Hi Shopware - Team,

bei uns tritt das bei allen Varianten auf:

Paypal, Paypal Express, Paypal Express Mobile

Wir benutzen nur das Standard Paypal-Modul (SwagPaymentPaypal).

Paypal schickt den Fehlerreport leider auch nicht sofort raus, sondern immer erst in der Nacht. So dass eine zeitnahe Fehleranalyse auch schwer fällt. Ichwerde daher mal unsere Logs im Auge behalten.

Hallo

also bei mir hat PayPal heute nach knapp 14 Tagen die letzte Mail versendet, dass die Funktion bei mir jetzt deaktiviert wurde.

Der PayPal Support ist auf das Problem noch garnicht eingegangen. 

Installiert habe ich nur das PayPal Plugin Version 3.4.0 ohne PayPal Plus.

Das ganze trat bei mir exakt nach dem 13.07.2016 auf als ich den Shop auf 5.2.2 gesetzt hatte. Auch ein Update auf 5.2.3 brachte keine Änderung.

@Patrick Stahl schrieb:

Hallo,

leider fehlt uns in diesem Zusammenhang noch die “Nachstellbarkeit”, was die Behebung des Verhaltens deutlich erschwert.

Um die Ursache möglichst schnell zu identifizieren, wäre es daher super, wenn ihr ein Auge auf die Paypal-Bestellungen haben könntet.
D.h. im Klartext: Wir müssen das Verhalten irgendwie nachstellen können - gibt es irgendwelche auffälligen Gemeinsamkeiten?

Könnt ihr folgende Punkte noch einmal verifizieren / bestätigen?

  • Das Verhalten tritt nur auf, wenn PayPal und PayPal PLUS gleichzeitig aktiviert sind?
  • Trotzdem sind nur Classic-Bestellungen betroffen (Also über das normale PayPal Modul, bspw. Paypal Express Bestellungen)
  • Das Verhalten wird erst ab Shopware 5.2.2 ausgelöst?

Gruß,
Patrick Shopware

WIe im ersten Post:

  • Fehler tritt auf seit dem Update auf Shopware 5.2.2 und gleichzeitigem PayPal-Plugin Update auf 3.4.0 (einzeln haben wir es leider nicht getestet)
  • PayPal Plus ist bei uns nicht installiert
  • Plugin-Einstellungen entsprechen dem Plugin-Standard (außer: Warenkorb wird bei uns nicht übertragen)

Ach, das ist ja interessant.
Haben alle Betroffenen kurz vorher auf Shopware 5.2.2 geupdatet?
Scheinbar scheint das Verhalten dann doch unabhängig von PP+ aufzutreten.

Können wir festhalten, dass das Problem also auch unabhängig vom Paypal 3.4.0 Update aufgetreten ist und ausschlaggebend scheinbar das Update auf 5.2.2 war?

Gruß,
Patrick Shopware

Hier der Error Log:

XXX.XXX.XXX.XXX - - [26/Jul/2016:08:13:18 +0200] "POST /payment_paypal/notify?session-1=XXXXXXXXXXXXXXXXXXX&__shop=1 HTTP/1.1" 503 12345 "-" "PayPal IPN ( https://www.paypal.com/ipn )"

Shopware gibt hier ein 503 Zurück.

1 Like

@tremonti schrieb:

Hier der Error Log:

XXX.XXX.XXX.XXX - - [26/Jul/2016:08:13:18 +0200] „POST /payment_paypal/notify?session-1=XXXXXXXXXXXXXXXXXXX&__shop=1 HTTP/1.1“ 503 12345 „-“ „PayPal IPN ( https://www.paypal.com/ipn )“

Shopware gibt hier ein 503 Zurück.

Hier gibt es keinen HTTP-Fehler, trotzdem beschwert sich Paypal. Die „Response“ scheint wohl nicht dem zu entsprechen, was erwartet wird:

xxx.xxx.xxx.xxx - - [27/Jul/2016:10:28:40 +0200] "POST /payment_paypal/notify?session-1=xxxxxxxxxxxxxxxxxxxxxxxx&__shop=1 HTTP/1.1" 200 4736 "-" "PayPal IPN ( https://www.paypal.com/ipn )" [unsere shop url]

 

1 Like

Wir konnten nun einen Fehler ausfindig machen, der zu 99% das genannte Verhalten verursacht.
Wir prüfen dieses Verhalten noch gemeinsam mit PayPal und werden dann, sofern erfolgreich verifiziert, noch heute ein Hotfix-Update herausbringen.

Vielen Dank für die Beteiligung, die Rückmeldungen haben uns hier tatsächlich enorm geholfen! Thumb-Up

Gruß,
Patrick Shopware

1 Like

Hallo zusammen,

wir haben soeben eine neue Version veröffentlicht. Über euer Feedback würden wir uns freuen.

Viele Grüße aus Schöppingen

cool Michael Telgmann

2 Likes