Paypal Express funktioniert nicht mehr nach 2.1.7 Update

Hallo, habe nach dem Update das ich am 22.12. ausgeführt habe keine Zahlungseingänge von Paypal Express Bestellungen mehr. Wenn ich im Backend Kunden->Zahlungen->Paypal aufrufe kommt folgende Fehlermeldung: Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘oa.swag_payal_express’ in ‘field list’ in Zend/Db/Statement/Pdo.php on line 234 Stack trace: #0 Zend/Db/Statement.php(300): Zend_Db_Statement_Pdo->_execute(Array) #1 Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array) #2 Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query(Object(Zend_Db_Select), Array) #3 Enlight/Components/Db/Adapter/Pdo/Mysql.php(75): Zend_Db_Adapter_Pdo_Abstract->query(Object(Zend_Db_Select), Array) #4 Zend/Db/Adapter/Abstract.php(736): Enlight_Components_Db_Adapter_Pdo_Mysql->query(Object(Zend_Db_Select), Array) #5 Shopware/Plugins/Default/Frontend/SwagPaymentPaypal/Controllers/Backend/PaymentPaypal.php(177): Zend_Db_Adapter_Abstract->fetchAll(Object(Zend_Db_Select)) #6 Enlight/Controller/Action.php(135): Shopware_Controllers_Backend_PaymentPaypal->getListAction() #7 Enlight/Controller/Dispatcher/Default.php(521): Enlight_Controller_Action->dispatch(‘getListAction’) #8 Enlight/Controller/Front.php(214): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #9 Shopware/Bootstrap.php(79): Enlight_Controller_Front->dispatch() #10 Enlight/Application.php(192): Shopware_Bootstrap->run() #11 shopware.php(74): Enlight_Application->run() #12 {main} Wenn ich eine Testbestellung mache kommt diese Fehlermeldung: SQLSTATE[42S22]: Column not found: 1054 Unknown column’swag_payal_express’ in ‘field list’ in Zend/Db/Statement/Pdo.php on line 234Stack trace:#0 Zend/Db/Statement.php(300): Zend_Db_Statement_Pdo->_execute(Array)#1 Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)#2 Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query('UPDATE s_o#3 Enlight/Components/Db/Adapter/Pdo/Mysql.php(75): Zend_Db_Adapter_Pdo_Abstract->que#4 Shopware/Plugins/Default/Frontend/SwagPaymentPaypal/Bootstrap.php(722): Enlight_Co#5 Enlight/Event/Handler/Plugin.php(149): Shopware_Plugins_Frontend_SwagPaymentPaypal#6 Enlight/Event/EventManager.php(239): Enlight_Event_Handler_Plugin->execute(Object(#7 Enlight/Hook/HookManager.php(177): Enlight_Event_EventManager->filter('sOrder::sSa#8 Shopware/Proxies/sOrderProxy.php(23): Enlight_Hook_HookManager->executeHooks(Objec#9 Shopware/Controllers/Frontend/Payment.php(119): Shopware_Proxies_sOrderProxy->sSav#10 Shopware/Plugins/Default/Frontend/SwagPaymentPaypal/Controllers/Frontend/PaymentP#11 Shopware/Plugins/Default/Frontend/SwagPaymentPaypal/Controllers/Frontend/PaymentP#12 Enlight/Controller/Action.php(135): Shopware_Controllers_Frontend_PaymentPaypal->#13 Enlight/Controller/Dispatcher/Default.php(521): Enlight_Controller_Action->dispat#14 Enlight/Controller/Front.php(214): Enlight_Controller_Dispatcher_Default->dispatc#15 Shopware/Bootstrap.php(79): Enlight_Controller_Front->dispatch()#16 Enlight/Application.php(192): Shopware_Bootstrap->run()#17 shopware.php(74): Enlight_Application->run()#18 {main} An was kann das liegen bzw. wie bekomme ich das wieder zum laufen. Bitte dringend um Hilfe!! MFG

Hallo, bei mir verschwindet der PayPal Express Button, wenn ich Amazon Payment aktiviere. Komplikationen zwischen den Plugine Amazaon Payment und PayPal gab es schon vor ein Paaar Monaten. Vielleicht bsteht ja hier der Zusammanhang auch bei deiner Fehlermeldung. Das ganze besteht bei mir auch erst seit Update auf PayPal 2.1.7 in SW 4.1.4.

Der Paypal Express button ist nach wie vor da, nicht verschwunden. Nur beim Abschluss der Zahlung kommt eben diese Fehlermeldung. Amazon Payments verwende ich nicht! Meine Version von Shopware ist allerdings 4.0.6, kann es damit zusammenhängen?? Grüße

Tut mit leid, aber da bin ich zu wenig im Bilde ob das an der SW Version hängt. In dem Fall vermute ich wäre ein Update hilfreich von Shopware. Mit SW 4.1.3 konnte ich PayPal garnicht installieren und das Update zu 4.1.4 löste diede Probleme … Eine komplexe Materie.

In 4.1.4 wurde Paypal überarbeitet. Würde erst mal auf die neuste Version updaten.

Hallo, läuft denn Paypal 2.1.7 auf 4.1.4 bei Euch??? Ich habe seit dem Update auf 4.1.4 mehrere Zahlungen per Paypal und keine Bestellungen im Shop. Sind auch nicht in abgebrochene Warenkörbe! Habe noch Version 2.1.6 Auch habe ich verschiedene Zahlungsbestätigungen von Paypal. Mal mit Artikelauflistung und Bestellnummer, mal ohne. Es kam auch eine Zahlungsbestätigung an, die einen Artikel auswies ohne Preis, ohne Stückzahl etc. Irgendwie ist der Wurm drin und ich trau mich gar nicht auf 2.1.7 zu gehen. :frowning:

Hi Artep, habe dir eine PN geschickt. Hoffe die ist angekommen!?! Hängt bei mir im Postausgang und nicht unter gesendet.

Moin, so, ich habe Rückmeldung von Kunden. Kauf über den Express-Button, Rückleitung zum Shop - alles ohne Fehlermedung. Leider kommt keine Bestellung rein, sowie Bestätigung fehlt. Zahlungsbestätigung von Paypal unvollständig, sowie keine Übergabe der Versandkosten!! Sehr schön! Gleiche Fehler, wie damals in 3.5. Normale Paypalzahlungen funktionieren einwandfrei. Also liegt das wieder was im Argen mit dem Express-Button. Momentan habe ich den Express-Button deaktiviert. Ein Update auf 2.1.7 möchte ich zwischen den Feiertagen nicht wagen, nachher erhalte ich auch eine Fehlermeldung und dann stehe ich da. Also abwarten bis zum neuen Jahr!

Halli hallo. Ich habe eine frisch aufgesetzte Shopware 4.1.4-Version (www.maloves.me sofern das hilfreich ist) und wollte natürlich Paypal als Zahlungmöglichkeit anbieten. Sobald ich das Paypal-Plugin (neueste Version) 2.1.7 aktiviere, kommt im Warenkorb folgende Meldung: Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. Unable to load template snippet ‚frontend/checkout/cart.tpl|frontend/plugins/compare/index.tpl|frontend/plugins/seo/index.tpl|frontend/payment_paypal/header.tpl‘ in Smarty/sysplugins/smarty_internal_templatebase.php on line 127 Stack trace: #0 Enlight/View/Default.php(273): Smarty_Internal_TemplateBase->fetch() #1 Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(212): Enlight_View_Default->render(Object(Enlight_Template_Default)) #2 Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(238): Enlight_Controller_Plugins_ViewRenderer_Bootstrap->renderTemplate(Object(Enlight_Template_Default)) #3 Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(136): Enlight_Controller_Plugins_ViewRenderer_Bootstrap->render() #4 [internal function]: Enlight_Controller_Plugins_ViewRenderer_Bootstrap->onPostDispatch(Object(Enlight_Event_EventArgs)) #5 Enlight/Event/Handler/Default.php(91): call_user_func(Array, Object(Enlight_Event_EventArgs)) #6 Enlight/Event/EventManager.php(165): Enlight_Event_Handler_Default->execute(Object(Enlight_Event_EventArgs)) #7 Enlight/Controller/Action.php(191): Enlight_Event_EventManager->notify(‚Enlight_Control…‘, Array) #8 Enlight/Controller/Dispatcher/Default.php(521): Enlight_Controller_Action->dispatch(‚cartAction‘) #9 Enlight/Controller/Front.php(214): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #10 Shopware/Components/HttpCache/HttpKernel.php(79): Enlight_Controller_Front->dispatch() #11 Symfony/Component/HttpKernel/HttpCache/HttpCache.php(434): Shopware\Components\HttpCache\HttpKernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #12 Shopware/Components/HttpCache/AppCache.php(242): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #13 Symfony/Component/HttpKernel/HttpCache/HttpCache.php(403): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) #14 Symfony/Component/HttpKernel/HttpCache/HttpCache.php(303): Symfony\Component\HttpKernel\HttpCache\HttpCache->fetch(Object(Symfony\Component\HttpFoundation\Request), true) #15 Shopware/Components/HttpCache/AppCache.php(162): Symfony\Component\HttpKernel\HttpCache\HttpCache->lookup(Object(Symfony\Component\HttpFoundation\Request), true) #16 Symfony/Component/HttpKernel/HttpCache/HttpCache.php(192): Shopware\Components\HttpCache\AppCache->lookup(Object(Symfony\Component\HttpFoundation\Request), true) #17 Shopware/Components/HttpCache/AppCache.php(97): Symfony\Component\HttpKernel\HttpCache\HttpCache->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #18 Shopware/Bootstrap.php(70): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) #19 Enlight/Application.php(192): Shopware_Bootstrap->run() #20 shopware.php(83): Enlight_Application->run() #21 {main} Ich finde leider nirgends eine Lösung dafür… Erst wenn ich das Plugin wieder deinstalliere funktioniert der Warenkorb wieder. Leider nicht ganz Sinn der Sache. Hat da jemand eine Idee oder sogar eine Lösung? Vielen Dank schonmal.

bei uns werden keine Bestellbestätigungen mehr verschickt, wenn jemand mit PP Express bezahlt Plugin Version 2.1.7 Allerdings nutzen wir Shopware 4.1.2, und dieser Fred ist im 3.5.x Forum…

Moin, so, ich konnte mein Problem nun beheben. Hatte ja keinerlei Fehlermeldungen, aber trotzdem Kuddelmuddel. Und zwar war die alte URL für die Zahlungsbestätigung bei Paypal aktiviert, obwohl ich das deaktiviert hatte nach Update auf 4.0!! Wieso das wieder auf aktiv stand - keine Ahnung. Nachdem ist das deaktiviert habe, funktioniert der Express-Button und Zahlungsbestätigung kommt rein. Auch habe ich eine Rückzahlung gemacht übers Backend und es wurde keine neue Bestellung erstellt! Klappt nun auch! Vielleicht überprüft auch Ihr mal die Einstellungen bei Paypal!

1 Like

Hallöchen, es ist noch nicht zu Ende!!! Ich führe mein Problem mal hier weiter auf, anstatt einen neuen Post aufzumachen. Problem 1: Paypal 2.1.7 lässt sich nicht über den Pluginmanager updaten!! Hab alles versucht. Problem 2: Heute Paypalzahlungsbestätigung enthielt wieder nur die Hälfte der Angaben. Nachdem ich das bei den anderen Mails gescheckt habe, hat Paypal wohl ein Problem mit Umlauten. (Allerdings erst nach dem Update auf 4.1.4!! Es steht so ín der Mail: Farbkappenhalter 9 Löcher1Ç@HN Danach kommt nix mehr!! War bei den anderen Bestätigungen auch, dass nach dem Wort mit Umlaut nichts mehr angezeigt wurde. Seltsames Verhalten… :frowning:

Hi artep, ich kann kein Fehlverhalten mit Umlauten feststellen. Habe Shopware 4.1.4 sowie Paypal 2.1.7 zum Testen verwendet. Zu dem Paypal Update. Schau mal ob das Plugin eventuell doppelt vorhanden ist. Im Standard sollte dies unter: engine/Shopware/Plugins/Default/Frontend. Wenn das Plugin jedoch manuell über den Plugin Manager Installiert wird, wird unter /engine/Shopware/Plugins/Community/Frontend das Plugin angelegt. Solltest du das Plugin auch im Community Ordner haben, so entferne es dort bitte. Anschließend natürlich überprüfen ob noch alle Daten im Backend eingetragen sind :wink: Gruß Dennis

Hallo Dennis, ich habe das Plugin nicht manuell updaten wollen, es steht unter Updates im Pluginmanager bereit. Aber es geht nicht. Und ich habe es nicht doppelt. Es ist unter engine/Shopware/Plugins/Default/Frontend drin. Es muss sich doch updaten lassen, wenn es dort steht!!?? EDIT: Updateproblem gelöst! Es war mal wieder die fehlerhafte Cache-Datei .php im Verzeichnis cache/doctrine/attributes. Wo, bzw. durch welches Plugin die erzeugt wird weiss ich immer noch nicht.

Hallo, ich habe natürlich auch wieder mal Pech mit Paypal, nach dem Update auf neue Version berichten Kunden von massiven Problemen. Einer hat es geschafft mit viel vor und zurück eine Bestellung durch zu bekommen. Es wird aber keine Bestellbestätigung versand und wenn ich im Backend unter Kunden/Zahlungen/PayPal aufrufe kommt folgende Fehlermeldung. Hat jemand eine Idee was das bedeutet??? Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘oa.swag_payal_express’ in ‘field list’ in Zend/Db/Statement/Pdo.php on line 234 Stack trace: #0 Zend/Db/Statement.php(300): Zend_Db_Statement_Pdo->_execute(Array) #1 Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array) #2 Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query(Object(Zend_Db_Select), Array) #3 Enlight/Components/Db/Adapter/Pdo/Mysql.php(75): Zend_Db_Adapter_Pdo_Abstract->query(Object(Zend_Db_Select), Array) #4 Zend/Db/Adapter/Abstract.php(736): Enlight_Components_Db_Adapter_Pdo_Mysql->query(Object(Zend_Db_Select), Array) #5 Shopware/Plugins/Default/Frontend/SwagPaymentPaypal/Controllers/Backend/PaymentPaypal.php(177): Zend_Db_Adapter_Abstract->fetchAll(Object(Zend_Db_Select)) #6 Enlight/Controller/Action.php(148): Shopware_Controllers_Backend_PaymentPaypal->getListAction() #7 Enlight/Controller/Dispatcher/Default.php(521): Enlight_Controller_Action->dispatch(‘getListAction’) #8 Enlight/Controller/Front.php(214): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #9 Shopware/Components/HttpCache/HttpKernel.php(79): Enlight_Controller_Front->dispatch() #10 Symfony/Component/HttpKernel/HttpCache/HttpCache.php(434): Shopware\Components\HttpCache\HttpKernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #11 Shopware/Components/HttpCache/AppCache.php(242): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #12 Symfony/Component/HttpKernel/HttpCache/HttpCache.php(230): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) #13 Shopware/Components/HttpCache/AppCache.php(86): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true) #14 Shopware/Bootstrap.php(70): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) #15 Enlight/Application.php(192): Shopware_Bootstrap->run() #16 shopware.php(83): Enlight_Application->run() #17 {main} VG Roland

Hi, ja da fehlt ein Feld in der DB, so wie es aussieht. Einmal das Plugin deinstallieren, wieder installieren, Daten wieder ins Plugin eintragen und fertig. Dann sollte es wieder klappen

1 Like

[quote=„Sebastian Klöpper“]Hi, ja da fehlt ein Feld in der DB, so wie es aussieht. Einmal das Plugin deinstallieren, wieder installieren, Daten wieder ins Plugin eintragen und fertig. Dann sollte es wieder klappen[/quote] Besten Dank für die schnelle Hilfe, die Anzeige im Backend klappt jetzt. Ist der Fehler im Zahlvorgang auch behoben, der Kunde hat ü. Express versucht zu kaufen ist mehrmals vor und zurück bis es geklappt hat nun hab ich zwei Bestellungen und eine Bestätigung ist nicht an den Kunden versandt worden. Ich kann Paypal nicht mit meinem Zugang testen und das Verhalten nachstellen. VG Roland

Hatte da auch das Problem und konnte es durch ein Update beheben…

Hallo, nbei mir werden die Versandkosten nicht an Paypal übertragen wenn ich den Paypal Express Button verwende. Also zwar alle Daten aber nur die reinen Produktkosten. Weiter steht dann in den Fenster welches sich öffnet “Demo Shop” Habe doch überall den Shopnamen eingetragen. Viele Grüße Lene

Will mir niemand helfen ein update des Paypal plugins durchzuführen ? Die anbindung an den Plugin store klappt immer noch nicht, würde mich freuen wenn mir jemand die dateien hier online stellt damit ich es über FTP hochladen kann. Kunden können nicht über Paypal einkaufen. “Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. SQLSTATE[23000]: Integrity constraint violation: 1048 Column ‘encoder’ cannot be null in Zend/Db/Statement/Pdo.php on line 234 Stack trace: #0 Zend/Db/Statement.php(300): Zend_Db_Statement_Pdo->_execute(Array) #1 Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)” Am ende des Bestellvorgangs bei Paypal.