Keine WENN-Bedingungen im Flow-Builder der CE-Version?

Hallo zusammen,

ich würde gerne im Flow-Builder nach einer folgten Bestellung in einer WENN-Abfrage eine Aktion auslösen. Kann es sein, dass WENN-Abfragen prinzipiell in einer CE-Version nicht möglich sind?

Grüße
sunflower

Moin,
das glaube ich nicht, ich verwende es bei der Händlerregistrierung ohne Probleme mit der 6.4.20.2 CE

Habe den Flow nachgebaut.
Speichern war kein Problem, gehe ich dann in den Flow wieder rein, bekomme ich auch den Hinweis.

Dieser Flow verwendet Aktionen, die aufgrund einer Änderung der gebuchten Edition bzw. durch Deaktivierung oder Deinstallation der dazugehörigen Erweiterungen, nicht mehr verfügbar sind. Wenn dieser Flow ausgelöst wird, werden nicht verfügbare Aktionen nicht ausgeführt.

SW 6.5.3.1

Und warum kann ich denn dann zunächst so anlegen?

Wenn das vorher funktioniert hat, und nun nicht mehr, darf das ja nur ein Bug sein, denn nach Aussage Offizieller hier im Forum wird die CE ja nicht nachträglich kastriert.

Ich habe mal in einer 6.5.1.1 getestet. Da funktioniert der Flow noch… :see_no_evil:

Wenn das vorher funktioniert hat, und nun nicht mehr, darf das ja nur ein Bug sein, denn nach Aussage Offizieller hier im Forum wird die CE ja nicht nachträglich kastriert.

Nachdem was in den letzten Monaten im Shopware-Universum passiert ist glaube ich da gar nichts mehr.
Wie hat schon seinerzeit unsere Bundesbirne gesagt:

Was interessiert mich mein Geschwätz von Gestern!

1 Like

Das schaut ja so aus, als würden die aktuellen Pläne von Shopware keinen großen Mehrwert bieten, sodass man nun einige Dinge aus der CE streicht :smiley:

Den „Jetzt kostenpflichtig bestellen“ Button gibt es bald nur noch in der Beyond Edition :joy::rofl::sweat_smile::joy_cat:

1 Like

Ich habe mal im Slack-Channel nachgefragt, vielleicht bekomme ich da eine Antwort. Sieht jetzt meiner Ansicht nach eher nach einem Bug aus.

Gerade getestet, Flows funkionieren weiterhein (6.5.3.1). Habe einen Flow mit Bedingung erstellt (Ort = xyz bei der Anmeldung, Tag dem Kunden zuweisen). Passt alles.

Denke es handelt sich wirklich nur um einen Darstellungsfehler.

Ja, sieht mir auch nach einem Bug aus. Hat schon jemand eingetragen? Dann gern hier verlinken. Ansonsten mach ich das fix.

1 Like

@marco.steinhaeuser Das wäre prima wenn Du das erledigen könntest. Bin gerade unterwegs :red_car:.

Here we go Shopware Issuetracker

2 Likes

Super, Dankeschön. Wäre gut wenn nun viele voten würden :pray:

Ich denke ihr habt noch keine Neuigkeiten was ?

1 Like

Zwei (drei) Einträge weiter oben steht das Ticket zum Bug. Dort kannst du dich über den aktuellen Stand informieren.

Wir sind letzte Woche auch auf das Problem gestoßen. Die Meldung ist wirklich unschön, weil die impliziert, dass irgendwas nicht stimmt am Flow und nicht, dass die nur die computed-method zum Anzeigen der Fehlermeldung beim letzten Rewrite leider kaputt gegangen ist.
Unsere Lösung ist nun ein Plugin zu schreiben und dort die Methode zu überschreiben. Sollte dann später das bei der letzten Änderungen verloren gegangene filter() wieder ergänzt werden, werden wir uns Plugin wieder deaktivieren.

Ist nun irgendwie mal klar, wann dieser Bug jetzt genau gefixt wird?
Beim Issuetracker hat sich der Status bisher auch nicht mehr geändert.

Bei uns gibt es nach einem Update auf 6.5.6.0 auch das Problem, dass bei manchen Flows diese Meldung kommt (wie bei euch bei Bestellabschluss / Bestellung / Eingang) - nur leider mit dem Unterschied, dass die Fehlermeldung bei uns den Tatsachen entspricht, d.h. der Flow funktioniert tatsächlich nicht mehr. Im Issuetracker steht das Problem als „gelöst“ und hilft mir nicht weiter. Konntet ihr das Problem @sunflower schon lösen?
Liebe Grüße

1 Like

Ticket wurde am 24.10. geschlossen.
Der Commit dazu war vor ~ 2 Wochen:

Denke mal, das ist dann im November-Release enthalten ?!?

Danke für die schnelle Antwort. Ich bin technisch leider nicht so versiert, dass ich verstehe, welche Änderungen umgesetzt werden. Lt. Issuetracker wird das Problem ja folgendermaßen beschrieben:
Der Flow Builder zeigt beim Bearbeiten eines bestimmten Flows offenbar eine falsche Fehlermeldung an. Interessanterweise wird der ursprüngliche Flow ordnungsgemäß gespeichert, während die Fehlermeldung nur beim Bearbeiten des Flows angezeigt wird.

Bei uns ist es so, dass der Flow Bestellabschluss / Bestellung / Eingang + Wenn-Bedingung zwar gespeichert werden kann, aber nicht funktioniert (auch nicht, wenn er neu erstellt wird, ohne dass er nochmals bearbeitet wird). In der Praxis heißt das, wenn ein Kunde Vorkasse als Zahlungsart auswählt, erhält er keine E-Mail mit Bestellbestätigung und Überweisungsdaten…