Ioncube Loader, Wer hat denn jetzt recht? Shopware oder mein Provider?

Hallo liebe Gemeinde!

Habe einen Testshop angelegt damals in der Version 5.1.6 hat funktioniert. Nach einiger Zeit wieder gelöscht. Wieder Installiert usw.

Arbeite sonst mit einem anderen System. Aber das Frontend von Shopware würde mir besser gefallen. 

Aktuell habe ich jetzt 5.2.6 installiert und würde auch drittanbieter Plugins installieren wollen.

ABER SHOPWARE SYSTEM INFO ZEIGT: IonCube: Nicht installiert oder falsche Version (nur benötigt für verschlüsselte Drittanbieterplugins)

Also meinen Provider World4Youangeschrieben ob es möglich wäre eine Version 5.x zu bekommen.

Antwort:

Guten Tag, vielen Dank für Ihre Kontaktaufnahme mit unserem Kundenservice. Ich habe gesehen, dass Sie bereits den Ioncube Loader im Kundenbereich (my.world4you.com) unter Webspace->Einstellungen aktiviert haben. Herzliche Grüße

wieder geschrieben das ich doch eine Version höher 5.x benötige:

Guten Tag! Naja, aktuell verwenden Sie die Ioncube Loader Version 5.6. Das richtet sich nach der PHP Version.

In der PHP-Info steht:

PHP Version 5.6.25Zend Engine v2.6.0, Copyright © 1998-2016 Zend Technologies
    with the ionCube PHP Loader v4.7.4, Copyright © 2002-2014, by ionCube Ltd., and
    with Zend Guard Loader v3.3, Copyright © 1998-2014, by Zend Technologies
    with Zend OPcache v7.0.4-dev, Copyright © 1999-2015, by Zend Technologies
    with Suhosin v0.9.38, Copyright © 2007-2015, by SektionEins GmbH

Also wer hat den nun recht? 

lg aus dem sonnigen Oberösterreich

Stefan

Wenn die PHP-Info sagt 4.7.4 dann sollte das auch so stimmen. Daher: Hoster ist Schuld und muss die Version ändern (sofern du das nicht selbst ändern kannst)

1 Like

@t2oh4e schrieb:

Wenn die PHP-Info sagt 4.7.4 dann sollte das auch so stimmen. Daher: Hoster ist Schuld und muss die Version ändern (sofern du das nicht selbst ändern kannst)

Danke sehr!

Kann es nur Aktivieren aber es ist nicht ersichtlich welche Version.

Dachte ich mir auch dass mein netter Provider unter Stress steht und nicht wirklich Zeit hat meine Anfrage zu lesen. Da die Antworten immer kurz vor ablauf der 24 Stunden kam. Also warte ich jetzt wieder so 23 Stunden auf die nächste Antwort. LOOOOOOOOOOOOOOOOL

Hi,

die Versionsnummern von ionCube sind nicht identisch mit denen der PHP Version. Es kann durchaus sein, dass PHP 5.6 läuft - jedoch mit einer veralteten ionCube Loader Version. Aktuell ist ionCube verfügbar in Version 5.1.2 - siehe Loader Download - PHP Encoder, protection, installer and performance tools from ionCube

Dein Hoster muss also die ionCube Version aktualisieren, falls Du selbst keine andere auswählen kannst.

VG

1 Like

Sorry, aber es geht weiter:

World4you schreibt zurück:

 Guten Tag! In der php.ini wird folgendes geladen: zend\_extension = /usr/world4you/php/ioncube\_loader\_lin\_5.6.so sollte also passen. 

 

Dachte es gibt erst Version 5.1.2

 

Nach deinem Auszug aus “php -v”: 

PHP Version 5.6.25Zend Engine v2.6.0, Copyright © 1998-2016 Zend Technologies
    with the ionCube PHP Loader v4.7.4, Copyright © 2002-2014, by ionCube Ltd., and
    with Zend Guard Loader v3.3, Copyright © 1998-2014, by Zend Technologies
    with Zend OPcache v7.0.4-dev, Copyright © 1999-2015, by Zend Technologies
    with Suhosin v0.9.38, Copyright © 2007-2015, by SektionEins GmbH

Hier steht, dass deine PHP-Version: 5.6.25 (neueste) ist. Die Angegebene IONCube Version ist 4.7.4. Das würde nicht funktionieren. Weil die IonCube Nummer auch besagt für welche PHP-Version es ist. Wenn du PHP-Version 5.6.25 hast, brauchst du IonCube 5.6.so

1 Like

Hallo Stefano,

daraus geht nicht die ionCube Loader Version hervor. Die vorgenannte Datei bezieht sich nur auf die PHP Version (ioncube_loader_lin_5.6.so für PHP 5.6 eben).

Für die jeweilige PHP Version gibt es also entsprechende ionCube Loader Dateien (z.B. ioncube_loader_lin_5.5.so für PHP 5.5, ioncube_loader_lin_5.4.so für PHP 5.4 usw.).

Nur um welche ionCube Loader Version es sich handelt, geht daraus nicht hervor, kann jedoch mit php -v abgefragt werden (und ist wohl in Deinem Fall die alte 4.7.4).

VG

1 Like

Habe jetzt keine Email mehr geschrieben sondern beim Support angerufen.

Also es ist so: 

Die haben sehr grossen Stress, da Urlaubszeit. Deswegen werden Emails nicht richtig oder zu schnell gelesen. Und da kann es schon mal vorkommen das man die PHP Version mit der Ioncube Loader Version verwechselt.

Ich habe PHP Version 5.6 mit dem alten Ioncube Loader 4.7.4 

Der neue in der Version 5.x kommt irgendwann aber nicht in nächster Zeit. Also werde ich wieder die alte Version 5.1.6 von Shopware aufspielen.

Danke an die vielen netten und kompeten Antworten.

LIEBEN HERZLICHEN DANK!

Stefan

Ganz ehrlich: Such dir nen anderen Hoster.
“Der neue” IonCube-Loader 5.x ist schon über ein Jahr veröffentlicht. Und die Tatsache, dass es 3 Tage dauert bist du diese Information hast spricht auch nicht wirklich für den Hoster.

Edit: Ganz vergessen. Ist ja Montag heute. Vergesst die Kritik an den 3 Tagen.

1 Like

@t2oh4e schrieb:

Ganz ehrlich: Such dir nen anderen Hoster.
„Der neue“ IonCube-Loader 5.x ist schon über ein Jahr veröffentlicht. Und die Tatsache, dass es 3 Tage dauert bist du diese Information hast spricht auch nicht wirklich für den Hoster.

Edit: Ganz vergessen. Ist ja Montag heute. Vergesst die Kritik an den 3 Tagen.

Kritik an 3 Tagen ist schon berechtigt.

Meine erste Anfrage war am 31.8.  Hätte gleich anrufen sollen. Dachte mir aber es eilt ja nicht. Genau deswegen hasse ich Email Support. 

Ausserdem bekommt man auch heute nur das was man bezahlt. Geiz ist geil! 

Wenn ich mich entschieden habe welches Shopsystem ich verwenden werde, werde ich mich nach einem geeigneten Hoster umsehen.

Installation von IonCube dauert max 15min wenn man keine Kenntnisse in der Konsole hätte. Hast du Root-Rechte? Dann installiere es am besten selbst oder verzichtest auf Verschlüsselung.

Habe keine Rootrechte. Und auf dieVerschlüsselung kann ich nicht verzichten wegen der Plugins die ich gerne hätte. 

Du kannst auch bei den Pluginherstellern nachfragen ob sie dir diese Unverschlüsselt anbieten. Hab ich schon einige Male gehabt.

1 Like