Intelligente Suchfunktion - Fehlermeldung

Hallo zusammen, ich habe leider ein kleines Problem mit der „Intelligente Suchfunktion“… Zum einen funktioniert die erworbene Lizenz nicht und es gibt folgende Fehlermeldung: Fatal error: Uncaught exception 'Enlight\_Exception' with message 'License check for modul "sFUZZY" has failed' in /var/www/lampenstar.de/htdocs/public/store/engine/Shopware/Plugins/Default/Core/License/Bootstrap.php:115 Stack trace: #0 /var/www/lampenstar.de/htdocs/public/store/engine/Shopware/Plugins/Default/Core/License/Bootstrap.php(115): Shopware\_Plugins\_Core\_License\_Bootstrap::checkLicense() #1 /var/www/lampenstar.de/htdocs/public/store/engine/core/class/sSearch.php(56): Shopware\_Plugins\_Core\_License\_Bootstrap-\>checkLicense() #2 /var/www/lampenstar.de/htdocs/public/store/engine/core/class/sSearch.php(419): sSearch::checkLicense() #3 /var/www/lampenstar.de/htdocs/public/store/engine/Shopware/Controllers/Frontend/Search.php(119): sSearch-\>sStartSearch(Array) #4 /var/www/lampenstar.de/htdocs/public/store/engine/Enlight/Enlight/Controller/Action.php(70): Shopware\_Controllers\_Frontend\_Search-\>searchFuzzyAction() #5 /var/www/lampenstar.de/htdocs/public/store/engine/Enlight/Enlight/Controller/Dispatcher/DispatcherDefault.ph in /var/www/lampenstar.de/htdocs/public/store/engine/Shopware/Plugins/Default/Core/License/Bootstrap.php on line 115 Fatal error: Undefined class constant 'PRIMARY\_TYPE\_NUM' in /var/www/lampenstar.de/htdocs/public/store/engine/Enlight/Vendor/Zend/library/Zend/Session/SaveHandler/DbTable.php on line 522 Und zum andern funktioniert sie zwar mit einer testlizenz, läuft ABER sehr sehr langsam bis gar nicht… Was könnte das sein?

Hallo, sind die Datenbank Tabellen für die Suche auf innoDB? Falls die auf myisam stehen könnte das das Problem für die Geschwindigkeit sein. Wenn der Suchcache in der DB aufgebaut ist sollte die sehr fix Ergebnisse liefern. Zur Lizenz Welche Einstellungen hast du für Shophost und Installationpfad hinterlegt? Ist da ggf. Noch ein Slash am Ende oder evtl. Leerzeichen irgendwo enthalten? Vielleicht die Lizenzen im Account oder Backend auf Domain mit Groß- und Kleinschreibung ausgestellt? Die Meldung besagt klar, dass Lizenz nicht zur Domain passt! Eigentlich sollte bei korrekter Installation und Domaindefinition im Account kein Problem bzgl. der Lizenz auftreten können. PS: Bitte eingetragene Lizenz auch mal genau prüfen. Also das dort auch sFUZZY steht und nicht sFuzzy ( das passiert gerne mal :wink: ) Bitte auch mal auf Leerzeichen achten in den Lizenzfeldern… Sollte alles nicht helfen kannst du mir auch mal temporäre DB und Backenddaten zukommen lassen. Werde dann versuchen morgen mal reinzuschauen.

1 Like

hallo zusammen… danke sebastian wurde das Problem mit der Geschwindigkeit schon mal geregelt… es lag an der Datenbanktabelle - s_search_index und s_search_keywords müssen als innoDB laufen und waren als MyISAM angelegt. nur leider habe ich immer noch ein kleines Problem mit der Ausgabe: ich habe die Relevanz der Artikelnummer sehr hoch gesetzt, so das jemand auch den Artikel findet wenn er die Artikelnummer eingibt… nur leider zeigt die suche dann nur den genauen Treffer und irgendwelche anderen Artikel… als Beispiel: Artikel Suche: 201036 Artikelnummer im Shop: DL201036 Suchergebnisse: DL201036 + SLV111108 + SLV143714 + SLV152164 gewünschte Ergebnisse zb.: DL201036 + DL201037 + DL201034 + DL201033 (da diese ja ähnlich sind) kann da jemand helfen?

Keiner eine Idee? Auch nicht shopware? Z.zt. fahre ich auch noch mit der testlizenz… Was ist mit der gekauften?!?

hallo zusammen… leider funktionieren die “plugins” bei uns nicht so wie sie sollen :wtf: nach dem problem mit der “Intelligente Suchfunktion” kommt nun das problem mit dem einrichten des “subshops”… das plugin läuft soweit bis ich dem subshop ein anderes template als dem hauptshop zuweise!? Fehler Meldung: Fatal error: Uncaught exception 'SmartyException' with message 'Unable to load template extends 'frontend/listing/index.tpl|ListingPreview/index.tpl|frontend/plugins/titletag/index.tpl|frontend/plugins/greeting/index.tpl|frontend/plugins/express/index.tpl|frontend/plugins/google/index.tpl|frontend/plugins/supplier/index.tpl|frontend/plugins/advanced\_menu/index.tpl|frontend/plugins/paypal/index.tpl|frontend/plugins/compare/index.tpl|frontend/plugins/swag\_piwik/template/index.tpl|frontend/plugins/seo/index.tpl'' in /var/www/lampenstar.de/htdocs/public/store/engine/Enlight/Vendor/Smarty/libs/sysplugins/smarty\_internal\_template.php:174 Stack trace: #0 /var/www/lampenstar.de/htdocs/public/store/engine/Enlight/Vendor/Smarty/libs/sysplugins/smarty\_internal\_template.php(551): Smarty\_Internal\_Template-\>isExisting(true) #1 /var/www/lampenstar.de/htdocs/public/store/engine/Enlight/Vendor/Smarty/libs/Smarty.class.php(328): Smarty\_Internal\_Template-\>getRenderedTemplate() #2 /var/www/lampenstar.de/htdocs/public/store/engine/Enlight/Ven in /var/www/lampenstar.de/htdocs/public/store/engine/Enlight/Vendor/Smarty/libs/sysplugins/smarty\_internal\_template.php on line 174 Fatal error: Undefined class constant 'PRIMARY\_TYPE\_NUM' in /var/www/lampenstar.de/htdocs/public/store/engine/Enlight/Vendor/Zend/library/Zend/Session/SaveHandler/DbTable.php on line 522 hauptshop: http://www.lampenstar.de subshop: http://www.ledlabs.de kann da jemand helfen?

[quote=“lampenstar”][quote=“lampenstar”]hallo zusammen… leider funktionieren die “plugins” bei uns nicht so wie sie sollen :wtf: nach dem problem mit der “Intelligente Suchfunktion” kommt nun das problem mit dem einrichten des “subshops”… das plugin läuft soweit bis ich dem subshop ein anderes template als dem hauptshop zuweise!? Fehler Meldung: Fatal error: Uncaught exception 'SmartyException' with message 'Unable to load template extends 'frontend/listing/index.tpl|ListingPreview/index.tpl|frontend/plugins/titletag/index.tpl|frontend/plugins/greeting/index.tpl|frontend/plugins/express/index.tpl|frontend/plugins/google/index.tpl|frontend/plugins/supplier/index.tpl|frontend/plugins/advanced\_menu/index.tpl|frontend/plugins/paypal/index.tpl|frontend/plugins/compare/index.tpl|frontend/plugins/swag\_piwik/template/index.tpl|frontend/plugins/seo/index.tpl'' in /var/www/lampenstar.de/htdocs/public/store/engine/Enlight/Vendor/Smarty/libs/sysplugins/smarty\_internal\_template.php:174 Stack trace: #0 /var/www/lampenstar.de/htdocs/public/store/engine/Enlight/Vendor/Smarty/libs/sysplugins/smarty\_internal\_template.php(551): Smarty\_Internal\_Template-\>isExisting(true) #1 /var/www/lampenstar.de/htdocs/public/store/engine/Enlight/Vendor/Smarty/libs/Smarty.class.php(328): Smarty\_Internal\_Template-\>getRenderedTemplate() #2 /var/www/lampenstar.de/htdocs/public/store/engine/Enlight/Ven in /var/www/lampenstar.de/htdocs/public/store/engine/Enlight/Vendor/Smarty/libs/sysplugins/smarty\_internal\_template.php on line 174 Fatal error: Undefined class constant 'PRIMARY\_TYPE\_NUM' in /var/www/lampenstar.de/htdocs/public/store/engine/Enlight/Vendor/Zend/library/Zend/Session/SaveHandler/DbTable.php on line 522 hauptshop: http://www.lampenstar.de subshop: http://www.ledlabs.de kann da jemand helfen?[/quote] problem eingegrenzt! habe meinen “plugin” Ordner vom funktionierenden template ins neue template kopiert… anschließend lief es… also muss im “plugin” Ordner etwas sein was sich nicht OHNE realisieren lässt?! kann das jemand aus dem Fehler-code erkennen? Fatal error: Uncaught exception 'SmartyException' with message 'Unable to load template extends 'frontend/listing/index.tpl|ListingPreview/index.tpl|frontend/plugins/titletag/index.tpl|frontend/plugins/greeting/index.tpl|frontend/plugins/express/index.tpl|frontend/plugins/google/index.tpl|frontend/plugins/supplier/index.tpl|frontend/plugins/advanced\_menu/index.tpl|frontend/plugins/paypal/index.tpl|frontend/plugins/compare/index.tpl|frontend/plugins/swag\_piwik/template/index.tpl|frontend/plugins/seo/index.tpl'' in /var/www/lampenstar.de/htdocs/public/store/engine/Enlight/Vendor/Smarty/libs/sysplugins/smarty\_internal\_template.php:174 Stack trace: #0 /var/www/lampenstar.de/htdocs/public/store/engine/Enlight/Vendor/Smarty/libs/sysplugins/smarty\_internal\_template.php(551): Smarty\_Internal\_Template-\>isExisting(true) #1 /var/www/lampenstar.de/htdocs/public/store/engine/Enlight/Vendor/Smarty/libs/Smarty.class.php(328): Smarty\_Internal\_Template-\>getRenderedTemplate() #2 /var/www/lampenstar.de/htdocs/public/store/engine/Enlight/Ven in /var/www/lampenstar.de/htdocs/public/store/engine/Enlight/Vendor/Smarty/libs/sysplugins/smarty\_internal\_template.php on line 174 Fatal error: Undefined class constant 'PRIMARY\_TYPE\_NUM' in /var/www/lampenstar.de/htdocs/public/store/engine/Enlight/Vendor/Zend/library/Zend/Session/SaveHandler/DbTable.php on line 522[/quote] höchstwahrscheinlich lag es am plugin “Begrüßung im header” nach update - läufst.

nun kommt ein weiteres problem mit dem einrichten eines subshops: wo stelle ich den “shopnamen” für den subshop ein? hauptshop ist ja “Einstellungen” > “system” > “system” nur leider hat der subshop den selben Namen :-/ -> http://www.ledlabs.de (oder nur bei mir im cache?)