Installationsproblem bei 1und1 auf Shared Server

Hallo, Versuche schon seit Tagen die Software bei 1und1 zu aktivieren (Installation war ohne Fehler erfolgreich). Ich bekomme jedoch bei der Installation kein Aktivierungsfenster (Controller konnte nicht geladen werden). Habe alle Regeln wie im Forum beschrieben befolgt - manuelle Installation ZendOptimizer - php.ini in allen php-Ordnern kopiert zend_optimizer.optimization_level=15 zend_extension=/homepages/31/d406……/htdocs/Shopordner/loader/ZendOptimizer.so memory_limit=64M magic_quotes_gpc = off allow_url_fopen = on upload_max_filesize=10M - .htaccess RewriteEngine on RewriteBase / AddType x-mapp-php5 .php AddHandler x-mapp-php5 .php check.php = nur der bekannte Fehler = keine Lizenz Die Datenbank habe ich überprüft, auch hier sind die URLs richtig eingetragen. Ich hoffe es kann mir jemand helfen – ich bin zur Zeit ziemlich ratlos.

Hey, du könntest dir einmal die FireBug Extension für Firefox installieren und dann im Backend in der Konsole die Rückgabe der Backend-Scripte einsehen - also da wird sehr wahrscheinlich irgendeine Exception ausgelöst und diese Fehlermeldung sollte dir / uns sagen, wo das Problem liegt.

Hi Webworker, ich vermute die Zugangsdaten für die Datenbank im Backend ist bei dir nicht richtig hinterlegt. Information dazu, wie du richtig hinterlegts, findest du hier: http://www.shopware.de/wiki/Installatio … der_Socket Viele Grüße Heiner

Hallo Stefan Hamann und rocky, Vielen Dank für die schnelle Antwort. Habe alles ausprobiert: - FireBug löst keine Fehlermeldung aus – Scripteausführungen sind alle OK – kann nirgends eine Fehlermeldung im Backend erkennen. - Port in der Application.php ergänzt und Host direkt eingetragen (z.B. bei 1und1) = db7777.1und1.de - Daten in der config.php überprüft – alles ok. Das Resultat ist leider das gleiche - Controller kann nicht geladen werden!

Hi, wie sieht den bei dir die config.php aus? Der Host-Wert müsste bei dir in etwa so aussehen: $DB\_HOST = "db7777.1und1.de:XXXX"; Und in Application.php so: 'db' =\> array( 'username' =\> $DB\_USER, 'password' =\> $DB\_PASSWORD, 'dbname' =\> $DB\_DATABASE, 'host' =\> 'db7777.1und1.de', 'host' =\> 'XXXX' ), Es kann aber auch sein die Einträge in s_core_config-Tabelle nicht stimmen: Siehe: http://www.shopware.de/wiki/Installatio … ank_Import Hast du die schonmal überprüft? Überprüfen kannst du die Werte auch mit einem Script: http://www.shopware.de/wiki/SystemCheck … l_135.html Viele Grüße Heiner

Hallo, so sieht in etwa meine config.php aus: $DB_HOST = “db7777.1und1.de:3306”; $DB_USER = “dbo357774255”; $DB_PASSWORD = “XXXXXX”; $DB_DATABASE = “d777364255”; $DB_CONNECTOR = “mysql”; und so meine Application.php: ‘db’ => array( ‘username’ => $DB_USER, ‘password’ => $DB_PASSWORD, ‘dbname’ => $DB_DATABASE, ‘host’ => ‘db7777.1und1.de’, ‘port’ => ‘3306’ ), Die Einträge in der s_core_config-Tabelle sind auch korrekt und die check.php zeigt als einzige Fehler den fehlenden ionCube Loader (wird nicht benötigt da Zend Optimizer korrekt installiert ist). Ich kann nirgends einen Fehler erkennen?

Ich habe jetzt doch noch eine Fehleranzeige in der check.php gefunden: Benötigte Shop-Domain = www.12345.de Vorhandene Shop-Domain = www.12345.de Hier gibt es einen Status–Fehler obwohl beide identisch sind?

Das gleiche Problem hatten wir bei Strato auch. Eine Lösung habe ich allerdings nicht. Vielleicht kann ja einer was dazu sagen die über Strato den Shop installiert haben? Wenn es welche gibt?!

Hi, vieleicht hat sich bei dir nur ein Leerzeichen eingeschlichen? Kannst du mir kurz den Link zu deinem Shop schicken? Dann kann ich dir defenitiv sagen woran es liegt. :wink: Viele grüße Heiner

Hi, anscheined ist bei dir doch ein Leerzeichen in der Config. Laut Check.php ist im sHOST-Eintrage ein Zeilenumbruch drin: “www.1.______.de\r\n” Diesen musst du einfach entfernen und den Cache “/cache/database” leeren. Danach solltes du das Backend ohne Fehler aufrufen können. Viele Grüße Heiner

Hallo Heiner, in der Config ist leider kein Leerzeichen - ich kann wirklich nirgends ein Fehler erkennen. Darf ich Dir einmal die FTP-Zugangsdaten senden, damit Du es dir einmal anschauen kannst? Vielen Dank im Voraus!

Ja, kannst du machen. :wink:

Hi, ich konnte das Problem jetzt lösen. Es war zwar ein Leerzeichen in der sHOST-Config-Variable, das war aber nicht das Problem warum das Backend nicht funktionierte. Das Problem war das die Server-Variable „SERVER_NAME“ , die in 1und1-Webserver nicht richtig gesetzt wird. Und dadurch hat die CSRF-Überpürfung nicht richtig funktioniert. Ich konnte das Problem aber mit der folgenden Zeile in der config.php beheben: $\_SERVER['SERVER\_NAME'] = $\_SERVER['HTTP\_HOST']; Viele Grüße Heiner

1 Like

Hallo Heiner, er funktioniert tatsächlich – wirklich großes Lob an Dich – ohne Dich hätte ich die Sache aufgegeben müssen! Nochmals - vielen vielen Dank Kann es sein, dass Du eine andere Datei als die config.php meinst, in der config sehe ich keine Veränderungen!

Hi, hab die Änderung dort jetzt wieder eingebaut. Zum Testen hatte ich die Option “refererCheck” in der Application.php deaktiviert, dadurch konnte ich das Problem auch umgehen. :wink: Viele Grüße Heiner